Create New Year | Double-entry accounting

Documentation •
In this article

The Create New Year command prepares a file for the new year based on the accounting file that is being closed. The command does not modify the current file, so it can be executed without any effect.

Logics of the transition to the New Year

With Banana Accounting you have a separate file for each year. When the new year starts, the operational logic is as follows:

  • With the Actions → Create New Year command, the Program creates a new file for the year, using the same chart of accounts, settings and balances of the current year that is about to close.
    • Once the new year file is created, save it with a new name.
    • The operation of creating the new file can be repeated if you decide not to save the file.
  • You can work on both files at the same time:
    • In the new one, the transactions of the new year will be entered. It will also be possible to make changes to the chart of accounts, VAT or other, without affecting the previous one.
    • In the previous year's file, the operations will continue to be entered in order to complete the year and carry out the typical closing operations, verification of balances, printing of reports etc.
  • In the New Year's file, with the command Actions → Update Opening Balances, the changes that were made in the previous year's file are resumed. This operation should be done at the latest when there are no more changes in the previous year.

Once the New Year's file has been created, those who have subscribed to the Professional Plan of Banana Accounting Plus, will see the message Advanced Plan in demonstration mode. This message will appear in the Info window at the bottom of the screen and it will only disappear when reaching 70 transaction rows in the Transactions table.

Checking and closing previous year's accounts

Before updating opening balances, to avoid any differences between closing and opening balances for the following year, it is important to ensure that you have performed all checks, verification operations, and all closing accounting entries. Please refer to the page:

Operations performed by the Create new year command

The Create new year command performs automatically the following operations, taking into account the parameters set by the user:

  • Creates a new file (with no name) with the chart of accounts and all the settings identical to your current file, but without transactions.
  • Copies the data from the Balance column of your current file to the Opening column of the new file (only for the selected classes)
  • Adds the profit or loss of the previous year to the opening balance of the indicated Balance Sheet account or accounts for the breakdown (usually the Profit / Loss carried forward account is indicated).
  • Copies the data for all the Balance Sheet accounts from the Balance column of your current file to the Previous Year column of the new file.
  • Updates the File and accounting Properties:
    • Sets the start and end dates, adding 1 year to the existing ones.
    • In the Options section, sets the previous year's file name and enables the option to use the previous year's transactions for autocompletion.
  • In Multi-currency accounting, enters the closing exchange rates of the previous year as opening exchange rates.
  • If there are data in the Budget table, it carries over the operation rows in the new year taking into account the settings.
  • If the Segments option is activated, it creates opening transactions for the segments.

Create New Year dialog

The Create New Year dialog allows you to specify the parameters for creating the new year file:

create new year

Carry forward account opening balances

The opening balances of the selected options are carried forward

Balance Sheet
Carries forward the balances of active, passive and equity accounts. This option should generally be activated.

Profit and Loss statement (not recommended)
The balances of the expense and income accounts must NOT be carried forward to the new year.
This option is only used in special situations. Activate this option only if you are sure of what you are doing.

Off balance sheet
Reports accounts with BClass (5 and 6)

Cost centers
They must be activated if the cost centers are used to manage positions that must be continuous over time, such as customers, suppliers and partners.

Cost center CC1
Those starting with a dot ".".

Cost center CC2
Those starting with a comma ",".

Cost center CC3
Those starting with a semicolon ";".
For further information see the Cost / Profit Centers page.

Segments

The opening balances of the Segments are created with opening transactions in the Transactions table.

  • For further information see the Segments page.
  • The program creates a transaction for each account and segment matching, exactly resuming the final situation of the previous year.
  • It is recommended not to enter opening balances of the segments using the Opening column. If this was done in the previous year, the program will report the balance again in the New Year's Opening column.

Note: settlement operations such as the recognition and closure of transitional accounts, these must be entered manually.

Allocation profit/loss

When the opening balances are carried over into the new year, the profit carryover accounts are added to the figures shown.

Total to allocate
The program will automatically indicate the profit/loss amount that needs to be allocated. 

Accounts
Select the account or accounts (up to three) into which the operating result is to be divided. If there are several accounts for the allocation of the financial year result, the amount must be entered manually in the appropriate boxes.

If only one account is indicated, the amount will be automatically entered into the account selected from the list. The program automatically updates the opening balances. The total assets corresponds exactly to the total liabilities.

Allocation of the result of the accounting period on more than three accounts.
In this case, allocate the result of the accounting period automatically on the Profit or loss brought forward account as usual, and continue to proceed with the creation of the new year.
In the Transactions table of the new year (new file), perform a multiple posting to attribute the operating result from the Profit and loss account carried forward to the desired accounts.

Postponing the allocation of the profit or loss for the year
If you do not want to allocate the year's profit or loss yet, you can proceed to the creation of the new year anyway, by clicking on the OK button. Afterwards you can proceed to allocate the operating result from the menu Actions → Update opening balances. The program displays the same window that appears with the Create New Year command.

Save the new file

The program creates a new accounting file for the new year,:

  • Confirm the File and accounting properties for the new year. The program resumes the headings of the previous year and automatically enters the start and end date of the new year.
  • Via the File → Save as... command, indicate the folder where the new accounting file needs to be saved.
    We recommend that you enter the company name and year as the name.
    See also Organize accounting files

If there are differences or other error messages, you may also not save the created file and repeat the new year file creation operation later.

Update Opening Balances

After having entered the last modifications in the previous year, use the Actions → Update Opening balances command, to retrieve the opening balances and attribute the profit of the last year anew.

This operation can be repeated several times and can be carried out safely, as the integrity of the data during the changeover is guaranteed and there is no loss of information.

If you wish to switch to another type of accounting for the new year (with multi-currency or with VAT) proceed with the creation of the new file and then use the command Tools → Convert to new file.

If you want to create a copy of the file, without reporting the balances, use the command Tools → Create file copy.

Modifying balances carried forward

Once the balances have been carried over into the new year (new file), if there is a need to change the opening balances, they can be changed manually by changing the amounts in the following columns:

  • Opening column of the Accounts table.
  • Previous column, for balances relating to the previous year.
  • In the Transactions table for the Segments.

If you have made changes in the previous year's file, click on the menu Actions → Update Opening balances, to resume and update the opening balances again.

help_id
DlgDoppiaRiportaSaldi

Help us improve the documentation

We welcome feedback on how to improve this page.

Tell us what theme needs a better explanation or how to clarify a topic.

Share this article: Twitter | Facebook | LinkedIn | Email