Accounting with multiple languages

Documentation •
In this article

With Banana Accounting Plus, you can create accounting files in different languages, and present the Balance Sheet and Profit & Loss Statement in the language you need.
The available languages are: English, Italian, German, French, Spanish, Portuguese, Chinese, Dutch.

multilanguage software

The different languages

  • Program language
    The one used for the interface, menu dialogues, etc.
    You can change it from the Tools menu → Program options.
    See red box 1 and 3 in the image above.
  • Documentation in different languages
    You have a complete documentation in different languages, easily accessible by clicking on the help button.
  • Accounting file language
    When you create an accounting file, the columns are set in the creation language.
    See red box 2 in the image above.
  • The language of the column and table header
    You can change it at your convenience. For example, instead of using the term VAT, you can use the abbreviation that best suits your country's requirement.
  • The content in any language
    In the cells you can enter texts in any language.
  • Additional columns for other languages.
    You can add columns to have the Balance Sheet and the Profit & Loss Statement in different languages. You can create columns for other languages in the Transactions table and also in all other tables.
  • Views in different languages
    You can easily switch between different languages and just print the output in the desired language.
  • Balance Sheet and Profit & Loss Statement in different languages
    You can customize the printout, and just choose to show the required columns in the final reports.

How to change the file creation language

Each document on Banana Accounting Plus is a separate file. The language of the file is separate from that of the program and is defined when the file is created. (File menu → New).

Column names and headers are assigned at the time the file is created, the creation language is then used.

cambiare lingua file

To change the language of the file and columns, you need to re-create a new file:

  • From the Tools menu → Convert to new file command
  • In the open dialog box, select the file type equivalent to your existing file and click OK
  • In the next window choose the new language of the file and the type of rounding, then click OK

The program creates a new file identical to your previous one, with the new language settings. This new file must be saved with a new name.

Change the current language of the file

The current language is the one the program uses to display the wordings, such as "Opening balance" in the account card or the dates in the reports.
Normally, it will be the same as the creation language, but it may be changed in File properties → Other.

Change the column headings

You can change the column header with the Data menu → Columns setup.

Add columns for different languages

In the Accounts table and also in the other tables (Transactions, VAT codes), you can add additional columns where you can enter the descriptions in other languages.

  • From the Data menu →Tables setup → Add new column command
  • Use the name of the language (e.g. German, Chinese, etc.) as the column name.
  • In the newly created columns, for each row, complete the description in the language that has been added.

Create Views for each language

Create a view for each language to have printout only with the desired language.

  • Data menu → Tables setup command
  • Create a View for each language.
    In each table you can have different views for different languages, or the views that include columns of different languages.
  • Customize your printout in the language you require. If you want to print in different languages you can create one Customization print for each language so you don't have to change the settings each time, but have them already set up.

Enhanced Balance Sheet for each language

Once you've added the language column to the Accounts table, you can have it appear in the Enhanced Balance Sheet report as well.

The predefined texts of the report (date etc.) are displayed in the current accounting language. It may be necessary to change the current language from time to time.

Extensions

If you have specific needs in different languages, they can be programmed as Extensions.

 

Help us improve the documentation

We welcome feedback on how to improve this page.

Tell us what theme needs a better explanation or how to clarify a topic.

Share this article: Twitter | Facebook | LinkedIn | Email