Interface

When a new file is being created or an existing one is opened, the software presents a structure that is characterized by the following elements

The menubar

The menubar contains all commands grouped by menus. The menubar changes depending on the chosen accounting type.

Attention: in the Mac operating system, the Banana menu bar is located on the top of the screen, at the rightside of the apple logo:


 

The toolbar

The toolbar contains icons that allow you to access the most used commands and dialogs.
If you go over the icon with your mouse a command description will be displayed.


 

Text input area

Text are entered directly in the cell. The entered text is also shown in the text input area, right below the toolbar.

Editing a text

  • double click on the cell
  • press on the F2 key
  • pres the spacebar key (you will be able to edit an empty cell)

Short-cut keys for editing

  • If you press "." on a Date column, the software will enter today's date
  • If you press "." on a Hour column, the software will enter the current time (for example in a Time sheet management file)
  • when the Smart Fill option is activated, you select your choice with the combination Ctrl + arrow down keys - the software will accept your choice and move to the following cell

You can always view the short-cut keys list from the Help menu - Keyboard shortcuts command.

Suggestions and auto-complete function

If the Smart fill option is activated (Program Options command from the Tools menu), a drop-down menu will be shown with all the possible text choices: you can then select the chosen text in different ways:

  • press the Enter key - the program will accept your choice and move to the following cell on the right or below (depending on your settings)
  • press the Tab key - the program will accept your choice and move to the following cell on the right
  • press the Shift + Tab keys - the program will accept your choice and move to the following cell on the left
  • or the F6 key (or Cmd+6) - the program will accept your choice and execute the associate command (see below)

The program will suggest some choices (similar transactions, accounts or VAT codes) based on the entered text.
You must scroll with the arrow down key and select the appropriate choice.

The program will select for you:

  • Transactions starting with the same text (if any)
  • Elements containing the entered text anywhere. For example the account 1000 cash will be shown by the program as soon as you type 10 or just "cash".


Integrated calculator

If you need to execute a calculation, you can just go in any amount cell and enter your calculation: as soon as you press the Enter key the program will execute the calculation. This is a practical and time saving tool if for example you need to enter in the program only some amounts of a paper document or if you need to enter a percentage.

This feature is available in all tables and in all amount columns.

Integrated calculator


Execute command

Some columns are associated with certain actions that can be executed with the Execute command (from the Edit menu) or relative touch key, as indicated in the information window.

Some examples:

  • Doc column: recovery of recurring rows or progressive number
  • Description column: recovery of similar row data

The tables

Each accounting file has various tables. Some of them are main tables and others are optional. Tables vary depending on the chosen accounting type.


 

The views

The views are ways of showing the accounting data with specific columns. For each table there are different views and they are very useful when you want to show your data in different ways, without altering your basic settings.
Views are located right below the tables and can be personalized using the Tables setup command from the Data menu. You can also create new ones.


 

The columns

Columns are the table vertical elements. Each table has specific columns with specific heathers. The display, size, description, format, width, style, alignment can be edited thorough the Columns setup command from the Data menu.

Some columns contain data entered by the user, and some others can only be used by the program and cannot be edited by the user (for example the account cards columns).

Users can add new columns in order to include additional information (always with the Columns setup command from the Data menu), but the data entered will not be processed by the program.

A group of specific columns composes a view that displays only specific data.


 

The information window

This is a window located in the lower part of the screen, where the program displays useful information related to the active table and cell. Error messages are shown in red.


 

The Message dialog window

When an error occurs, the program displays the error in the Message window, indicating in which row of which table the error is located. It also shows a description of the error.

  • By clicking on the Help button you will be addressed of the online page where the error is explained, along with possible solutions.
  • All error messages reported by the program are saved in the Error Message window.

The Error Messages window

The Messages windows contains a list of the errors found by the program.
In order to read the messages click on the Messages tab.

  • From the Messages window, by double clicking on the error message, you will be taken to the row that generated the error.
  • If you click on the help symbol next to the error messageyou will be taken to our online documentation page where the error is explained, along with possible solutions

Table help

From version 9.0.4 of Banana Accounting 9, a help button has also been introduced in each table, on the top-right corner.
By clicking on the help button you will be automatically addressed to our online documentation page where that specific table is described.

Charts window

Graphs are integrated in the program: you can now generate graphs directly in Banana accounting. By selecting an account or group, it is possible to display a chart in the charts window at the bottom. The graph will allow you to instantly visualise the evolution of your situation, and even allow a comparison between your forecast and your actual figures.

Status bar

Status bar is located at the very bottom of the Banana Accounting window and contains the following information:

  • row number where the mouse is located
  • rows in the table
  • if you select more than one cell (amounts or time)
    • Calculator: the software will add the amount of the selected columns (if they contain numbers)
    • Value sum
  • Zoom - you can change the window zoom from here

 Date and numbers format by per default

Once the program is installed, it automatically uses as default your operating system settings.

If you wish to change your operating system settings, you should go in your Control Panel (Windows) or your System Preferences (Mac).

Here is the step by step process on Windows 8 and Windows 10:

  • from the Start menu, go to the Control Panel
  • click on International options and then on Change date, time or numbers format
  • a dialog window will appear where you can change your data format (in the Format tab)
  • in order to change your numbers or currency format, from the same window you can click on the Additional settings button and then on the Numbers or currency tab.

Here is the step by step process on Mac OS X 10.9.5:

  • from the Apple logo (on the top left of your screen) click on System Preferences
  • from the dialog window that appears choose the Date and time icon
  • a new window will appear where you can choose Open language and zone...
  • a new window will appear where you can click on the Advanced button
  • finally a new window will appear where you can change the numbers format (General tab), date or time format (Date and Time tabs)


Format and numbers in Banana Accounting

 

Help us improve the documentation

We welcome feedback on how to improve this page.

Tell us what theme needs a better explanation or how to clarify a topic.

Share this article: Twitter | Facebook | Email