Open, save, copy and backup

In this article

Opening a file

Data on the disk is loaded into memory, where it can be processed.

  • Accounting files can be opened in Banana Accounting if they are on the local computer or if they are accessible through a network.
    If they have been sent by email, you need to move them to a computer folder before opening.
  • Only one user at a time can edit a file
    If you edit a protected file or a file already in use by other users, you will need to save the file with different name in order to save your changes.
  • The Banana Accounting program, notifies you that you have opened a read-only file in the following cases:
    • the file is located on a non-writable disk (CD-ROM)
    • the file is located on a temporary non-writable folder
    • the file is protected or the user doesn't have rights to edit it
    • the file has already been opened by another user
    • the file has already been opened by the same user but in another session

How to look for *.ac2 files

If you don't remember in which directory your accounting files are located, you can use the search Windows Explorer or the Mac finder search tool.

Find your accounting file on a Windows computer

Banana Accounting files have an .ac2 or .sba extension. The Windows search tool will vary depending on your Windows version.

  • Windows 10: click on the search icon on the Applications bar and enter "ac2" or "sba" or your file name and click on the Documents arrow.
  • From the Explorer File Manager enter the "*.ac2" extension, the "*.sba" extension or your file name and let Windows look for it.
  • When in Banana you get to the Open file dialog window (File menu -> Open), enter the "*.ac2" or "*.sba" extension in the top right search box and then click on the look in the whole PC icon, or select the directory where you want Windows to look for your file.

Find your accounting file on a Mac computer

  • When in Banana you get to the Open file dialog window (File menu -> Open), enter "ac2" or "sba" or a word that is part of the file name in the top right search box. With the icons, select where you want to look for your file (in the entire computer or in selected folders).
  • Open the Finder and enter "ac2" or "sba"or a word belonging to the file name in the search box.
  • Right click on the Finder icon, then click on Search, and then enter "ac2" or "sba" or a word belonging to the file name.

 

Saving a file

 

With the Save or Save as... command, data is saved onto the hard disk. Pre-existing disk data are replaced with the new ones.

  • A single file can be saved by only one user at a time.
    The file can be saved by the user and only if it is not also being used by other users
  • Files can be saved anywhere.
    You can enter the file name and destination when saving it for the first time or when using the Save as command from the File menu
    As a first option, Banana Accounting will suggest the Documents folder as destination folder for the .ac2 files, but this can be changed with the Browse button.
  • If you are managing different accounting files, we suggest you create a separate folder for each company and for each accounting year.
  • Each file can be password protected.
     

Accounting files (*.ac2, *.sba)

  • Files created with Banana Accounting have an ".ac2" or ".sba" extension, regardless of the operating system being used.
  • The file with the extension "sba" is completely identical to ac2. The sba extension is used for the Dutch and Chinese version of the program. When referring to the file type "ac2" it also applies to the "sba" file type.
  • The .ac2 file format is specific for Banana. When saving, all data are compacted and saved in bulk.
  • Ac2 files are compatible between different operating systems (Windows, Mac and Linux)
    You can save a file with Windows, then open it and edit it on a Mac, and then reopen in it a Linux or Windows computer.
  • Each file can be sent as an email attachment, edited on different operating system and resent to the sender.
  • Accounting files are completely separated from the software Banana itself, that has an .exe extension for Windows,
  • The installation files for Mac have a .dmg extension and a .deb, .rmp .run or .tgz extension for Linux.


Autosave

Banana Accounting automatically creates and saves your work in a temporary file that ends with ".autosave" . When you save a file or you exit the program, this temporary file is deleted. In case your computer should crash or turn off in the middle of your work, it would be possible to recover your data by opening this file.

In order to have the program automatically create this temporary autosave file, the corresponding option should be active (it usually is by default) in the Program Options of the Tools menu.

When the program is reopened after a crash, it will check that the temporary autosave file was not deleted, a message appears, asking whether you want to retrieve the file. If the user confirms the recovery, the original file is renamed in the following format: < file_name.ac2 >. > date + time >. bak.
 

Help us improve the documentation

We welcome feedback on how to improve this page.

Tell us what theme needs a better explanation or how to clarify a topic.

Share this article: Twitter | Facebook | LinkedIn | Email