Edit Menu

In this article

The Edit menu contains a series of practical data editing commands.
Also see Keyboard shortcut.

Undo / Redo operation

These simple commands allow you to cancel or restore the last operation made. To set the maximum number of undo operations, you need to set it in the Tools menu → Program Options → Editor → Max number of Undo Operations.

Copy, Cut and Paste

All rows of Banana Accounting tables and the data they contain (except data in protected tables and cells) can be copied, cut and pasted exactly as in Excel.

  • Select the line or the area of data to be copied
  • In the Edit menu, select the Copy or Cut command
  • Move to the row or the area where the information should be copied
  • From the Edit menu, select Paste

The user can also copy/paste by using the icons copy and paste icons or press Ctrl+C to copy, Ctrl+X to cut and Ctrl+V to paste.
There are also the following commands:

  • Copy rows, Delete rows and Paste rows: in this case they refer to a full row or rows and not to a cell selection. For this purpose the commands Copy, Cut and Paste should not be used.
  • Copy rows copies the cells to the clipboard with the column header, very useful for filtering in Excel.

Select all

This command selects all the rows and columns of the active table.
It's the equivalent to clicking at the top left hand side of the table.

Copy row from above (F4 or Cmd + 4)

This command is very practical and allows you to copy the contents of the cell above to the one you are in. Applicable to a single cell, several cells or an entire row.

Execute command (F6 or Cmd + 6)

This command performs various practical functions depending on the cell in which you are located. More information on the Interface page.

Insert blank rows... (Ctrl and + key)

This command inserts blank rows above the selected row:

  • Position the cursor below the line where the empty rows are to be inserted
  • From the Edit menu, select the Insert rows command
  • In the window that appears, type the number of rows to be inserted
  • Confirm with OK.

Add rows...

To insert blank rows below the selected row, follow these steps:

  • Move the cursor above the row where additional rows need to be inserted
  • From the Edit menu, select the Add rows command
  • In the window that appears, key in the number of rows to insert
  • Confirm by clicking on OK

There is another procedure to add blank rows:

  • Move the cursor above the row where additional rows need to be inserted
  • Click on the following icon Add empty rows on the Tool bar, one time for each row that you want to add. This procedure is recommended when the amount of rows to be added is rather limited. The sequence for the shortcut key is: Ctrl+Enter.

Duplicate rows...

This command duplicates the selected row(s).

After duplication, the rows remain selected and can be moved with the Move Up and Move Down command.

Copy rows ... (Ctrl + Shift + C)

This command copies all row data, including non-visible columns, to a temporary space, so that they can be resumed with the command Insert copied rows

In addition, the command copies cell values to the clipboard/clipboard with the column header, which is very useful for filtering data in Excel or other programmes. If you have selected only a few cells, it copies the contents, but always with the corresponding column header.

The column header makes it easier to process data in Excel or with other programmes.

You can also make copies with the header with the Preview command.

Delete rows... (Ctrl and - key)

In order to delete one or more rows, select the row or rows that need to be deleted and from the Edit menu, click on the Delete rows command.

Rows are deleted are saved in the Copied Rows memory and can be reinserted with the Insert Copied Rows command.

Move up (Alt + arrow down) and Down (Alt + arrow down)

Moves the selected rows up and down one position.

Protect/Unprotect rows

Using the Protect rows command, from the Edit menu, the user activates rows protection to avoid making any changes by mistake.
Protected rows have light grey row numbers. The protected rows cannot be edited until, by using the Unprotect rows command, the protection is being removed.

To put protection into effect:

  • Select the desired row(s) to protect
  • From the Edit menu, select the Protect rows command
  • Confirm the number of rows to be protected by clicking on OK.

 

Help us improve the documentation

We welcome feedback on how to improve this page.

Tell us what theme needs a better explanation or how to clarify a topic.

Share this article: Twitter | Facebook | LinkedIn | Email