Link to a document

Documentation •
In this article

With Banana Plus, for each row and in any table, you can enter a link to a digital documents stored on your computer or on the Internet. So, say good-bye to paper and move to a completely digital accounting management. Also refer to Organize accounting files locally, online or in the cloud.

  • Create a folder where you will save all your digital documents. It can be the folder where you keep your accounting file, but we would recommend to create a subfolder.

    Example of how to organize the directories to save your digital documents
    Example of how to organize the directories to save your digital documents
     
  • Use this folder to save all files containing documents, invoices, receipts, etc.
  • Link the transaction with the digital document:
    • Via Data → Links → Add link. You can view the content of the digital document whenever you need it.
    • Directly write in the Link (DocLink) column: as soon as you start typing the document's name, the program will show all the matching files in the folder, that have not been yet used as links.

The Links Column

The DocLink column (in the Transactions table) and the Links column (in all other tables) make it possible to enter a link to an external file (usually a scan of a receipt or an invoice).

  • The Links column is usually not visible.
    In order to display it, use the Columns setup command from the Data menu.
  • Once the Links column is visible, you can edit the file name.
  • The file name is related to the accounting file: if the documents are in a sub-folder, the file name in the Links column will be preceded by the folder's name.
  • It is equally possible to manually enter a web address in the Links column. The connection must be preceded by the "https: //" or "http: //" indication.
  • In order to open the linked document, click Data → Links → Open link command, or click on the small square that appears on the upper right hand corner of the cell that contains the link.

    Open link icon

 

Entering a link to a file

There are three ways to enter a link to a document:

Add Link command

  • Place yourself on the row of the table where you wish to create a link and the choose the Data menu Links → Add link.
  • Select the document  file that you want to link and click on the Open button (the program inserts the link automatically). The program enters the path to the digital file in the Links column, even if the column is not visible.

Add Link Button

  • In the table, make the Links column visible. Also see: Columns setup.
  • Click on the small icon at the top right of the cell.

    Add link icon
     
  • Indicate the path where the chosen file is located.

Direct enter the file name into the cell

  • Double-click on cell to edit it .
  • Type in the file name or enter it using copy and paste.
  • The autocomplete feature shows you the document files, with this logic:
    • Provides a list of all files that are present:
      • In the accounting folder.
      • In other file folders that appear as links in other rows of the column.
        If you insert a link to a file in another folder, it will then list the files in that folder as well
    • The list of files is sorted alphabetically
    • Of these files, are only shown those that:
      • Have not already been included as links in other rows
      • If the text starts with "*", the program displays all files, even if they have already been used.
        In this way you can search for files, which have already been included in the list.
      • Contain in their name the text you are entering.
      • Do not exceed the number of files provided by the Smartfill limit.

Adding a link to a digital document

Editing a link

Proceed in the same way as when entering a new link.

Opening the link

There are two ways to open the link:

  • Position yourself on the row and follow the Data → Links → Open link command
  • Or position yourself on the cell of the Links column and click on the icon to open the link.

    Open link icon

For security reasons, the program only opens files with an extension that is considered secure, see Program Options Advanced, from the Tools menu.

Remove a link

There are two ways to delete a link:

  • Position yourself on the row and follow via the Data menu → Links → Remove link.
  • Clear the contents of the Links cell.

Help us improve the documentation

We welcome feedback on how to improve this page.

Tell us what theme needs a better explanation or how to clarify a topic.

Share this article: Twitter | Facebook | LinkedIn | Email