Ajouter des liens vers des documents numériques

Documentação •
Neste artigo

La fonction de liaison d'un document numérique, enregistré sur votre ordinateur ou sur Internet, à une ligne d'entrée vous permet d'ouvrir un reçu, une facture ou un autre document directement dans le fichier comptable d'un simple clic. Vos documents seront toujours à portée de main et vous pourrez dire adieu au papier et passer à une comptabilité entièrement numérique.
Voir aussi Organiser vos fichiers comptables localement, sur le réseau et dans le Cloud.

  • La fonction permettant de lier un document numérique à une ligne est disponible dans tous les tableaux, même dans le tableau Comptes, postes et autres.
  • A partir de l'aperçu avant impression, avec la fonction Exporter vers PDF, le programme vous permet également d'inclure les fichiers des documents numériques liés dans le PDF. Lors d'un audit, l'auditeur peut également ouvrir le document joint (facture, reçu, autre document PDF) dans le fichier comptable.

 

Ajoutez un lien vers vos documents numériques

Colonne Lien

La colonne DocLink du tableau Écritures et la colonne Lien (autres tableaux) permettent d'insérer un lien à un fichier externe (habituellement une numérisation d'un reçu ou d'une facture).

  • La colonne Lien n'est normalement pas visible.
    Pour l'afficher, utiliser la fonction Organiser colonnes.
  • Une fois affichée la colonne Lien, vous pouvez modifier le nom du fichier.
  • Le nom du fichier est relatif au dossier comptable.
    • Si les documents sont situés dans un sous-dossier, dans la colonne Lien, le nom du fichier doit être précédé du nom du dossier.  
    • Si vous copiez le contenu du dossier sur un autre ordinateur, les liens restent valables, sauf si les fichiers se trouvent dans le dossier copié ou contiennent des caractères tels que "*&%", qui ne sont pas transférables à d'autres systèmes d'exploitation.
  • Vous pouvez également saisir manuellement une adresse Internet dans la colonne Lien. Le lien doit être précédé de "https://" ou "http://".
  • Pour ouvrir le document lié, cliquez sur le menu Données > Liens > Ouvrir lien, ou cliquez sur la petite case qui apparaît dans le coin supérieur droit de la cellule contenant le lien.

    Bouton ouvrir lien
     

Insérer un lien à un fichier

Le lien peut être inséré de trois façons:

Commande Ajouter un lien

  • Accédez à la ligne du tableau et, dans le menu, cliquez sur Données > Liens > Ajouter lien.
  • Sélectionnez le fichier qui correspond au document à lier et cliquez sur le bouton Ouvrir (le programme insère automatiquement le lien). Le programme insère le chemin d'accès au fichier numérique dans la colonne Lien, même s'il n'est pas visible.
  • Le nom du fichier est relatif au fichier de la comptabilité.
    De cette façon, le lien sera valable même si vous déplacez le dossier comptable ou si vous l'utilisez sur le réseau ou sur un autre ordinateur par le biais d'un système de synchronisation.
    • Si le fichier se trouve dans le même dossier, seul le nom de fichier "invoice.pdf" apparaîtra.
    • Si le fichier se trouve dans le sous-dossier 'pièces jointes', il sera 'pièces jointes/facture.pdf'.

Bouton Ajouter un lien

  • Dans le tableau, rendez visible la colonne Lien. Voir : Organiser Colonnes
  • Cliquez sur la petite case en haut à droite de la cellule.

    Bouton ajouter lien
     
  • Indiquez le chemin où se trouve le fichier en le sélectionnant.

Insérer le nom du fichier directement dans la cellule

Le nom du fichier du document numérique peut être saisi directement dans la cellule de la colonne DocLink, sans avoir à sélectionner le fichier dans le dossier où il se trouve.

Ce mode permet d'accélérer encore le travail d'insertion.

  • Allez à l'édition dans la cellule en cliquant deux fois.
  • Tapez le nom du fichier ou entrez-le par copier-coller.
  • La fonction d'auto-complétion répertorie les fichiers des documents qui ne sont pas encore liés.
  • Pour obtenir une liste des fichiers disponibles, il faut au moins saisir le nom d'un fichier avec la boîte de dialogue de sélection des fichiers.
  • Parmi les fichiers contenus dans les dossiers, seuls les suivants sont affichés :
    • Fichiers apparaissant dans les dossiers de recherche.
    • Fichiers qui n'ont pas encore été repris comme liens dans d'autres lignes.
    • Si le texte commence par "*", le programme affiche tous les fichiers, même s'ils ont déjà été utilisés (s'ils appartiennent au dossier comptable ou à un sous-dossier). 
      Cela permet de rechercher des fichiers qui ont déjà été inclus dans la liste.
    • Les fichiers dont le nom contient le texte que vous êtes en train de saisir.
    • Les fichiers dont l'extension est considérée comme sûre.
    • Les fichiers qui ne dépassent pas le nombre de fichiers prévu par l'option limite de Smartfill.

Configuration des dossiers de recherche de documents

Lorsque vous insérez un lien vers un document et que celui-ci se trouve dans le dossier Comptes ou dans un sous-dossier, le dossier du document est automatiquement placé dans les dossiers de recherche de documents. Dans la liste proposée par l'auto-complétion, il y a des fichiers dans le même dossier qui n'ont pas encore été utilisés.

Avec des commandes spécifiques, à saisir dans la colonne Lien, vous pouvez indiquer de rechercher dans d'autres dossiers ou même d'exclure des dossiers spécifiques de la recherche.
Les commandes sont des noms de dossiers accompagnés d'un point d'exclamation ' !

  • !dossier1
    Recherche les fichiers uniquement dans le sous-dossier et non dans les dossiers de fichiers déjà inclus.
  • !+dossier1
    Le signe '+' ajoute le dossier aux dossiers de fichiers déjà utilisés ou déjà spécifiés avec include.
  • !-dossier1
    Il sert à exclure un dossier dont le fichier a été utilisé, mais qui n'est plus utilisé pour d'autres fichiers
  • Symboles spéciaux:
    • !.
      Le point '.' indique le dossier dans lequel se trouve le fichier de comptabilité.
      Pour exclure le dossier, utilisez "!-.".
    • !dossier1*
      "*" à la fin du nom du dossier signifie également que tous les sous-dossiers sont inclus.
      S'il y a beaucoup de sous-dossiers avec beaucoup de fichiers, la recherche peut être ralentie.
    • !*.
      Comprend le dossier dans lequel se trouve le fichier de comptabilité et tous les sous-dossiers.
    • !fichier1;fichier2
      le point-virgule ';' est utilisé pour insérer plusieurs dossiers.
    • !../fichier1
      Le "..." fait référence au dossier de niveau supérieur.

Les commandes permettant d'inclure ou d'exclure des dossiers :

  • Doivent être saisies dans la colonne où le lien vers le document est inséré.
  • Elles peuvent être insérées dans n'importe quelle ligne.
  • Elles déterminent la recherche pour toutes les cellules, même celles qui précèdent.

     

Lien à un document

Modifier le lien

Procéder comme pour l'insertion d'un nouveau lien

Renommer le lien

Cette fonction vous permet de modifier/renommer le lien. Le programme, en automatique, va également :

  • Renommer le nom du fichier dans son répertoire d'origine
  • Renommer tous les liens vers ce document récurrents dans le fichier comptable.

Vous pouvez ainsi modifier les noms de fichiers sans avoir à ouvrir le gestionnaire de fichiers.

Exigences

Plus d'informations sur la fonction Renommer.

Ouvrir lien

Il y a deux façons pour ouvrir un lien:

  • Se positionner sur la ligne et cliquer sur Données > Liens > Ajouter Lien.
  • Se positionner sur la colonne Lien et cliquer sur l'icône pour l'ouverture.

    Bouton ouvrir lien

Pour des raisons de sécurité, le programme ouvre seulement des fichiers avec une extension considérée sécurisée; voir Options programme > Gestion Fichier , du menu Outils.

Supprimer lien

Il y a deux façons pour supprimer un lien:

  • Se positionner sur la ligne et cliquer sur Données > Liens > Supprimer lien.
  • Supprimer le contenu de la cellule Lien avec le bouton supprimer.

Ressources utiles:

Help us improve the documentation

We welcome feedback on how to improve this page.

Tell us what theme needs a better explanation or how to clarify a topic.

Share this article: Twitter | Facebook | LinkedIn | Email