Datenübernahme aus anderen Programmen

Dokumentation •
In diesem Artikel

Einmalige Datenmigration mit Excel (One-Time-Importmodus)

Führen Sie Ihre Buchhaltung neu mit Banana und möchten Sie Ihre Daten aus einem anderen Buchhaltungssoftware übernehmen, raten wir Ihnen, dabei Excel zu benutzen. Excel erlaubt auf einfachste Art und Weise die Daten zu kopieren und einzufügen (Kopieren & Einfügen).

  1. Mit dem alten Buchhaltungsprogramm exportieren Sie die Daten in ein für Excel lesbares Format (CSV, txt, ...).
  2. Importieren Sie die Daten in Excel (siehe unten).
  3. Ordnen Sie in Excel die Daten (Spalten) so an, wie sie in der Tabelle Buchungen von Banana erscheinen.
    • Anstatt die Anordnung der Spalten zu ändern, kann es bequemer sein, zusätzliche Spalten neben den bereits vorhandenen hinzuzufügen und die Daten dorthin zu kopieren oder Formeln zu verwenden, die die Daten übernehmen und umwandeln.
      Mit Hilfe von Formeln können Sie Leerzeichen entfernen, Texte bearbeiten oder Beträge und Daten konvertieren.
  4. Öffnen Sie Ihre neue Buchhaltung in Banana Buchhaltung.
  5. Wählen Sie die zu kopierenden Daten in Excel aus und verwenden Sie den Befehl Kopieren (Ctrl+C oder Kopieren aus Menü Bearbeiten).
  6. Begeben Sie sich in Banana Buchhaltung und erteilen den Befehl Einfügen (Ctrl+V oder Einfügen aus Menü Bearbeiten).

Dank dieser Methode können Sie Daten aus MS-Money, Intuit Quicken und Quickbooks übernehmen, sowie aus den meisten anderen Programmen.

Banktransaktionen importieren

In diesem Fall ist es sinnvoll, eine der bereits verfügbaren Importfunktionen zu verwenden.

Wenn es keine für Sie geeignete Importerweiterung gibt, können Sie auch den oben beschriebenen "One-Time-Importmodus" verwenden.

Beispiel für den Import einer CSV-Bankdatei mit Excel

Wenn Sie Bankdaten importieren müssen aber es keine Importerweiterung gibt, können Sie Excel benutzen, indem Sie dem hier erläuterten Beispiel folgen.

Der Zweck besteht darin, die Daten in Excel zu laden und sie genau so anzuordnen, wie sie in der Tabelle 'Buchungen' von Banana erscheinen, um sie anschliessend auszuwählen, zu kopieren und einzufügen.

  1. Erstellen Sie eine neue leere Datei in Excel.
    • Gehen Sie auf "Daten"
    • Aus Text/CSV
    • Wählen Sie die zu importierende Datei aus
    • Passen Sie die von Excel vorgegebenen Parameter an
    • Nutzen Sie bei Bedarf die Schaltfläche "Daten transformieren" am unteren Rand, um weitere Änderungen vorzunehmen.
    • Bestätigen Sie mit "Laden"
  2. Fügen Sie rechts neben den Daten Spaltenüberschriften hinzu, wie sie in der Tabelle 'Buchungen' der Buchhaltung erscheinen.
    • Datum
    • Beleg
    • Beschreibung
    • KtSoll (Soll-Konto)
    • KtHaben (Haben-Konto)
    • Betrag
  3. Fügen Sie in der ersten Zeile der Daten Formeln hinzu, um die Bankdaten zu übernehmen und konvertieren.
    • Datum       
      (übernimmt das gewünschte Datum)       
      =C2
    • Beleg       
      Lassen Sie es leer; aber bei Bedarf könnte eine Nummerierung vorgenommen werden.
    • Beschreibung  
      (übernimmt die gewünschte Beschreibung)       
      =B2
    • KtSoll (Soll-Konto) 
      Geben Sie die Kontonummer der Bank ein (z.B. "1010"); nur wenn der Betrag positiv ist.     
      =WENN(E2>0,"1010","")
    • KtHaben (Haben-Konto)
      Geben Sie die Kontonummer der Bank ein (z.B. "1010"); nur wenn der Betrag negativ ist.      
      =WENN(E2<0,"1010","")
    • Betrag       
      Erfassen Sie den Betrag ohne negativem Vorzeichen (-).        
      =ABS(E2)
  4. Kopieren Sie die erstellten Formeln, in allen folgenden Zeilen mit Daten.
  5. Wählen Sie die zu kopierenden Daten/Zeilen in Excel aus und erteilen den Befehl Kopieren.
  6. Wechseln Sie zur Tabelle Buchungen in Ihrer Buchhaltungsdatei und begeben Sie sich zur ersten leere Zeile der Spalte Datum am Ende der Tabelle.
  7. Erteilen Sie den Befehl Einfügen.

dialogo importa in contabilità

Spalten der 'Buchhaltung mit Fremdwährungen'

Wenn die Buchführung in mehreren Währungen erfolgt, fügen Sie auch die folgenden Spalten hinzu:

  • Währungskennzeichen
  • Betrag Basiswährung.       
    Wenn Ihnen der Fremdwährungsbetrag (Betrag Währung) und der Betrag (Basiswährung) bekannt ist, wird der Wechselkurs (Umrechnungskurs) von Banana Buchhaltung berechnet.

Weitere nützliche Tipps

  • Wenn die Betragsspalten keine Tausendertrennzeichen enthalten, werden sie von Excel möglicherweise nicht in Zahlen konvertiert. Markieren Sie in diesem Fall die gesamte Spalte und verwenden Sie den Befehl "Ersetzen", um das Tausendertrennzeichen einzufügen.
  • Wenn die Daten anders sortiert sind als in Banana Buchhaltung, müssen Sie, bevor Sie mit der Zuordnung der Felder fortfahren, sich auf die Spalte 'Datum' stellen und danach auf den kleinen Pfeil auf der rechten Seite klicken, uns die vom ältesten zum neuesten sortieren.
  • Sie können beliebig viele zusätzliche Spalten hinzufügen.
  • Mit Office-Scripts in Excel können Sie allenfalls auch ein Makro erstellen, um die Dateikonvertierung zu automatisieren.

Regelmässiger Datenimport aus anderen Programmen

Sehen Sie bitte Bewegungen importieren.

Es kommt vor, dass man regelmässig Daten aus anderen Programmen importieren muss. Zum Beispiel:

  • Monatliche Bewegungen aus dem Lohnprogramm importieren.
  • Ausgestellte Rechnungen aus dem Fakturierungsprogramm importieren.
  • Verbuchte Zahlungen aus dem Fakturierungsprogramm importieren.
  • Verbuchte Verkäufe aus einem Online-Shop importieren.
  • Daten aus einem anderen Buchhaltungsprogramm importieren.
  • Daten aus einer Kassensoftware importieren (z.B. Restaurant oder Hotel).

In diesen Fällen können Sie auf zwei Arten vorgehen:

  1. Stellen Sie sicher, dass Ihre Anwendung die Daten in das speziell für den Import in Banana vorbereitete txt-Dateiformat exportiert.
    Sehen Sie bitte die Anweisungen (in Englisch) zum Erstellen einer Importdatei in Banana Buchhaltung.
  2. Erstellen Sie ein Import-Skript, welches die Daten der Datei eines anderen Programms umwandelt, so dass sie in Banana importiert werden können.

Helfen Sie uns, unsere Dokumentation zu verbessern

Ihre Anregungen, wie wir diese Seite verbessern könnten, sind uns jederzeit willkommen.

Sagen Sie uns bitte, welches Thema eine bessere Erklärung braucht oder wie wir ein Argument verständlicher erklären könnten.

Diesen Artikel teilen: Twitter | Facebook | LinkedIn | Email