Dans cet article
Avec Banana Comptabilité, vous disposez d'un fichier séparé pour chaque année comptable. Le nouveau fichier pour l'année suivante est préparé automatiquement à partir des données du fichier comptable actuel qui est sur le point d'être clôturé. Le fichier actuel n'est pas modifié, la commande peut donc être exécutée en toute sécurité.
Comment passer à la nouvelle année comptable
Pour passer à la nouvelle année comptable, utilisez la commande Actions > Créer nouvelle année. Un nouveau fichier pour l'année suivante est créé à partir du fichier comptable qui est sur le point d'être clôturé.
Opérations effectuées par la commande Créer nouvelle année
La commande Actions > Créer nouvelle année, en fonction des paramètres définis par l'utilisateur, effectue automatiquement une série d'opérations pour préparer le fichier de la nouvelle année comptable.
En particulier, le programme :
- Crée un nouveau fichier (sans nom) avec le même plan comptable et les mêmes configurations que le fichier ouvert, mais sans écritures.
- Copie les soldes de clôture du fichier actuel (colonne Solde) et les saisit comme soldes d'Ouverture dans le nouveau fichier (colonne Ouverture), uniquement pour les classes de comptes indiquées dans les paramètres.
- Reporte le bénéfice ou la perte de l'année précédente en ajoutant le résultat de l'exercice au solde d'ouverture du ou des comptes du bilan indiqués pour l'affectation (normalement le compte Bénéfices/Pertes reportés).
- Copie les soldes des comptes du Bilan du fichier actuel (colonne Solde) dans la colonne Année précédente du nouveau fichier, pour tous les comptes du Bilan.
- Met à jour les propriétés du fichier en définissant les nouvelles dates de début et de fin de l'année comptable, en les avançant d'une année par rapport au fichier source.
- Dans la section Options :
- définit le nom du fichier de l'année précédente ;
- active l'option qui permet d'utiliser les écritures de l'année précédente pour l'autocomplétion.
- Dans la comptabilité multidevise, saisit les taux de change de clôture de l'année précédente comme taux de change d'ouverture.
- Si le tableau Budget contient des données, reporte les écritures dans la nouvelle année, selon les paramètres définis.
- Si l'option Segments est activée, crée également des écritures d'ouverture pour les segments.
Dialogue Reporter soldes à nouveau
Le dialogue Reporter soldes à nouveau permet de spécifier les paramètres pour la création du fichier de la nouvelle année :

Reporter les soldes d'ouverture des comptes
Les soldes d'ouverture des postes activés sont reportés :
Bilan
Reporte les soldes des comptes actifs, passifs et des capitaux propres. Cette option doit généralement être activée.
Compte de résultat (non recommandé)
Les soldes des comptes de charges et de produits NE DOIVENT PAS être reportés dans la nouvelle année.
Activez cette option uniquement dans des cas particuliers et seulement si vous êtes certain de ce que cela implique.
Hors bilan
Reporte les comptes avec BClass (5 et 6 pour les comptes actifs et passifs hors bilan et 7 - 10 pour les autres comptes hors bilan). Si les soldes de clôture de ces comptes ne doivent pas être reportés, désactivez l'option correspondante.
Centres de coûts
Ils ne doivent être activés que lorsque les centres de coûts sont utilisés pour gérer des postes qui doivent continuer dans le temps, tels que les clients, les fournisseurs et les partenaires.
Centres de coûts CC1
Ceux qui commencent par un point ".".
Centres de coûts CC2
Ceux qui commencent par une virgule ",".
Centres de coûts CC3
Ceux qui commencent par un point-virgule ";".
Pour plus d'informations, consultez la page Centres de coûts/profits.
Segments
Les soldes d'ouverture des segments sont créés avec des écritures d'ouverture dans le Tableau Écritures.
- Pour plus d'informations, consultez la page Segments.
- Le programme crée une écriture pour chaque combinaison de compte et de segment, en reproduisant exactement la situation de clôture de l'année précédente.
- Il est préférable de ne pas saisir les soldes d'ouverture des segments en utilisant la colonne Ouverture. Si cela a été fait l'année précédente, le programme reportera à nouveau le solde dans la colonne Ouverture de la nouvelle année.
Note : les opérations de régularisation, telles que l'enregistrement et la clôture des comptes transitoires, doivent être saisies manuellement.
Total à répartir
Le programme indique automatiquement le montant du bénéfice ou de la perte à répartir.
Comptes
Sélectionnez le ou les comptes (jusqu'à trois) auxquels le résultat de l'exercice doit être affecté. S'il existe plusieurs comptes auxquels le résultat de l'exercice doit être affecté, le montant doit être saisi manuellement dans les champs correspondants.
Si un seul compte est indiqué, le montant est automatiquement saisi dans le compte sélectionné dans la liste.
Le programme met automatiquement à jour les soldes d'ouverture. Le total de l'actif correspond exactement au total du passif.
Affectation du résultat de l'exercice à plus de trois comptes
Dans ce cas, affectez automatiquement le résultat de l'exercice uniquement au compte Bénéfices/Pertes reportés et poursuivez avec la création de la nouvelle année.
Dans la nouvelle année (nouveau fichier), dans le Tableau Écritures, saisissez une écriture composée pour transférer le résultat de l'exercice du compte Bénéfices/Pertes reportés vers les comptes souhaités.
Reporter l'affectation du bénéfice ou de la perte de l'exercice
Si vous ne souhaitez pas encore affecter le résultat de l'exercice, vous pouvez tout de même procéder à la création de la nouvelle année en cliquant sur le bouton OK. Vous pourrez ensuite affecter le résultat de l'exercice depuis le menu Actions > Mettre à jour soldes d'ouverture. Le programme affiche la même fenêtre que celle qui apparaît avec la commande Créer nouvelle année.
Enregistrer le nouveau fichier
Le programme crée un nouveau fichier comptable pour la nouvelle année :
- Confirmez les Données de base pour la nouvelle année. Le programme reporte les en-têtes de l'année précédente et saisit automatiquement les dates de début et de fin de la nouvelle année.
- Cliquez sur le menu Fichier > Enregistrer sous et indiquez le dossier dans lequel vous souhaitez enregistrer le nouveau fichier comptable. Nous vous recommandons d'utiliser le nom de l'entreprise et l'année comme nom de fichier.
Voir aussi Organiser les fichiers comptables.
S'il existe des différences ou d'autres messages d'erreur, vous pouvez choisir de ne pas enregistrer le fichier créé et répéter ultérieurement l'opération de création du fichier de la nouvelle année.
Travailler sur deux années en même temps
Après avoir créé le nouveau fichier, vous pouvez travailler en parallèle sur les deux années :
- Fichier de la nouvelle année
- Saisissez les écritures de la nouvelle année comptable.
- Vous pouvez modifier le plan comptable, la TVA et les segments sans affecter l'année précédente.
- Si vous avez effectué des modifications dans le fichier de l'année précédente, utilisez la commande Actions > Mettre à jour soldes d'ouverture.
- Fichier de l'année précédente
- Complétez les écritures.
- Effectuez les opérations de clôture, les vérifications, les impressions et les contrôles.
Message du plan Professional avec Fonctions Advanced jusqu'à 70 lignes
Si vous utilisez Banana Comptabilité Plus – Plan Professional, après la création du nouveau fichier, le message suivant apparaît :
Souscription active : Plan Professional. Les fonctions du plan Advanced sont disponibles jusqu'à 70 écritures.
Le message indique uniquement que les fonctions Advanced sont disponibles gratuitement jusqu'à 70 lignes.
Il n'affecte en aucune manière l'utilisation du plan Professional, qui reste illimité en termes d'écritures.
Le message disparaît automatiquement dès que 70 lignes sont dépassées.
Vérifications dans la nouvelle année comptable
Après avoir créé le nouveau fichier :
- Exécutez la commande Créer nouvelle année.
- Vérifiez les soldes d'ouverture qui ont été reportés automatiquement.
- Vérifiez que le bénéfice ou la perte de l'exercice a été correctement comptabilisé.
- Ne supprimez pas dans la nouvelle année les comptes qui présentent un solde de clôture dans l'année précédente.
- Si vous utilisez la comptabilité en partie double multidevise, assurez-vous d'avoir calculé et enregistré automatiquement les différences de change.
Mettre à jour les soldes d'ouverture
Après avoir enregistré le fichier de la nouvelle année et effectué des modifications dans l'année précédente, cliquez sur Actions > Mettre à jour soldes d'ouverture pour reprendre les soldes d'ouverture et répartir à nouveau le bénéfice.
Cette opération peut être répétée plusieurs fois et peut être effectuée en toute sécurité. L'intégrité des données pendant le passage à la nouvelle année est garantie et aucune donnée n'est perdue.
Si, avec la nouvelle année, vous souhaitez passer à un autre type de comptabilité (multidevise ou avec TVA), créez le nouveau fichier puis utilisez la commande Outils > Convertir fichier.
Si, au contraire, vous souhaitez créer une copie du fichier sans reporter les soldes, utilisez la commande Outils > Créer copie fichier.
Modifier les soldes reportés
Une fois les soldes reportés dans la nouvelle année (nouveau fichier), s'il est nécessaire de modifier les soldes d'ouverture, ils peuvent être modifiés manuellement en changeant les montants dans les colonnes suivantes :
- Ouverture dans le tableau Comptes.
- Précédent (tableau Comptes > vue Précédente), pour les soldes relatifs à l'année précédente.
- Dans le Tableau Écritures pour les Segments.
Si vous avez effectué des modifications dans le fichier de l'année précédente, cliquez sur Actions > Mettre à jour soldes d'ouverture pour reprendre et mettre à jour à nouveau les soldes d'ouverture.
Vérifier les Règles dans le Tableau Écritures répétées
Lorsque vous exécutez la commande Créer nouvelle année, le programme reporte dans le fichier de la nouvelle année toutes les écritures qui ont des Règles.
Avant de comptabiliser les écritures de la nouvelle année, il est conseillé de vérifier et de mettre à jour toutes les Écritures avec Règles dans le Tableau Écritures répétées.
Si les conditions ne sont plus valables, vous pouvez :
- Modifier le compte, le compte de contrepartie, le code TVA, CC3 ou les segments.
- Supprimer les écritures qui ne sont plus actuelles.
- Ajouter de nouvelles écritures avec des Règles.
Si, dans le Tableau Écritures répétées, en plus des écritures avec Règles, vous avez également enregistré :
- des écritures répétées identifiées à l'aide de la colonne Pièce
- des écritures avec une périodicité régulière.
vous devez également les vérifier et les mettre à jour.
Effectuer cette vérification immédiatement permet d'éviter des erreurs et des corrections ultérieures, tant dans le Tableau Écritures que dans le Tableau Écritures répétées.
Reprise des textes dans la nouvelle année / Smart Fill
Lors de la création d'une nouvelle année, les textes descriptifs de l'année précédente sont également repris. Cette fonction facilite et accélère la saisie des écritures dans la nouvelle année.
Si vous ne souhaitez pas que les textes descriptifs de l'année précédente soient automatiquement repris, il suffit de désactiver la fonction Smart Fill :
- depuis le menu Fichier > Propriétés fichier (Données de base) > Options.