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Banana Accounting 7 
Introductory Quick-start guide to Banana Accounting. 
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How to install the Program 

The installation of the program is completely automatic and requires no detailed technical knowledge: 

• Insert the disk into the CD-ROM drive 

• In case the Setup program doesn’t display automatically, start executing the program yourself 

with a double click on the setup.exe file (Windows) or Install Banana 7.dmg (Mac). 

For Linux, launch the CD and execute the specific installation file for one’s own Linux 

distribution. 

The program can also be installed directly from our website 

http://www.banana.ch/cms/en/download_en  

 

Installation under Windows 

All the steps of the installation and the related images can be consulted at the page   

http://www.banana.ch/cms/en/node/3623 

Installation under Mac 

All the steps of the installation and the related images can be consulted at the page  

http://www.banana.ch/cms/en/node/3625 

Installation under Linux 

All the steps of the installation and the related images can be consulted at the page  

http://www.banana.ch/cms/en/node/4661 

At the end of the installation process, the program asks for the license key.  

Warning! If the license key is not being entered, the program functions in the Starter Edition mode  

(where only 70 transaction rows can be entered). 

 

In case Banana has already been installed but the license key has not yet been entered, it can be 

entered through the Manage license keys command of the Help menu. 

The installation does not alter main or system files and installs nothing in the system directory. A 

program to remove all the files that have been installed (un-install), is installed at the same time. 
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Create a new Accounting 

Creating one’s own accounting is easy (a working knowledge of the Operating system is being assumed). 

The program is equipped with a series of templates of specific charts of accounts for individual nations. 

In order to set up an accounting, it is better to adapt an existing chart of accounts to one’s own needs 

than to start an accounting without a template to work with.   

 

There are templates available with a preconfigured chart of accounts as well as accounting examples 

with, added to the chart of accounts, opening balances and example transactions.  

 

• Launch Banana Accounting and select the New command from the File menu. 

 

A window opens in which the desired type of accounting can be indicated and the template that is 

closest to the user’s  specific needs. 

 

 

 

• Press OK to continue ... 

 

A new  window will appear, where the main accounting parameters of one’s own accounting should be 

entered; according to the type of file that has been selected, there can be added sections (Foreign 

currency and VAT). 

 



 
 

 

www.banana.ch  4 

 

 

For detailed  explanations on the different sections for the File and accounting properties (Basic data), 

please consult our page http://www.banana.ch/cms/en/node/2001 

 

• Press OK to continue. 

 

Now the accounting template that has been selected is being opened; before modifying it, it needs to be 

saved through the Save as… command from the File menu. 

The saved file becomes the user’s own accounting file, in which the necessary modifications can be 

entered to adapt it to the personal needs.   

The Basic data of the accounting can be modified by selecting the File and accounting properties (Basic 

data) command of the File menu. 

 

In order to customize an accounting, the user should:  

 

• Adapt the Chart of accounts – in the Accounts table, the Chart of accounts can be modified 

according the one’s own wishes. Accounts, groups and subgroups can be added or deleted. 

More information can be found on the web page: http://www.banana.ch/cms/en/node/3637#1 

 

• Enter the opening balances in the Opening  column of the Accounts table. The balances of the 

Liabilities’ accounts have to be entered preceded by  the minus sign. Upon completion of 

entering the opening balances, check in the information window (bottom part of the screen) 

that there is no difference indicated in the opening balances.  

 

• Enter the Transactions- Go to the Transactions table and enter the accounting transactions. 
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In the information window (bottom part of the screen), no error (red color) should be indicated. In the 

Totals table, there should be no difference (difference should be = 0). If there is a difference, it means 

that there are errors in the transactions or in the opening balances.  

After correcting possible errors, recheck the accounting with the Recheck accounting command (Shift 

+F9). 

 

For more information on how to set up the chart of accounts, go to the following pages: 

http://www.banana.ch/cms/en/node/3968 - The accounts of the accounting 

http://www.banana.ch/cms/en/node/3261 - The groups 

http://www.banana.ch/cms/en/node/3638 - The sections 

http://www.banana.ch/cms/en/node/3703 - The segments 

 

  

Different types of accounting 

The program offers the possibility to create different accounting types: 

 

Cash book Manages income/expenses  of one single account, for example the 

bank or the cash account. Also indicated for separate projects. 
 

Income/Expense Manages income/expenses of several accounts  (managing, at the 

same time, the cash account, bank, customers, etc.). Very suitable for 

managing the household’s  accounting. 
 

Double-entry The basis for all the others, because it takes into consideration all the 

necessary functions to keep a Double-entry accounting, as is being 

taught in the school books. Without VAT it is ideal for Non-profit, 

private, condominiums or entities governed by public law not 

submitted to VAT.  
 

Double-entry with VAT Includes also the VAT Codes table and the VAT columns in the 

Transactions table. The program automatically separates the VAT and 

calculates the VAT report by period. Ideal for companies, small 

companies and freelancers, that need to present their VAT declaration.  
 

Multi-currency accounting For managing accounts in foreign currencies.  Includes the Exchange 

rate table, in which the different currencies and exchange rates can be 

defined. 
 

Addresses / Labels Database management of clients, members, suppliers, customers, 

partners, etc.  Listings with names of which the columns and the 

printouts can be customized.  
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The Tables 

Banana Accounting interface 

 

Menu bar  Contains all the commands grouped by Menu. These can vary according to the 

table in which the user is positioned. 
 

Tool bar The most used commands of the Menu bar are being represented here, in 

order to access them faster (with a double mouse click).  
 

Information window  Here, useful information for the operations is being displayed, related to the 

table and the cell in which the user is positioned. It also shows eventual error 

messages in red.  
 

Tables These are the different accounting sheets. There are main tables and auxiliary 

tables; they can vary according to the used accounting type.   
 

Views There are various ways to display the accounting. In every view, different 

accounting aspects are being highlighted. Views can also be customized.    

 

For more information, please consult our page: http://www.banana.ch/cms/en/node/2189  
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The Accounts table 

This is the table where the chart of accounts is being set up, where the various additions and groupings 

of the accounting are being organized; it is highly important that the setup is correct.   

 

The Totaling system 

In Banana Accounting the calculations (totaling) are being based on the BClass number.  

 

The BClass 

In the BClass column, specific numbers have to be entered and only in the rows where an account 

number is present:  

 1 – for ASSETS accounts         3 – for EXPENSES accounts  5 – for OFF BALANCE SH. ASSETS accounts 

 2 – for LIABILITIES accounts   4 – for REVENUE accounts   6 – for OFF BALANCE SH. LIABILITIES accts  

 

For more information on the BClass, see our page: http://www.banana.ch/cms/en/node/3968 

 

In the existing templates, various totaling types have been set up, but there are some that are present in 

all of them: 

 

Sum of Assets/Liabilities  The Liabilities are being entered in negative (preceded by the minus sign), 

therefore the sum of the Assets and Liabilities (including the Profit or Loss 

of the current year) has to be zero. 

 

Sum of Expenses/Revenue The Revenue accounts are being indicated in negative (preceded by the 

minus sign), therefore the sum of the Expenses and Revenue gives the 

Profit/Loss of the Profit & Loss Statement; if this amount is negative, there 

is a Profit; if it is positive, there is a Loss. The Profit/Loss of the Profit & 

Loss Statement is then being totaled in the Liabilities. 

 

Account, Group and Gr 

Account Every account needs to have its own number or code (free for the 

choosing), in the Account column. This account number will then be 

entered when entering data in the Transactions table. 

 

Gr In the Gr column, enter a code that can be freely chosen for the rows of 

which the amounts have to summed up together.  

 

Group If there is a code in the Group column of a row, the program sums up in 

that Group the amounts of all the rows that have a Gr with the same 

code. It is not possible to have both a Group and a Gr in the same row.  

 This totaling system can also take place at more than one level, and makes 

it possible to organize the chart of accounts in different groups and 

subgroups. 
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In the example image, the accounts from 1000 to 1512 have the number 1 in the Gr column, the same 

number that is also being entered in the Group column in the Total row (TOTAL ASSETS). Thus, the 

program sums up, in the TOTAL ASSETS row, the amounts of the rows of the Cash, Post office current 

account, Bank account, etc.  

In the chart of accounts, this totaling system can be repeated at unlimited levels. In the example image, 

we see that in fact the TOTAL ASSETS and TOTAL LIABILITIES have in turn the 00 code for a Gr, that is 

being totaled in the Difference should be = 0 (blank cell) row.  

For more information on the Chart of accounts and the totaling system, visit the page 

http://www.banana.ch/cms/en/node/3261. 

 

Sections 

The Sections give the possibility to also print selected parts of the Balance sheet only, imparting the 

Enhanced Balance Sheet with groups command (from the Account1). In order to use this function, the 

chart of accounts needs to be set up with a specific code in the Section column of the Accounts table. 
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For more information, visit our page http://www.banana.ch/cms/en/node/3638. 

 

Cost- and Profit Centers 

In the chart of accounts, there can also be Cost- and Profit Centers;  these are useful when one wants to 

obtain, at the side of the main accounting, different totals without modifying the accounting itself.  They 

are entered at the bottom of the chart of accounts and have as a characteristic that their account 

number is preceded by a period, a comma or a semicolon. In the Transactions table, when the 

transactions are being entered, just enter the account number or the code of the Cost center in the CC1, 

CC2, CC3 column (Cost center view) without the period, comma or semicolon. In the Accounts table, in 

the rows where the Cost centers are being set up, the totals of the Cost centers are being displayed. 

These totals are equally displayed in the Enhanced Balance sheet with groups. 

For more information, visit our page http://www.banana.ch/cms/en/node/3764. 

 

The Segments 

Thanks to the segments, extra entities can be created to which the transaction amounts can be 

attributed. Segments are being used to obtain accounting reports subdivided by Department, Project, 

Branch. 

For more information, visit our page http://www.banana.ch/cms/en/node/3703 

 

The Transactions table 

This is the table in which the accounting transactions are being entered. There are different columns: 

Date, Document, Description, Debit A/C, Credit A/C, Amount. The columns vary according to the 

accounting type selected and according to personal options.  

For example, in an accounting with VAT/Sales tax, there are also the columns to record the VAT, while 

for a Multi-currency accounting, there are additional columns for the exchange rates. 

The columns of the table can be sorted, displayed or cancelled. It is equally possible to enter new 

columns according to  one’s own needs. Select the Columns setup command from the Data menu. 

 

The Transactions table has different views: the Base view (includes the most used columns), the 

Complete VAT view (with all the detailed VAT columns), Cost centers (with the three Cost center 

columns), Expiry date, etc.  

For more information, visit our page http://www.banana.ch/cms/en/node/3240. 
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In the example, the Transaction table of a Multi-currency accounting with VAT is being shown.  

 

 

The Totals table 

The Totals table contains the groupings of the classes with its constantly updated balances: 1 Assets, 2 

Liabilities, 3 Expenses, 4 Revenue, 5 Off Balance sheet Assets, 6 Off Balance Sheet Liabilities, etc.  

This table makes it possible to immediately check whether the opening balances balance, if there is a 

profit or a loss and if there are accounting differences. 

 

 

 

 

The VAT Codes table 

If, in the program, an existing template with VAT has been selected, the VAT Codes table has already 

been set up with the codes and percentages pertaining to the selected nation.   

The VAT Codes allow the program to separate the VAT automatically according to the various 

percentages and to debit or credit it on the Automatic VAT account  or the specific VAT accounts. While 

entering the accounting transactions, enter the specific code, according to the type of accounting 

transaction (purchase or sales), in the VAT Code column. 

In case the Automatic  VAT account is being used, it is advised to define it in the File and accounting 

properties of the File menu. If one wants to use several VAT accounts, these need to be defined in the 

VAT Codes table, VAT account column. 

The code number as well as the percentage of the VAT Codes can be modified.  
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With the VAT/Sales tax report command of the Account1 menu, detailed reports can be obtained, even 

by period.  

For Switzerland, from the Account1 menu and selecting the Swiss VAT reports command, it is possible 

to obtain a fac-simile of the official forms, for the Effective method as well as for the Flat tax rate. 

Afterwards, the amounts can simply be copied unto the official form.  

For more information on managing the VAT, visit the page http://www.banana.ch/cms/en/node/3679 

 

The Exchange Rate table 

The Exchange Rate table can only be found in the Multi-currency accounting. In this table, the codes for 

the currencies that are being used in the accounting, are being defined. Each currency has its own 

symbol and exchange rate referring to the Reference currency.  

The Mult. is the multiplier of the exchange rate so that the effective change can be obtained. Usually 1, 

100 or 1000. There are indeed currencies that are not worth much in units so that instead of using lots 

of zeros, a multiplier is used. The multiplier can also be negative. In this case the program uses the 

exchange rate in the opposite way. 

For more information, visit our page http://www.banana.ch/cms/en/node/3665 

 

 

 



 
 

 

www.banana.ch  12 

 

 

 

Other tables 

Other auxiliary tables also exist, such as the Recurring transactions table, Expiry dates, Extract rows, 

etc., depending on the specific functions asked for in the program.  

For more details on this subject, please consult our online Documentation. 

 

Technical characteristics and accounting characteristics 

Fast entries 

In Banana Accounting, there are several features that speed up the entry of the accounting transactions:  

 

• Smart Fill - As soon as you begin typing, the program, where possible, will try to suggest how to 

complete the text to avoid having to spell out completely the date, a phrase, or an account 

number. When there are various possibilities, these are being displayed in a dropdown list: just 

select the appropriate option with the arrow and press the F6 key. 

For more information, visit our page http://www.banana.ch/cms/en/node/3250. 

 

• Recurring Transactions table -  In order to avoid rewriting always the same texts, it is possible to 

store transaction groups in the Recurring transactions table, Account2 menu. These can be 

retrieved and entered into the Transactions table by means of a code. 

For more information, visit our page http://www.banana.ch/cms/en/node/4865. 

 

Other features to speed up the work (visit the corresponding pages): 

• Copy, cut and paste  

• Rename an account 

• Importing the movements of bank statements  
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Recheck the Accounting 

Recalculate group  From the Account1 menu, selecting the Recalculate group totals (Accounts 

totals table) command, or simply by pressing the F9 key on the keyboard (Cmd+9 

 for Mac), totals on the chart of accounts are being updated. In case of errors in 

the chart of accounts, error messages will be displayed. Correct the errors and 

repeat F9. 

 

Recheck accounting From the Account1 menu, selecting the Recheck accounting command, or 

simply by pressing the Shift + F9 key on the keyboard (Shift +Cmd+9 for Mac), 

the entire accounting is recalculated and rechecked to see  that there are no 

errors or omissions. The program resets all the balances to zero and 

recalculates/verifies the entire accounting transaction after transaction, as if 

rewriting all the transactions manually. It also recalculates the VAT percentage 

(not in locked rows). If there are many errors, press Don’t warn, the messages 

are in any case saved in the message window and can be read later. Further, 

when double clicking on the message in the message window, one goes directly 

to the row that generated the error. It is advised to use this command often.  

 

 

Sort/Lock/Unlock Transactions  

Sort transactions From the Data menu, selecting the Sort rows command, a window appears in 

which the transactions can be sorted according to various criteria (it is not 

always necessary to have them sorted by date). However,  attention needs to 

paid to the fact that once the transactions have been sorted according to a 

different  criteria,  it might be difficult to return to its previous order. 

 

Lock transactions From the Account2 menu, the Lock transactions command locks the 

transactions in a permanent way. This might be necessary for legal reasons or 

for auditing. Activating the command, a window opens in which it is necessary to 

indicate the date of the lock. Confirm with OK. Then the Lock view is being 

displayed. Locked data can longer be modified. Rows with errors or transactions 

without dates cannot be locked. When the transactions are being locked, the 

program numbers them with a progressive number as well as with a unique 

number that cannot be repeated. To check whether an accounting has been 

locked, use the File info command (Tools menu). 

 

Unlock transactions When the transactions are being locked, the program associates a unique, 

unrepeatable number to the lock. The transactions can be unlocked using the 

Unlock transactions command from the Account2 menu but if they are locked 

once again, the number for the second lock will be different from the first and 

there will thus be proof that these transactions have been altered.  
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Protect rows  When only temporary protection is needed, in order to avoid that the rows are 

being altered by mistake, it is advised to use the Protect rows command from 

the Edit menu. The protected rows, unlike locked ones, can be unprotected. 

 

Journal by period /Show Expiry dates 

Journal by period With the Journal by period command of the Account1 menu, the movements of 

all the accounts during the period specified in the window that appears, are 

being calculated:  

 

 

 

 After confirming with OK, the Journal table will open itself with the specified 

period in the header; all the movements included in the period will be displayed. 

 

For more information, visit our page http://www.banana.ch/cms/en/node/2155 

 

Show expiry dates The expiry dates are managed with the Expiry dates view, that appears in the 

upper part of the Transactions table. To keep the unpaid invoices under control, 

just enter the payment deadline in the Date Exp. column. Afterwards, when the 

payment has been received, the payment date has to be entered on the same 

row. With the Show expiry dates command of the Account2 menu, a list of the 

pending payments appears.  

For more information, visit our page http://www.banana.ch/cms/en/node/3647. 

 

In the Experimental version, that can, at the moment, only  be downloaded from 

our website, at the following page http://www.banana.ch/cms/en/node/4617, 

there are advanced features available that automate the expiry dates and that 

show the customers and suppliers data.  

For more information, visit our page http://www.banana.ch/cms/en/node/4838. 
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Import/Export Data 

Importing  With the Import to accounting command of the Account1 menu, one can import 

transactions, accounts, changes or VAT codes  into the accounting from various 

file formats. The feature that helps the user to accelerate data entry is certainly 

the possibility to import the movements of the bank statements, obtained 

through e-banking. 

 

For more information, visit our page http://www.banana.ch/cms/en/node/3963 

 

Exporting With the Export rows command of the Data menu or with the Export file 

command of the File menu, one can export several rows or the entire 

accounting file in various formats (Txt, Html, Xml, Excel). The data of the 

accounting can be exported to external archives.  

 

For more information, visit our page http://www.banana.ch/cms/en/node/3935  

 

Create PDF dossier With the Create Pdf dossier command of the File menu, it is possible to save the 

entire accounting (Chart of accounts, Transactions, Account cards, Balance sheet 

and Profit & Loss statement, etc.) in a single accounting file. The data saving 

options can be customized.  

  

For more information, visit our page http://www.banana.ch/cms/en/node/2124 

 

Checking / Closing of accounts / New Year 

Differences The program constantly updates the totals of the Debit and Credit transactions 

and indicates whether there is a difference. This could be caused by the fact that 

an account, used in a transaction, would not exist in the Chart of accounts, or (in 

the majority of the cases) when a transaction on multiple rows is incomplete. 

The Search for transaction difference command of the Account1 menu finds the 

transaction from  which the total transactions Debit and the total transactions 

Credit no longer correspond. If there is indeed a difference, the cursor will be 

positioned on the row where the Debit transactions and the Credit transactions 

no longer balance. As a precaution, in case it is difficult to locate the incorrect 

transaction, it is useful to Recheck the accounting. 

 

For more information, visit our page http://www.banana.ch/cms/en/node/3653 

 

Exchange rate  If you are working with accounts in foreign currencies, there will always be 

differences exchange rate or rounding variations. The exchange rate difference exists 

because amounts in foreign currency are converted into the national currency 

(basic currency) and since the exchange rate fluctuates each day, there will 
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always be differences. The program uses the exchange rates from the Exchange 

rate table. The user needs to update the table with the exchange rates of the 

day that he  wants to use. When closing the accounts, the exchange rates need 

to be updated with the official exchange rates on December 31st. These 

exchange rates will then become the opening exchange rates of the following 

year. In order to have a correct accounting, the Exchange rate differences have 

to be recorded with the Create transaction for exchange rate variation 

command of the Account2 menu (in the window that appears, enter the 

transaction date, usually the 31
st

 of December of the current accounting year).  

After confirming with OK, the program creates the requested exchange rate 

difference transactions immediately in the Transactions table (one for every 

account with a foreign currency).  

For more information, visit our page http://www.banana.ch/cms/en/node/4019 

 

Year’s End  The program automatically calculates the profit at any time, without having to 

close the accounting. It is thus possible to proceed directly with the Opening 

balance of the new year, without having to close the accounting. 

In the Multi-currency accounting, before creating a new year, one should: 
 

• Update the Exchange rate table with the closing exchange rates (these 

correspond then to the opening exchange rates of the new year).  

• Record the Exchange rate- and rounding differences, otherwise these would 

be carried forward to the next year; if, afterwards, more accounting 

operations are being entered, check once more whether there are 

accounting differences or not. 

 

Provisional Closure It is possible to create a new year, even if the current one is not yet closed; the 

opening balances of the new year are provisional and can be updated at a later 

date. For the Multi-currency accounting, if balance sheets are being printed at 

certain times during the year, it is good to update the Exchange rate table every 

time with the new exchange rates and to record the related exchange rate 

differences, otherwise there might be accounting differences that will also 

influence the result of the accounting period.  

 

Create New Year This is the command that one uses when a year comes to an end and a new 

accounting needs to be created for the next year, with the same chart of 

accounts that includes the opening balances. From the Account2 menu, 

selecting the Create New Year command, a window opens in which one can 

indicate the accounts for which the opening balances need to be carried forward 

(Assets and Liabilities), and select the account(s) to allocate the profit or loss of 

the accounting period.   

After having checked the opening balances, one needs to verify  the basic data 

of the new accounting (File menu, File and accounting properties command), 

automatically proposed by the program and save the file under a new name. The 
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program transfers the final balances also in the Balance from previous year 

column of the Previous view of the Accounts table.   

 

For more information, visit our page http://www.banana.ch/cms/en/node/3652 

 

Update opening   It is possible that the accounting of the last year is still being modified and that  

balances  the closing balances change (when a new year is being opened without having 

closed the previous one). When afterwards the accounting of the previous year 

is definitely closed, the final balances can be transferred to the new year.  This is 

possible with the Update opening balances command (Account2 menu); a 

window opens in which the file name (*.ac2) of the previous year’s accounting 

should be indicated. After confirming with OK, the window of the Create New 

Year command appears and has to be completed. 

 

For more information, visit our page http://www.banana.ch/cms/en/node/3652#1 

 

Printouts  With the Page setup command, File menu, a window opens in which different 

printing options can be selected, referring to the active table (for every table, 

the operation needs to be repeated). Before printing, it is advised to make a 

print preview (File menu, Print preview). The contents of the active table can be 

printed with the Print command from the File menu. A single page can be 

printed, several pages or only selected rows.  
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Banana Accounting provides various printouts, and each one of them can be customized:  
  

• Journal 

• Enhanced balance sheet 

• Enhanced balance sheet with groups 

• Accounting report 

• Account card 

• End-of-year printouts in pdf 

• Printouts VAT reports  (for Switzerland reports are available in effective and flat tax rate 

method)  
 

We refer to our webpage where detailed explanations of each printout can be found, with specific 

options for each accounting type: http://www.banana.ch/cms/en/node/3678 

 

Assistance and support 

The company Banana.ch SA, with more than 20 years of experience, has developed an efficient and fast 

assistance and support system for its own users.  
 

Online Help always available for the user, supplies detailed and in-depth instructions on the 

different subjects. By clicking on the Help button of any dialogue window of the 

program, the user is directly transferred to related online explanation page.   
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Internet Extensive documentation on all the various accounting and technical subjects is 

present on our website, and is being constantly updated. Just enter the key words in 

the search box to immediately find solutions. 
  

 
  

 Also, our Support page, organizes the main subjects by theme.  
 

 

Email Our email support@banana.ch is always available, to receive a quick and competent 

answer.  
 

Address   Banana.ch SA, Via Trevano 7 A 

 6900 Lugano – Switzerland 

 www.banana.ch 

 

Copyright & Trademarks 

Copyright Banana.ch SA, Lugano (Switzerland). All rights reserved. 

In the interest of continuing product development, Banana.ch SA reserves the right to make 

improvements in this manual and the products it describes at any time, without notice or obligation. 

The program is supplied by virtue of the user's license and the conditions of distribution. 

The program may only be used in accordance with these conditions. 

All rights are reserved. 

No part of this document may be copied, reproduced, memorized in filing systems or sent in any other 

form or by electronic, mechanical, photocopied, recorded or other means without prior authorization 

from Banana.ch SA. 

 

Trademarks 
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