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1 Introduction 

 

The Banana Accounting 6.0 software gives the opportunity to manage accounts according to 

different requirements, beginning with the Cash book and concluding with Double-entry 

accounting.  

 

This guide is made up of various sections, the first of which is dedicated to “functions in 

common”, which has been included to avoid useless repetition of functions and subjects common 

to the Cash book, Simple accounting and Double-entry accounting. 

 

 

1.1 Cash book 

The Cash book is ideal for managing income and expenses for a single account like petty cash, 

post office current account and bank current account. 

 

Various setups are possible: 

 Cash book 

 Cash book with VAT/Sales tax 

 Cash book with second currency  

 Cash book with second currency and VAT/Sales tax 

To simplify getting started, in the Create new file window, (File menu, New) various templates 

are available; just open one, edit the Accounts and Categories Table and save the file with a 

name. 

 

 
 

 

1.2 Simple accounting 

Simple accounting is ideal for small businesses, clubs and associations. It is based on the Income 

and Expense columns and, unlike the Cash book, it can manage more accounts (for example, 

petty cash, bank accounts, post accounts, debits, etc.). Data entry is initially done in the Accounts 
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table, where estate accounts are defined and in the Categories table, where income and expense 

accounts are defined. In the Transactions table, accounting entries are made. 

 

Various setups are possible: 

 Simple accounting 

 Simple accounting with VAT/Sales tax 

 Simple accounting with second currency  

 Simple accounting with second currency and VAT/Sales tax 

 

Along with the selected set up, there are templates that can be selected, edited and saved for 

personalized accounting.  

 

1.3 Double-entry accounting 

Setting up accounts using the Double-entry method is, without doubt, traditionally the most 

commonly used by professional accountants and by firms that need to present a balance sheet 

and profit and loss statement. It offers updated balance sheets, and it is recognized by tax 

authorities. It is based on the Debit and Credit columns and therefore it would be better to have 

some knowledge of how professional book-keeping works. In double-entry accounting, there are 

four series of accounts: 

 Assets 

 Liabilities 

 Expenses  

 Income 

Beside this, for the off balance accounts, two series of accounts are available: 

 Off balance assets 

 Off balance liabilities 

Double-entry accounting is ideal for those who need an accounting system with the most detailed 

reports about their company management. 

 

Various setups are possible: 

 Double-entry  

 Double-entry with VAT/Sales tax 

For each setup several chart of accounts templates are available which can be edited and saved. 

 

 

1.4 Multi currency accounting 

Multi currency accounting is recommended for those who need to manage Double-entry 

accounting with accounts in different foreign currencies.  
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Various setups are possible: 

 Double-entry with foreign currencies  

 Double-entry with foreign currencies and VAT/Sales tax 

 

1.5 Labels 

The labels application allows the user to create a database from which it is possible to print 

labels and pull up lists or data in a fast and simple way.  

   

1.6 Other 

The Other option contains specific accounting functions such as the accounting external report 

and the exchange rates history.
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2 Software installation 

2.1 How to install the software 

The software installation is entirely automatic. It is based on normal Windows program 

installation standards and requires no technical knowledge: 

 Insert the CD in the CD-drive and await the installation automatic start-up. 

 Should the automatic start-up not initiate, activate it by double-clicking on the setup.exe file. 

From this moment onwards, the installation will proceed automatically according to Windows 

standards. 

The installation program will check whether the software has been previously installed; in this 

case the user will need to either confirm or select another directory for the installation. 

 

 

2.2 Notes on installation 

The installation does not alter main or system files and installs no component in the Windows 

system directory. 

The installation program unzips and copies template and program files onto the user’s hard disk. 

At the same time an uninstall program is also installed. 

This uninstall program will take care of removing all the files that have previously been installed 

at any time they are no longer necessary. 

 

 

2.3 Notes on using more than one language 

All the multilingual components are copied to the sub-directory LangDll. These are files with the 

same name, but with a different extension to indicate the language. The software automatically 

displays the available languages.  

To add a language not yet installed, simply copy the language file into the LangDll directory and 

restart the program. 

To remove a language, simply cancel the language file that is to be removed. The software 

should not be in use while removing a language. 

 

Startup language 

In the startup, the program checks the language setup in Windows and, if it is available, uses that 

one. If the language is not available, it will show the choice of available languages to be used for 

the start-up. The language can always be changed using Program options, in the Tools menu.   

 

 

2.4 Installation on a network 

The program can be installed on a network in two ways: 

 Execute the installation procedure on the server. 

 Install the program on a local computer and copy all the contents of the folder where the 

program was installed on the server.  

To execute the program on the local computer, a link must be created with the file from the 

Banana60.exe program.  
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2.5 Other information 

On the www.banana.ch internet site, the most recent versions of the manuals, patch, and online 

lessons that help with interactive learning can be found.  

http://www.banana.ch/redirect/banana60.php?&dlang=enu&cmd=home
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3 Functions in common 

Under the title of Functions in common, all characteristics, structural and functional, which are 

similar to the Cash book, Simple Accounting and Double-entry accounting are going to be dealt 

with. 

 

 

3.1 How to begin 

Start the program and select the New command from the File menu: 

 

 
 

From the window that appears it is possible to select: 

 Setup for the desired type of accounting  

(Cash book, Simple accounting, Double-entry accounting …)  

 The kind of accounting (with or without VAT/Sales tax, with one or more currencies…) 

 The appropriate template or example for the circumstances. 

 

Note: the templates only show charts of accounts or lists of default categories, whereas there are 

some sample transactions shown on the examples.  

 

Once the file has been created, the user can begin working on his/her accounting: 

 Adjust the Chart of accounts: on the Accounts table (or on the Categories table for the 

Cash book and Simple Accounting) the user can add or edit the Chart of accounts however it 

is desired.  

 Save the file with a name: normally the name of the company and the current year are used. 

 Insert transactions: go to the Transactions table and input the accounting transactions. 

 

Important: always make back-ups of personal accounting files. 
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3.2 The Structure of Banana Accounting 

 

 
 

When an accounting file is opened, a window opens showing the following elements: 

 

Menubar 

Commands grouped together by menu are contained in the menubar. The menubar changes 

according to the accounting setup selected.  

 

 
 

Toolbar 

The toolbar grants rapid access to the most frequently used windows and commands. 

Simply move the mouse to the desired icon and wait a second to get a description of its meaning. 

 

 
 

Text input area 

The text input area is situated right below the toolbar. Text must be inserted in this area.  

To edit an existing cell, click with the mouse on the area and proceed to edit, or hit the F2 key. 

At the left side of the text input area, two icons appear to cancel or to accept the inserted text. 

 

 
 

Tables 

Each accounting file is made up of many tables. There are main and auxiliary tables. The tables 

vary according to the kind of accounting selected. 
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In order to move from one table to another, click on the name of the desired table or use the 

Ctrl+PgUp and Ctrl+PgDn keys. 

 

Columns 

These are the vertical elements on each table. Their arrangement can be personalized. The 

column headers also vary according to the type of accounting selected.  

 

 
 

In order to view the entire heading of each column (on two lines), double click on the first top 

left cell.  

 

 
 

Views 

Each table can have more than one view, positioned on the bar at the bottom. The Views 

represent various ways of visualizing the fields of a table. 

The Views are very useful when it is necessary to see the accounting data in a different way 

(adding or deleting columns for example), without altering the basic set up. The user can move 

from one view to another with a simple click of the mouse on the name of the desired view. 

 

 
 

Information window 

This is a window without a title, positioned in the lower part of the screen, where useful 

information about the table or the active cell be found. It is also used to signal error messages in 

red. 

 

 
 

Note: through the Program options command, from the Tools menu, the number of rows shown 

in the information window can be edited.  

 

3.3 Work rapidly 

Many options have been developed so the user can work rapidly. The list below illustrates those 

most frequently used. 
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Copy from above – F4 key 

When starting an empty entry row, this key will copy the content of the preceding line. The 

function can also be activated from the Edit menu or by hitting the following icon . 

 

Execute command – F6 key 

While inputting transactions, this key will increase the date automatically according to the date 

in the previous cell. 

 

Add line+transaction – Shift+F6 keys 

This option allows the user to add a new row and pick up the transaction from the preceding line, 

all at the same time. 

 

Pick up lines with the same text - Smart Fill 

The program memorizes the data previously inserted. When entering a new text (for example, 

when inserting a description or an account), by typing in just a few characters, all the texts that 

begin with the same letters will appear on the upper part of the screen in the text input area. 

By clicking on the desired text, the software inputs it automatically. To move the cursor within 

the list for selecting a certain text, press the Down Arrow key and confirm with Enter or F6. If 

you want to exit without confirming, press the Ctrl +Down Arrow keys.  

 

 
 

When you are working in the Text input area in the Description and Debit and Credit cells, the 

following symbol appears on the right side. . By clicking on this symbol, the complete Smart 

fill list appears.  

 

Pick up memorized text – F6 key 

When there are transactions to make that repeat themselves during the year, it is possible to save 

them in the Memorized text table. When the text is needed again, the user can pick them up in 

the Transactions table by hitting the F6 key (see para. 3.7.8 and further).  

 

Cut, Copy and Paste – Ctrl+X, Ctrl+C and Ctrl+V 

It is possible to cut, copy and paste cells, rows or selected text just as it is possible to do with any 

normal Windows program: 

 Select the line or the area of data to be cut or copied 

 In the Edit menu, select the Cut or Copy command 

 Move to the row or the area where the information should be entered  

 From the Edit menu, select Paste 
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The user can also cut, copy and paste by using the following icons  or press Ctrl+C to 

cut, Ctrl+C to copy and Ctrl+V to paste. 

 

Automatically create a New Year 

In the Cash2 menu (Cash book), Simple2 (Simple accounting) or Account2 (Double-entry 

accounting), by clicking on the Create New Year command, the program uses all of last year’s 

accounts and inserts the opening balances. The user must however save the new file with a new 

name. When entering new transactions, the list of texts used during the previous year is still 

available when using Smart fill.   

 

Calculate totals – F9 

The program automatically recalculates the totals after every operation.  

 

Recheck the accounting - Shift+F9 

From the Cash1 (Cash book), Simple1 (Simple accounting) or Account1 (Double-entry 

accounting) menus, by selecting Recheck accounting, or simply by hitting the Shift+F9 keys, 

the entire accounting will be recalculated and  rechecked in order to verify that there are no 

errors or omissions. The program resets the balances to zero, recalculates them and verifies the 

entire accounting (entry by entry) just as though all the transactions were rewritten by hand. It 

also recalculates the percentages of VAT/Sales tax (except where transactions have been locked). 

If there are many errors, click on Don’t warn; the messages will then be saved in the message 

window and can be viewed later.   

 

3.4 Groupings 

When an example must be edited in order to personalize it, or when a new blank file is started, 

the user must understand the grouping system in order for the program to sum up all the amounts 

from the various accounts and/or categories correctly. These groupings also serve to sum up the 

amounts of the VAT/Sales tax codes correctly. 

 

 
 

In the image above various columns can be seen that will differ according to the type of 

accounting being worked on.  

 

In order to sum up correctly, it is necessary for the program to have, in the Group column of the 

row in which the total should be shown (row 10, Total ASSETS in the example), the same 
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number or code that is shown in the Gr column of the rows to be added up (number 1 in the 

example). 

 

The numbers or codes in the Group, Account/Category and Gr columns can be chosen by the 

user and formed either by numbers, letters or a combination of both. The only numbers that must 

remain fixed are those in the BClass column: 1 for Assets, 2 for Liabilities, 3 for Expenses and 4 

for Receipts. 

When adding values, the program will correctly add the amounts to the Total Assets: 

 

 
 

This system of totaling functions on more than one level. 

 

Note: for a more detailed explanation about groupings, consult the individual chapters for the 

various types of accounting. 

 

3.5 File Menu 

In the File menu, there are the main commands to use when managing documents. The user can 

open more than one file at the same time. 
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3.5.1 Create a new file 

 

 
 

 Open the File menu 

 Select the New command 

 Select the desired file type 

 Confirm by clicking on OK 

 

It is usually easier to select an example/template that has already been set up and adapt it to the 

user’s needs. That way, the program creates a new file from the template. All the data and setup 

(language, decimal points) from the template file are copied. 

Once any necessary alterations have been made, the user must save the file to a new name (Save 

as…). 

 

3.5.2 New blank file 

When a new, blank file is created, some parameters must be input: 
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Language 

The desired language of the headers of the table fields must be selected. 

 

Decimal points for amounts 

In order to avoid accounting differences, the number of decimal points for the amounts is fixed 

for each file. Two decimal points are normally used, but there are currencies where decimal 

points are not required so 0 needs to be inserted. 

 

Decimal points for amounts in foreign currency  

If using multi-currency accounting, then it is necessary to define the number of decimal points 

for the amounts in the foreign currency as well. 

 

Rounding type 

The amounts are rounded up or down to the closest whole number. In the case of exactly half 

(for example: 100.5 / 101.5 / 102.5 / 103.5) the following systems are being used: 

 Banking (Half at even) is being rounded up or down towards the nearest even number (100 / 

102 / 102 / 104). 

 Commercial/Arithmetic (Half up) is being rounded up to the next whole number (101 / 102 

/ 103 / 104). In accounting, this is the system most used. 

 Compatible version 4. A minor precision is being used, which in very special cases, can 

bring forth a different rounding.  

 

Adress fields in accounts table 

When this option is activated, the Address view is created in the Accounts table. In this view, 

the user can enter the addresses of clients, suppliers and members. 

 

Just as soon as these values have been confirmed, a new file is created using the parameters 

inserted. 

The user can thus create different accounting files, in different languages, and with different 

decimal points. In order to change the language or the decimal points once the accounting file 

has been created, the accounting type must be converted by selecting Convert to new file in the 

Tools menu.  

 

3.5.3 Open a file 

To open an existing file, the user needs to use the Open command from the File menu and 

proceed with the following sequence of operations: 

 Open the File menu 

 Select the Open command 

 Select the folder where the file was saved 

 Double-click to open the file 

 

If there are two or more files open at the same time, the user can pass from one to the other by 

clicking on the appropriate icons in the toolbar, or by using the short-cut keys Ctrl+F6   . 

If the file has been protected by a password, then it must be given at the moment the file is 

opened. 

 

3.5.4 Save a file  

In order to save the inserted data, it is necessary to save the file before closing it.  
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It is advisable to periodically save files while working in order to avoid unnecessary loss of data. 

It is also recommended that back-up copies are regularly made on a CD or in other folders.  

The Save and Save as commands in the File menu both have the function of saving a file, with 

some differences:  

 

The Save as command is used when the user: 

 Saves a file to disk for the first time. 

 Gives a new name to an already existing file 

 Changes the file’s destination to another folder 

 Saves the file onto another disk (e.g. Save on a CD)  

 

Important: do not cancel the Save as or Save operations while they are in progress because of 

possible interference with the saving operation and then loss of part of the data. 

 

To save a file: 

 Open the File menu 

 Select the Save as command 

 Insert the desired file name 

 Confirm by clicking on OK 

 

The Save command is used to save to disk any changes on an already existing file. In this way 

the updated file substitutes the existing one. The file name remains unchanged.  

A file can also be saved by selecting the following icon from the toolbar . 

 

3.5.5 Automatic save  

In the dialog window that appears when selecting Program options, from the Tools menu, there 

are two options: Autosave (in minutes) and Create back-up copy. It is advisable to activate 

both of these options right from the start since they will ensure, in the first case, data 

automatically saved in temporary files (autobackup + file name) at each interval of time 

depending on the user and, in the second case, that the program creates a .bak copy.  

 

3.5.6 Close a file 

 Open the File menu 

 Select the Close command. 

If some changes have been made on a file and the user wants to close it, the user will be asked 

whether he/she wants to save the changes or not. 

 

3.5.7 Compatibility with previous versions 

The current version of the program is compatible with the earlier 3.0, 4.0 and 5.0 versions. 

When a file created using an earlier version is selected, the data will be converted automatically. 

When saving the file, the user will be informed that conversion has taken place. 

 

3.5.8 File and accounting properties 

The File and accounting properties command, activated from the File menu, enables to define 

the basic data of one’s own accounting: 
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The dialog window that opens shows the following tabs: 

 
Accounting Tab 

In this tab the user can input the data from his/her work file. The fields vary according to the 

type of accounting selected: 

 

 
 

Left and right headers 

These are the two empty cells at the top where any desired text can be inserted which will be 

used as a header for print-outs (left and right).  

 

Opening date 

The opening date is the date when the accounting begins. It can also be left blank. If a date prior 

to the opening date is inserted when entries are made, the program will give an error message.  

 

Closing date 

This is the closing date of the accounting. It can also be left blank. If a date greater than the 

closing date is inserted when entries are made, the program will give an error message.  

 

 

Basic currency 

The code of the currency in which the accounting is being handled.  When the code of the basic 

currency is being changed, the program changes the column headers for the amounts in basic 

currency using the new code.  
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Options Tab 

 

 
 

Transaction date required 

If this option is activated and then a transaction is entered without a date, there will be an error 

message. 

 

Recalculate totals manually (F9) 

If this option is activated, the program will not automatically recalculate the principal groups of 

the accounting file, but the user needs to use the F9 key.  

 

File from previous year 

By using the Browse button, the user can select a file from the previous year.  

If the Smart fill with transactions from previous year cell is activated, the program keeps the 

transactions from the previous year in memory, and offers them as Smart Fill while the user 

inputs new entries.  

 

Use the minus sign (-) as segments seperator 

When this option is activated, the segments have to be entered in the Transactions table with the 

minus (-) sign preceding the segment code.   

When this option is deactivated, the segments need to be entered with the colon sign (:), as in the 

chart of accounts. The colon needs to always preceed the segment code.  

 

Records (+/-) cost centers according to the category 

This function is active only for Simple accounting and Cash book. By activating this box, the 

amount is entered in the cost center (positive or negative) according to the category. 

 

If, instead, this option is not active, in order to enter a negative value, it is necessary to enter a 

minus sign before the cost center (-CC). 
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Address Tab 

 

 
 

In this tab data about the company or the individual whose accounting is being handled can be 

inserted. 

 
Foreign currency Tab 

 

 
 

This tab is only available in Double-entry accounting with foreign currencies. It presents the 

fields for the Exchange rate profit and loss accounts and for Currency2. 
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Note: for further details see the chapter on multi-currency accounting (chapter 7). For the Cash 

book and for Simple accounting, the Foreign Currency section is substituted by the section 

called Currency2, see chapter on Currency2 (para. 3.15) 

 
VAT/Sales tax Tab 

 

 
 

This tab only appears if an accounting with VAT/Sales tax is selected. 

 

VAT Account 

The Automatic VAT account, that is present in the chart of accounts, is defined here as default.  

In this case, the VAT account does not need to be inserted in the VAT Codes Table.   

 

VAT/Sales tax rounding 

This is where the user inserts how theVAT/Sales tax amounts should be rounded; if, for example, 

the user inputs 0.05, the VAT/Sales tax amounts will round to multiples of 0.05. 

 

Cost Centers 1, 2, 3 

For each Cost Center the user can select whether he/she wants to use the transaction amount, the 

amount inclusive VAT/Sales tax or the amount without VAT/Sales tax. 

 

Note: If one of these parameters is modified, the accounting must be recalculated. For more 

details on VAT/Sales tax, see paragraph 3.16 
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Other Tab 

 

 
 

Current language 

There are some file texts that the program generates automatically, (e.g. the lines of the Totals 

table, the transactions on the account card, and the printout of the Enhanced balance sheet); in 

this tab, the user can indicate the language for these texts (usually the same as the creation 

language). 

 

Creation language 

This is the language chosen and selected when the user creates an accounting file; this language 

is used for the column headers. If the user wants to change the creation language, then it is 

necessary to convert the file to a new one using the Convert to new file command in the Tools 

menu.  
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Password Tab  

 

 
 

The files can be protected by using a password. In this tab, the user can insert a new password by 

keying it in twice, the second time for confirmation. 

If the user wants to change an existing password, before entering the new password, he/she must 

first enter the old one. 

 

Note: using a password does not give a high level of protection. In order to render the data truly 

inaccessible to third parties, it is necessary to have the appropriate cryptographic software.  

 
Text Tab 

 

 



F U N C T I O N S  I N  C O M M O N  27 

 

B A N A N A  A C C O U N T I N G  

 

In this tab, freely input any data regarding the accounting file.  

 

Key 

In this field, input the reference text (e.g.: Address). 

  

Value 

In this field, it is necessary to input the value related to the key (e.g.: 515 St. Vincent Ave.). 

 

Modify 

This button saves all changes made to the key and/or to the value. 

 

Value=Key 

This button copies to the Value field the same text as in the Key field.  

 

Add 

This button saves the new inserted data. 

 

Remove 

This button removes the selected Key. 

 

3.5.9 Export file in MS Excel  

The user can export his/her own accounting file in a format compatible to Excel. 

  
Base Tab 

 

 
 

Export selection only 

When activating this option, the program exports only the selected area.   
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File Name 

In this area it is necessary to insert the name of the new file that the program will create to export 

the data. If, however, an existing file is selected by using the Browse button, the program will 

overwrite it with the new data.  

 

Display file immediately 

As soon as the MS Excel file has been created, the software to view it will be launched. In this 

way, the result of the export can be seen immediately. 

 

Options 

Create cell names 

This option will automatically give a name to each cell as the file is exported. For example, the 

cell that contains the balance for account 1000 will receive the name: "Accounts_1000_Balance" 

in Excel. This means the user can univocally identify each cell independently from its 

position on the sheet and thus create Excel reports that don't have to be corrected if the account 

plan is changed. The user thus saves having to manually carry forward any accounting data to 

Excel. However, inserting the names of the cells does slow down the opening of the Excel file. 

 

Create table names 

With this option, the program will automatically give a name to the whole area of the cells 

belonging to a table, at the moment the file is exported. For example, the area formed by the cells 

belonging to the Accounts table will be identified by the name DB_Accounts. This option is 

necessary if, when creating reports in Excel, database functions are used. 

 

Use names Xml (English) 

The cell names can either be defined in their original accounting language, or with their English 

name. In the original language, the names will be understandable to someone who speaks that 

language, but they will not be universally understood like a name in English would be. By 

selecting this option the user would have, for example, "Accounts_1000_Balance" instead of 

"Conti_1000_Saldo". 

 

Protect tables 

The entire content of cells is locked when selecting this option so that it is only possible to edit 

the format. This prevents the possibility of making any unintentional changes to the exported 

data. The user can remove this protection at any time by using the appropriate command in 

Excel. 
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Include Tab 

 

 
 

Recheck accounting 

By ticking this box, the accounting will be rechecked before it is exported. 

 

Include 

By ticking the different boxes, the user can export in MS Excel Xml the various tables and/or all 

the account cards and the VAT/Sales tax Report.  

 

Periods 

This function lets the user export the accounting data subdivided by periods with the account 

balances and/or the VAT/Sales tax Reports.  

 

Create periods for the whole year 

By selecting this function, the partial balances for the whole year will be exported, and not only 

the ones of the specified accounting period or the selected export period.  

 

Max number of periods 

The maximum possible number of periods. 
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Period Tab 

In this section, indicate the period of the data to be exported. 

 

 
All 

If this option is selected, the entire accounting period is included. 

 

Period selected 

If a specified period is desired, indicate the start and end dates. 
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VAT/Sales tax Tab 

 

 
 

The VAT/Sales tax tab for exporting files in MS Excel format is equal to the VAT/Sales tax 

Report command, which will be covered in para. 3.11.9. 
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Favorites Tab 

The functions in this tab allow the user to save export models with defined configurations, in 

order to avoid having to each time manually modify the selection of the options. 

 

 
 

Use selected 

When there is a list of different export models in the window, this button allows to choose one of 

them by selecting one.   

 

Duplicate 

Allows the user to duplicate an export model, in order to give the possibility to modify the 

desired configurations and create a new export model: 

 Click on “Duplicate” 

 Insert the name of the new exportation in the window and confirm with OK  

 Select the options of your choice in the different tabs  

 With the Preview, the configurations that have been chosen for the exportation are 

automatically being saved.   

 

Rename 

Allows the user to change the name of an already existing model.   

 

Delete 

Allows the user to delete an already existing model. 
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3.5.10 Export file in Html 

Exporting the accounting file in Html format enables the user to file the accounting and log on to 

it after many years, even if the program is no longer installed. 

The data filed in Html format are like print-outs. The totals are static, they are not recalculated. It 

is only necessary to have a browser like Mozilla or MS Explorer to view the data on screen and 

print it on paper.  

 
Base Tab 

 

 
 

File Name 

In this area, the user must insert the name of the new Html file that the program will create to 

export the data. If however the user selects an existing file through the Browse button, the 

program will overwrite it with the new data.  

 

 

Display file immediately 

As soon as the Html file has been created, the software to view it will be launched. In this way, 

the result of the export can be seen immediately. It is best to remember that browsers like 

Mozilla and MS Explorer use a cache mechanism for files. When the export is made for a second 

time, it is possible that the user will see the previous version until the browser Reload button is 

pressed. 

 

Table creation options 

Headers 1, 2 and 3 

These are the table headers. 

 
Include Tab 

The description for the Include tab is the same as the description already given for exporting the 

file in MS Excel Xml format (para. 3.5.9.) 
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Period Tab 

The description for the Period tab is the same as the description already given for exporting the 

file in MS Excel Xml format (para. 3.5.9.) 

 
Html Options Tab 

 

 
 

Use style sheet CSS 

Selecting this cell will allow the user to connect a style sheet to the exported file. By default the 

program will automatically use its own style sheets and incorporate it into the document. 

 

Use predefined style sheet 

The program’s default style sheet will be used. 

Deactivating the cell will automatically activate the External style sheet option. The user can 

then select the name of a personal style sheet. 

 

External style sheet 

In case an external style sheet is being used, select the file name of the style sheet with the 

Browse button.  

 

Include style sheet within html file 

When data is sent in Html format, the style sheet file must also be sent. To avoid sending two 

separate files the user can incorporate the style sheet to the Html accounting file by activating 

this cell. 

 

Selecting the cells will allow the program to file the data with various graphic options: 

 

Export visible columns only 
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Table with border 

 

Columns with headers 

 

Preserve page breaks within the table 

If there are page breaks on the original accounting file, these will be carried over in the export as 

well.  

 
VAT/Sales tax Tab 

The VAT/Sales tax tab for exporting files in Html format is the same as the one referring to the 

VAT/Sales tax Report command, which will be covered in para. 3.11.9. 

 
Favorites Tab 

The description for the Favorites tab is the same as the description already given for exporting 

the file in MS Excel Xml format (para. 3.5.9.) 

 

3.5.11 Export file in Xml 

Like the Html format, exporting in Xml format also allows the user to file his/her own 

accounting file with the possibility to access it after many years, even if the program is no longer 

installed.  
 

Base Tab 

 

 
 

File Name 

 

Display file immediately 

These descriptions are the same as the ones for the Export file in Html window (para. 3.5.10). 
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Style sheet XSLT 

In this area, the user can select the style sheet according to which the program should organize 

the graphic display of the accounting data. Thanks to the style sheets, the user can input his/her 

own data and conform to the print-outs required by the authorities. On the www.banana.ch 

various examples and further information on style sheets are available. 

Options  

It is possible to choose to export visible columns only and/or to export visible columns along 

with the view list. 

 
Include Tab 

The description for the Include Tab is the same as the description already given for exporting the 

file in MS Excel Xml format (para. 3.5.9.) 

 
Period Tab 

The description for the Period Tab is the same as the description already given for exporting the 

file in MS Excel Xml format (para. 3.5.9.) 

 
VAT/Sales tax Tab 

The VAT/Sales tax tab for exporting files in Xml format is the same as the one referring to the 

VAT/Sales tax Report command, which will be covered in para. 3.11.9. 

 
Favorites Tab 

The description for the Favorites tab is the same as the description already given for exporting 

the file in MS Excel Xml format (para. 3.5.9.) 

 

3.5.12 Export file in Pdf  

Exporting the file in PDF allows the user to record the data and to access them at whatever time. 

 

The tabs are similar to those of “Export file in Html” command, described in point 3.5.10, except 

for the Base tab which also includes  

the Page Options. 

 

http://www.banana.ch/redirect/banana60.php?&dlang=enu&cmd=xslt
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3.5.13 Printing 

Files can be subdivided into different pages by selecting the Page break command from the 

Format menu.  

Details for the page to be printed, for example, margins, headers, grid, page and row numbers, 

etc. can be defined in the Page setup window, from the File menu.  

 

To print the currently active table, proceed in two different ways: 

 

o Click on the Print icon on the Toolbar 

o Select the Print command from the File menu.  

 

The user can print a single page, a number of pages of choice or just some preselected rows. 

 

3.5.14  Print setup 

Using the Page setup command from the File menu, a window will pop up where various 

printing options for the active table and the current view can be chosen (for each table it is 

necessary to repeat these steps). Before printing, it is advisable to preview the page to see 

whether the details input for the page setup are correct.  
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Header left 

This is where the title for the current view is shown. The title can be edited to appear at the top 

left of the printed page.  

 

Header right 

It is possible to insert a different text that will be printed at the top right-hand side of the page.  

 

Margins 

It is possible to input the page margins here. Measurements are in centimeters. 

 

Include in print 

File Header 

This will be the text inserted in the File and Accounting properties found in the File menu.  

 

Table Header 

This is the text input in the Page setup window in the File menu (Header left and right). 

 

Auto text 

This is the text automatically attributed to the table by the program. This text cannot be edited by 

the user. For example, if the cash account card is being printed, then “Account Card: CASH” 

will be printed.  

 

Column headers 

These are the headers for the various table columns. 
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Large font 

The program prints the headers using a slightly larger font. 

 

Page break 

When activated, this option maintains the inserted page breaks; if not, they will be ignored, even 

if they are present. 

 

Page numbers 

Activate this option to request that the pages be numbered. 

 

 

Print time 

Activate this option to include the hour when the page was printed. 

 

 

Print date 

Activate this option to include the date when the page was printed. 

 

Row number 

Activate this option if a progressive number is to be given to each row. 

 

Grid 

The grid can be printed just as it is viewed on screen. 

 

Zoom 

Zoom % 

This allows the increase or decrease, on a percentage basis, of the size of the font to be printed.  

 

Reduce to page width 

If some columns exceed the width of the page, the program reduces (reduces the zoom) the 

printing so that all the columns will be printed correctly on the page. 

 

As on screen  

The print-out will be carried out exactly as presented on the screen. 

 

Print landscape 

To print in landscape format which makes the page read horizontal. 
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3.5.15  Print 

If the Print command in the File menu is used, the content of the table will be printed.  

 

 
 

Pages 

Input the desired page numbers to print, or leave blank to print everything. With the Start pages 

numbering option it is possible to start the page numbering from a number different than one.  

 

Copies 

Input the desired number of copies to print. 

 

Zoom 

Allows to increase or decrease, on a percentage basis, the size of the font to be printed.  

Shrink to page width 

When there are texts that exceed the printing margins, the size of the material to be printed will 

be reduced so that it fits the total width of the page, if this option is being activated.  

 

Selected rows only 

If some rows are selected from a table, this option is automatically activated and only the 

selected rows will be printed. 

 

All black and white 

This option makes the print come out in black and white. 

 

Preview 

The screen will show a print preview if this button is activated. 
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Page Setup 

This option allows the page definition to be edited for the active view. It is here where the user 

can define whether the page(s) should be printed horizontally or vertically. 

 

Printer Setup 

The button pulls up the Printer Setup window from Windows. The selections are only valid for 

the current working session. Permanent alterations need to be input using the Windows control 

panel. Horizontal or vertical printing needs to be input under Page Setup and is only valid for 

each view. 

 

3.5.16 Send file via Email 

By choosing this command from the File menu, the accounting file can be sent via email.  

An electronic mail message will be created automatically and the accounting file will then be 

sent as an attachment. 

 

 

3.6 Edit the data 

There are various ways of working on a table: 

 Select a cell and manually overwrite it with new data. If the previous data have not been 

cancelled, they will be cancelled automatically as the new texts are entered.  

 Select a cell or an area of cells and, by using the cut/paste function from the Edit menu, 

insert the new data. In this way the user only works on the visible cells and the data on the 

protected columns will not be edited.  

 From the Edit menu, select the option necessary (e.g. copy rows, cancel rows, duplicate 

rows, add rows, etc.). When using this command, the alterations will affect both the visible 

and the protected fields. 

 

Edit long texts 

If the inserted text is too long to be viewed in the text input area (the area below the toolbar), 

press Shift+F2 to see a dialog window with the entire content of the cell, thus simplifying the 

editing work. Press the OK button or hit Enter to close the window and confirm the alterations. 

If the size of the cell isn’t large enough to contain all of the text, either increase the horizontal 

size of the column or activate the Calculate row height command from the Format menu. It 

will automatically recalculate the vertical size of the cell so that the content can be viewed. 

 



42  F U N C T I O N S  I N  C O M M O N  

 

B A N A N A  A C C O U N T I N G  

3.7 Edit Menu 

 

 
 

3.7.1 The Undo/Redo commands 

Any operation can normally be deleted or, if deleted, it can be restored. 

The number of operations to be restored can be customized by selecting Program options from 

the Tools menu. The maximum number of operations that can be cancelled is 100. 

 

Important: the higher the number requested the more memory necessary.  

 

For each file, the program keeps a list of all the changes in the order they were made. The 

undo/redo functions work in the same order, but the user needs to always work on the same 

table. If, for example, a change in the Transactions table has been made and the user moves to 

the Accounts table, the user won’t be able to cancel an operation on the Transactions table from 

there. First, it is necessary to return to the Transactions table and then execute the Undo 

operation function; this rule also applies to the Redo operation. 

There are, however, operations that concern the entire file (e.g. changes made to the basic data) 

that can be cancelled no matter what table the user is in. 

 

The Undo Command 

This command allows the user to set an incorrect operation right, eliminating the effects of the 

last operation.  

From the Edit menu, select the Undo command, or use the shortcut keys Ctrl+Z. 

 

The Redo Command 

This command allows the user to restore an operation just cancelled.  From the Edit menu, select 

the Redo command, or use the shortcut keys Ctrl+Y. 

The user can also undo and redo operations using the following icons   
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Note: the Cut, Copy, Paste, Copy from above and Execute command commands have already 

been looked at in the paragraph Work Rapidly (para. 3.3).  

 

3.7.2 Insert rows 

This command allows the user to insert blank rows above the selected row.  

 Move the cursor below the row where additional rows need to be inserted 

 From the Edit menu, select the Insert rows command 

 In the window that appears, key in the number of rows to insert 

 Confirm by clicking on OK 

 

3.7.3 Add rows 

This command allows the user to insert blank rows below the selected row.  

 Move the cursor above the row where additional rows need to be inserted 

 From the Edit menu, select the Add rows command  

 In the window that appears, key in the number of rows to insert 

 Confirm by clicking on OK 

It is also possible to add rows by using the shortcut keys Ctrl+Enter or by clicking on the 

following icon . 

 

3.7.4 Duplicate rows 

This command allows the user to duplicate the selected row: 

 Move cursor to the row to be duplicated 

 From the Edit menu, select the Duplicate rows command. 

 

3.7.5 Copy rows 

 Select the row or the rows with the data to be copied  

 From the Edit menu, select the Copy rows command  

 Move to the place where the row or the rows need to be inserted  

 From the Edit menu, select the Paste rows command. 

The shortcut keys are: Ctrl+Shift+C 

 

3.7.6 Delete rows 

This command allows the user to delete rows by: 

 Selecting the rows to be deleted 

 From the Edit menu, select the Delete rows command 

 

3.7.7 Paste rows 

This command is similar to the cut/paste functions; however, the shortcut to activate it is 

Ctrl+Shift+V. 
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3.7.8 Protect and unprotect rows  

Using the Protect rows command, from the Edit menu, the user activates row protection to 

avoid making any changes by mistake. The protected rows cannot be edited until, by using the 

Unprotect rows command, the protection is being removed.  

To put protection into effect: 

 Select the desired row(s) to protect 

 From the Edit menu, select the Protect rows command 

 Confirm the number of rows to be protected by clicking on OK. 

 

Protected rows have light grey row numbers. In order to edit them again, first remove the 

protection by the Unprotect rows command in the Edit menu. 

 

 

3.8 Data Menu 

 

 
 

3.8.1 Search  

By selecting the Search command (shortcut: Shift+F3), a dialog window will pop up allowing 

the input of the search information.  

The text to be searched should be inserted in the same format as the one displayed in the input 

field. For example, the amounts should be inserted without the separator for the thousands.  
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Whole words only 

If this box is activated, the program will find whole words only. For example, if the word being 

searched is Tot, it will not find Totals. 

 

Match case 

If this box is activated, the program will make a distinction between capital letters and small 

letters. 

 

Selected area only 

If this box is activated, the program will only search the information in the selected area. 

 

In order to begin the search, click on the Find button. The first piece of information 

corresponding to the request will be selected. To continue the search and find the next piece of 

information, select the Search next command from the Data menu, or else use the F3 key. 

 

3.8.2 Replace  

The Replace command enables the user to search for information posted in the Search text area 

and replace it with text keyed into the Replace with area.   

The text to be searched and the text to be used as a replacement should be inserted in the same 

format as the one displayed in the input field. For example, the amounts should be inserted 

without the separator for the thousands. 
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The Whole words only, Match case and Selected area only options work in exactly the same 

way as described in the paragraph 3.8.1.  

 

Find 

This key begins the search of the data one by one. If the data in search is not present, the “Text 

not found” message will appear. 

 

Replace all 

This key will replace the desired data throughout the whole document at once.  

 

3.8.3 Rename 

This command allows the user to change the account or category number (accounts or categories 

table) and the VAT code (VAT Codes table), without having to enter the necessary modifications 

in the transactions.  

 

In order to rename, the user has to: 

 Position himself with the mouse on the cell that has to be changed (account/category number, 

VAT code)   

 Click on the Rename command in the Date menu.  

 

The software inserts the new modifications, connected to the Rename operation, automatically in 

the Transactions table.  

 

3.8.4 Go to 

Select the Go to… command from the Data menu to open a window allowing the user to move 

to a desired row.  

 

Note: when a selection table is active (for example, an account card), by using the Go to 

original row command, the program automatically takes the user to the corresponding row of 

the Transactions table. 

 

3.8.5 Extract rows 

If, for example, DATE is selected as the field, > (greater) as the condition and 19/4/2007 as the 

limit of comparison, the software will copy in the Selections table the rows with a date greater 

than 19th April, 2007.  
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All rows 

If this option is activated, all the rows in the current table will be copied to the Selections table. 

This command is used, for example, to sort the data using different criteria without, however, 

eliminating the previous order in the Transactions table.  

 

Selection  

Field 

This is a list of all table fields rows can be extracted from (e.g. The Transactions table has a list 

that contains the names Date, Doc, AccCredit, AccDebit, Amount, etc.). 

 

Condition 

This list contains all the conditions needed in order to select the rows to extract: = equal to, < 

less than, > greater than, <> different, <= less or equal, >= greater or equal, contains text, does 

not contain the text, blank, not blank. 

 

Comparison text 

In this field, insert text to be compared to the condition. For example, the condition is (=) equal 

to, and the user inserts as comparison text 15.01.2007, the program will extract all entries made 

on January 15
th

 2007. 

The text is a date if the field selected is a Date, a numerical value if the field is an Amount, a 

word if the field is a Description. 

 

Match case 

If this box is activated, the program will make a distinction between capital letters and small 

letters. 

 

Invert result 
If this option is activated, the program will select rows using the opposite criteria desired in the 

condition field. For example, if selecting, as a condition, all the rows with a date > 01/03/2007 

and activating the Invert result cell, the program will extract all the rows with a date <= 

01/03/2007. 
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3.8.6 Selections table 

This is a table that serves as a temporary container where the user can copy, view, and sort rows 

freely, according to current needs. 

 

To copy rows to the Selection table, it is possible to proceed in two ways: 

 Open the Data menu and click on Extract rows (see previous paragraph) 

 Double click on the cell containing a type of information. The user is then immediately 

transferred to the Selection table where all the rows that contain the same information can be 

found. 

For example, if in the Date column on the Transactions table, the user double clicks on 

30.01.2006, a table with the title Selections (Transactions) will automatically be opened and all 

the rows containing that date will be copied into this table.  

The title of the Selections table recalls the sequence of the executed operations. It is also possible 

to make a selection from the Selections table itself.  

In order to go back from the information on the Selections table to the information on the main 

table, double-click on the row number of the Selections table.    

 

3.8.7 Sort rows 

The rows on the table can be sorted according to the content of the fields. First of all, define the 

fields to use as a sorting key.  

 Open the Data menu 

 Select the Sort rows command 

 

 
 

First key, Second key, Third key 

There are three areas where the keys can be input and each one contains a list of field names 

from the current table. Choose how to sort each key. If the columns only contain numbers, then 

choose the Number option. 

 

Sort selected rows only 

This option is only available when rows have been pre-selected. If activated, only the selected 

rows will be sorted.  
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3.8.8 Export rows 

Unlike the Export file commands in Excel Xml, Html or Xml format that export the whole file, 

the Export rows command only exports the active table rows. 

 

3.8.9 Export rows in MS Excel  

The Export rows in MS Excel command (in the Data menu) allows the user to export data from 

the current table in the MS Excel Xml format.  

 

 
 

Export selection only 

This function is automatically activated when rows to be exported have been selected in a table. 

 

For a description of this window, please refer to the Export file in MS Excel (para. 3.5.9).  

 

3.8.10 Export rows in Html 

The user can export data from the current table in Html format. This format also exports any 

graphic characteristics so that the file can be easily recovered with a browser. The export takes 

place in the form of a table. The width of the export columns is based on the width of the 

columns as they appear in the active table. 

 
Base tab 

For a description of the Base tab, please refer to the one given for the Export file in Html 

command (para. 3.5.10). 

 
Html Options tab 

For a description of the Options tab, please refer to the one given for the Export file in Html 

command (para. 3.5.10). 
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3.8.11 Export rows in Pdf  

The Export rows  in Pdf command of the Data menu allows the user to export the data of the 

current table in Pdf format.  

 

 
 

The section is the same as the one of the “Export file in Pdf” command, described in point 

3.5.12. 

 

3.8.12 Export rows in Xml  

The user can export data from the current table in Xml format, which is an international standard 

for data sharing. This format exports the accounting data of the table so that they can be easily 

recovered with a database. 
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Base Tab 

 

 
 

Export selection only 

This function is automatically activated when rows to be exported have been previously selected 

in a table. 

 

For a description of this window, please refer to the one given for the Export file in Xml 

command – Base tab (para. 3.5.11). 

 

3.8.13 Export rows in txt 

 

 
 

Unicode (Utf-8)  
By activating this box, all data will be exported in a format readable by Unicode programs. 
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3.8.14 Using copy/paste 

Using the Copy/Paste commands, the user can export some areas or an entire table to other 

applications. The data is copied onto the clipboard, either in text or in Html format.  

 

3.8.15 Import rows 

The user can import data from other programs into the tables as long as they can be transformed 

into one of the formats listed in the Format area.  

Using the Browse button, select the file from which to extract the data. By clicking on the OK 

button, confirm the options selected.  

 

 
 

File name 
In this section, input the name of an existing file. 

 

Format 

This area contains the list of formats with which it is possible to import the data to the table. 

These include: ASCII format, Text, CSV.  

 

Import data from clipboard 

By selecting this box, the user can import data from the Windows clipboard. 

 

Autocomplete values 

It is advisable to select this function when it is necessary to import rows from a less complex 

accounting file into a more complex one. In this case, in the imported rows, some columns 

will stay blank. By selecting this function, the program will automatically complete the missing 

values with those from the current accounting. 

Fields header   

By selecting this box, not only data, but field headers will be included in the import. 

 

Unicode (Utf-8) 

By selecting this box, all the data will be imported in a format readable by Unicode programs. 

 

3.8.16 DDE connection 

Using the DDE connection, it is possible to set a connection between one cell on a table and, for 

example, an Excel spreadsheet.  



F U N C T I O N S  I N  C O M M O N  53 

 

B A N A N A  A C C O U N T I N G  

The user can even create macros and programs to pick up data from the accounting file.  

 

Note: the DDE connection offers substantial possibilities. Full documentation and up-to-date 

examples can be found on the www.banana.ch website. 

 

3.8.17 Set up fields  

The tables can be altered. Fields can be added, headers can be changed, and column sizes and the 

order in which they are shown can be altered.  

In the dialog window that pops up pressing the Set up fields command from the Data menu, the 

fields from the current table are listed with the keys to edit their attributes alongside. The title of 

the window carries the name of the view being edited.  

 

 
 

The fields are listed in the order in which they appear on the table being used. The visible fields 

are marked with an asterisk. 

The buttons beneath the field area serve to alter the order in which they appear. If, for example, 

on the Accounts table the user wants the Budget field to be the first column, just select the field 

and click on the Move up button until the field name reaches the top of the list.  

The Move down button works in the opposite way, making the field names fall towards the 

bottom of the list. 

 

Edit attributes 

This function opens a window where the user can input attributes to alter the protection, the 

visibility, the field header, the width of a column, and align the text. 

 

Edit data 

This function is used to alter the data of the fields input by the user, such as the type, size, 

maximum and minimum values. The system fields created by the program cannot be altered. 

 

Add a field 

This button adds new fields (columns) to the current table.  

 

http://www.banana.ch/
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Delete a field 

This function is used to delete a field (column) from the list. A system field, however, cannot be 

deleted. 

 

Page format 

This button is used to edit the format of the page. 

 

Note:  each View has its own page format. 

 

Move up 

This button allows the user to move the selected field towards the left of the table. 

 

Move up 

This button allows the user to move the selected field towards the right of the table. 

 

Note: for the Cash book and Simple accounting, the field list varies 

 

3.8.18 Edit attributes 

Each field has its own attributes for each individual View. The editing of an attribute is valid for 

only one View. In order to alter an attribute for all the views, repeat the operation in each View.  

 

To change the field attributes: 

 Open the Data menu 

 Select the Set up fields command 

 Click on the Edit attributes button 

 

The characteristics of the columns that can be edited are explained below, as well as the options 

and the buttons: 
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Field name 

This is the name of the active field and it is automatically inserted by the program. It cannot be 

modified. 

  

Field name Xml 

This is the name of the active field in the Xml format and it is automatically inserted by the 

program. It cannot be modified. 

 

Header 

This is the header for the column. 

 

Header 2 

This header is used by the program for only a few fields (e.g. Amount column). 

 

Description 

This is the description of the field. 

 

Format 

This is the format to show numbers, date and time (para. 3.8.19). 

 

Width 

This section defines the horizontal size of the column.  

 

Column Style  

This is a drop-down menu that indicates the style to be used (Format, menu, para. 3.9). This style 

has priority over the style of the row. 
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Alignment 

The user can choose whether to align the text right, left or center in this drop-down menu.  

 

Wrap text 

This option allows the user to view the input text on more than one line. 

 

Protected 

This option allows the user to protect the entire column so that no data can be input or edited. 

 

Exclude from printing 

When this option is activated, the field will be excluded from printing. 

 

Visible 

This option allows the user to make column visible. 

 

3.8.19 Edit date, hour and number format 

When the format is modified, the way the date, time and numbers are shown, changes.  

If no specific format is specified, the default Windows format will be used (date, time and 

numbers indicated on the control panel). 

In the Format area of the Set up fields/Edit attributes command    (Data menu) the user can use 

other formats. Types of formats, with some examples, are listed below: 

 

Format date Examples for date 

d mm yy 1 01 07 

dd m yy 01 1 07 

ddd mmm yyyy Fri Jan 2007 

dddd mmmm yyyy Friday January 2007 

The letter “d” (day) indicates the day, the “m” (month) indicates the month, and the “y” (year) 

indicates the year. 

 

Format time Examples for time 

hh:mm:ss:iii  04:04:36:089 

h:m:ss:ii  4:4:36:89 

Naturally the user can also invert the order of the elements making up the date or the time as 

desired (e.g.: mm dd yyyy). 

As far as the separators are concerned, the user can choose between all of those available on the 

keyboard (for example: #, @, -, /, ., etc.). 

 

Format numbers Example for numbers 

0.  259 

0.00  258.85 

0.000  258.848 

The number of decimal spaces in a number field can be edited according to the user’s needs. 

Actual calculations are made using all the inserted decimal numbers. Rounding is only done for 

what is shown on screen.  

 

Format text Description 

:link:  Insert and print a link. The text is interpreted as path to a document. 

:symbol: If :link: is set, instead of the full text a symbol representing a shortcut is 

printed. 
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:file: Print only the name of the path. The text is interpreted as path to a 

document. 

:n: Print only the firsts n characters. 

:-n: Print only the last n characters. 

:ellipsis: If :n: or :-n: are set and the text is cutted, an ellipsis “…” is inserted at 

the cut place. 

It is possible to combine the above formats. 

  

 Examples with “C:\Documents\card.pdf” 

:link: C:\Documents\card.pdf 

:link:symbol: >> 

:file: card.pdf 

:-14: ments\card.pdf 

:-14:ellipsis: …ts\card.pdf 

:link:file:6:ellipsis: car… 

 (a link is showed with an underline) 

 

 

3.8.20 Edit data  

It is possible to edit field data previously inserted by the user (system fields cannot be edited):  

 Open the Data menu 

 Select the Set up fields command 

 Click on the Edit Data button. 

 

 
 

Field name 

The program automatically inserts the name of the added field.  
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Field name Xml 

This is the field name for Xml format. 

 

Data type 

The user can choose from the following types of default data: Text, Number, Amount, Date, 

Time, True/False.  

Max and Min length 

These are the maximum and minimum field lengths. 

 

Max and Min value 

The user can insert maximum and minimum values here (numbers and letters). 

 

Decimal points 

The user can define the number of decimal points for the field here. 

 

All caps 

By activating this option, the field data will all be converted into capital letters.  

 

3.8.21 Add a field  

Click on the Add a field button in the View window, (Data menu, Set up fields command) to 

insert the desired characteristics for a new field added to a table. The descriptions for the fields 

are the same as given in para. 3.8.20. 

 

3.8.22 Delete a field  

Use this command to delete a field created by the user. 

System fields used by the software cannot be deleted. 

 

3.8.23 Page format  

This command activates the Page Setup window, already covered in para. 3.5.14. 

 

3.8.24 Select field view 

Using the Select field view command from the Data menu, a window appears where all the 

views present in the active table are listed, with the view currently in use highlighted.  
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Visible 

Activate this option to make a view visible in the bar at the bottom of the screen. 

 

System 

When this box is selected, it means that the view is a system view created by the program and 

that it cannot be eliminated.  

 

Select view 

Click on this button to select a View from the list. The active view is marked with an asterisk. 

 

Add 

To add a view to the list, click on this button and specify its name. Once it has been added the 

user can alter the field attributes.  

Page format 

This button opens a window that allows the user to edit the format of the page linked to the view. 

 

Delete 

This button deletes a view from the list. System views cannot be eliminated.  
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3.9 Format Menu 

 

 
 

The commands from this menu allow the user to choose the desired style for one or more rows at 

the same time: 

 Highlight the desired row(s) to be changed 

 Select the desired style from the Format menu 

 

3.9.1 Default style 

There is a default style for the whole file. When a new row is added, the default style is used.  

3.9.2 Set default style 

To change the default style: 

 Attribute the desired style to a row 

 Select the Set default style command from the Format menu 

All the rows with the original default style will then be shown in the new default style.  

  

3.9.3 Calculate row height 

When the text for a row is very long, the Calculate row height command from the Format 

menu allows the user to view it completely, adapting the height of the row. 

Activate this function on condition that, in the field attributes (Data menu, Set up fields 

command – Edit attributes button), the Wrap text option has been selected.   

 

3.9.4 Calculate all row heights 

This command operates in the same way as the previous command except that it works on all the 

rows in a table instead of only one. 
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3.9.5 Page break 

At any point in a file, the user can insert a page break  

 

To insert a page break: 

 Place the cursor on the first row where the new page is to be created 

 Open the Format menu  

 Select the Page break command 

 

To remove a page break: 

 Place the cursor on the row with the page break 

 Open the Format menu 

 Select the Page break command again  

 

3.10 Tools Menu  

 

 
 

3.10.1 File Info  

When the File Info command is selected, a table with all the statistical and informative data 

related to the file appears. It has complete information on the number of rows, errors, and 

warnings. 

Included in this data are the control numbers (Hash) which allow the user to verify whether the 

accounting has been altered in any way at all.  

The statistics have been created mainly to simplify the auditor’s task of rechecking the 

accounting. 

 

3.10.2 Add new functionalities 

This command allows the user the insert the Address view in the Accounts table, in which the 

addresses of clients, suppliers and members can be created. 

 

3.10.3 Create file copy  

This command creates a copy of the file with the possibility to select the indicated options in the 

window that appears:    
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3.10.4 Convert to new file  

This command converts an existing file with established settings to another with different 

characteristics. In the case of converting a file with more options into one that has fewer options, 

a part of the data will be lost during conversion. If, for example, an accounting file with 

VAT/Sales tax is converted into an accounting file without VAT/Sales tax, during conversion all 

data in the VAT columns will be lost.  

 

3.10.5 Merge file  

The user can merge files that belong to the same group. To merge the data of two different files, 

proceed as follows: 

 Open the file which will contain the data of both files 

 Select the Merge File command from the Tools menu 

 Select the path and the name of the file to be merged 

 Confirm the merge operation 

 If the files are not the same, even though they belong to the same group, (for example, 

accounting with VAT/Sales tax and accounting without VAT/Sales tax), a message will 

appear advising the probable loss of data.  

 

3.10.6 Program options 

In the Program options window, several technical options are possible for the accounting file. 
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Program language 

The Program Language is the language used by the program. Use this drop-down menu to select 

a language if the user wants to use a language different from the default or if the default is not 

available.  

 

Font type 

This drop-down menu allows the user to select the desired font. If the selected printer doesn’t 

print all the fonts, change the font with this menu. 

 

%Zoom 

If the user wants the data on the table to be shown in another size, adjust the percentage of Zoom 

here. 

 

Height of info-window (in rows) 

Insert the number of rows to be shown in the Information window. As soon as the number of 

rows has been changed, the height of the Information window is automatically adapted.  

 

Smart fill rows limit 

When inserting data, the program reads the data that has already been entered and tries to suggest 

how to complete an entry. In cases where there are many rows, this function could slow down 

the process.  

The user can define a limit for the number of rows, above which the smart fill will not be used. If 

there is no value entered or zero, smart fill will always be used.  

 

Automatic selection smart fill 

If this option is activated, the program automatically selects the first text suggestion that is being 

found in the drop-down list.  . 

 

Maximum number of undo operations 

Insert the maximum number of undo operations (one at a time) when using the Undo command 

from the Edit menu. 

 

Autosave (in minutes) 

This option allows saving the file automatically according to the desired frequency (in minutes). 

The program saves the data in a file called auto backup + file name. If the program or the 

computer crashes, the data can be recuperated by opening this file and saving it with a name 

(Save as…) from the File menu. 

 

Create backup copy (.bak) 

When the user saves to disk using the same name, the version of the file that already existed is 

renamed with a .BAK extension.  

 

Document Directory  

This is where the user inputs the name of the path (directory) in which the new files will be 

saved. 

 

Add up during selection 

By activating this cell, the program will add up the selected amounts. Deactivate this function if 

this instantaneous addition slows certain operations down. 
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Show recently used files  

In the File menu, all the most recently used files are listed.  

 

Caret always on 

The Caret is an indicator of the position of the mouse. It is generally used by programs that 

facilitate activity for the blind or partially blind.  

 

Check for updates 

This option establishes a connection to the www.banana.ch website and checks if there is an 

update compared to the version that is used.  

 

Download news 

By activating this option, the latest news items appear on the start page. 

 

Extensions of files considered secure 

This option defines the file types that the software consents to open with a double click on the 

DocLink column of the Transactions table. This prevents from opening non-secure files by the 

program.   

 

Associate “.ac2” files to this program 

This function indicates to the operational system that the .ac2 files should be opened through this 

program. 

 

 

3.11 Cash1/Simple1/Account1 Menu  

 

 
 

The Cash1, Simple1, and Account1 menus are the menus responsible for the main accounting 

operations. Below only the commands in common to all three types will be dealt with. 

 

3.11.1 Account/Category cards 

The account card gives a complete list of the accounting transactions for an account listed on the 

Chart of accounts.  

 

There are two ways to open an account or a category card: 

 Double click on a cell containing an account number or a category number. 

http://www.banana.ch/
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 Select the Account/Category Cards command (Cash book and Simple accounting) or 

Account Cards command (Double-entry Accounting) from the Cash1, Simple1 or 

Account1 menu, respectively. 

 

3.11.2 Account/Category cards characteristics 

Account card attributes 

On the account card, the title bar gives the account number and the account description. Just like 

all the other tables, the account card table also has views that can be edited (see the Set up fields 

and Select field view commands, para. 3.8.17 and 3.8.24 ). 

 

Always recalculate the account card 

The account card table is temporary and it is calculated when the command is given to do so. If 

transactions are altered or added, they are not automatically updated on the account card – the 

user needs to select the Account Cards command again.  

 

Go back to the transaction row 

From the account card, double-click on the row number to go back to the original line on the 

Transactions table. 

 

The Account/Category card window has four distinct tabs: Account/Category, Period, Options 

and Sort Fields. 
 

Accounts/Categories tab 
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Select Accounts/Categories 

If the user clicks on this button, all the accounts or the categories are automatically selected, 

excluding Cost centers. 

 

Select Cost centers 

If the user clicks on this button, only the Cost center accounts are automatically selected. 

 

Select All 

If the user clicks on this button, everything is automatically selected. 

 

Deselect all 
If the user clicks on this button, all previous selections are cancelled.  

 

Alphabetic sequence 

By activating this option, the accounts/categories are displayed in alphabetical order. 

 
Period tab 

 

 
 

All 

All the transactions will be included on the account card if this option is activated. 

Period selected 

Only transactions for a specified period will be included if this option is activated. 

 

Start date (inclusive) 

Insert the start date of the period. 

 

End date (inclusive) 

Insert the end date of the period. 
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Options tab 

 

 
 

Lines before end of page 

This function was created in order to avoid printing an account partially on one page and 

partially on the following. If the account card to be printed doesn’t have at least a number of 

lines correspondent to the number input in this field, printing the whole card will be moved to 

the next page. 

 

One account per page 

By activating this function, each card will be printed on a separate page (even those with few 

transactions). 

 

Repeat column’s headers 

By activating this function, the column headers will be repeated for each account, within the 

page. 

 

Include accounts with no transactions 

By activating this function, cards without transactions will be printed as well. 
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Sort Fields tab 

 

 
 

Transactions can be sorted according to different date criteria. If no criterion is specified, the 

exact order that exists for the transactions will be maintained. 

 

Note: to print the account cards: once all the parameters have been inserted, the account cards 

can be viewed on the screen by pressing “OK”. Proceed with the Print command in the File 

menu to launch the printing of the account cards.  

 

3.11.3 Journal by period 

This option allows the user to print the journals for a specified period of time. 
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Period tab 

By activating the All option it is possibile to print the whole period. By choosing the Period 

selected option, and by selecting a period (month, quarter, semestre or year), the program will 

automatically insert the correspondent dates. 

 

 
 
Sort Fields tab 

This tab allows the user to select the order in which to list transactions. 
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3.11.4 Recalculate balance and totals/Recalculate group totals (F9) 

When an entry is added or edited, the program executes automatically the Recalculate balance 

and totals/ Recalculate group totals command which updates:  

o the group totals of the Accounts and Categories table  

o the Balance column of the Transactions table (Cash book)  

o the exchange rate differences (Multi-currency accounting) 

o the Calculated balance column (Multi-currency accounting) 

 

If there are errors on the Categories table or on the Chart of Accounts (e.g.: group not found, 

infinite recurrence), error messages will be shown.  

 

Error: group not found 

A group not previously defined has been inserted in the Gr column. Find more information about 

groupings in para. 3.4.  

 

Error: infinite recurrence 

A group has been totaled in a group at a lower level. Find more information about groupings in 

para. 3.4.  

 

If, in the Options tab of the File and accounting properties, the Recalculate totals manually 

(F9) option is activated, the recalculation operation has to be executed manually by means of the 

Recalculate balance and totals/ Recalculate group totals command.  

 

Note: if the Recalculate balance and totals/ Recalculate group totals command is automatically 

executed, error messages will not be shown, but errors will only be indicated in the information 

window in the lower part of the screen.  

 

For more detailed information about the structure of the Categories table or the Chart of 

Accounts, see the individual chapters dedicated to the Cash book (chapter 4), Simple accounting 

(chapter 5) and Double-entry Accounting (chapter 6). 

 

3.11.5 Recheck accounting (Shift + F9) 

By selecting the Recheck Accounting command from the Cash1 (Cash book), Simple1 (Simple 

accounting) or Account1 (Double-entry) menus, or simply by hitting the Shift+F9 keys on the 

keyboard, all accounting will be rechecked and recalculated to ensure there are no errors or 

omissions. The program sets the totals at zero, recalculates and verifies the accounting, entry by 

entry, just as though the whole thing were to be rewritten. It even recalculates the VAT/Sales tax 

percentages (except for locked transactions). If there are many errors, click on the Don’t warn 

option. This way the messages will be saved in a message window and can be seen afterwards.  

 

3.11.6 Search for transaction differences 

The program always updates the total of all the Income/Expenses transactions (Cash book and 

Simple accounting) or Debit/Credit transactions (Double-entry Accounting) and signals any 

possible differences, usually due to incomplete transactions. The Search for transaction 

differences command finds the first entry in which the Income/Expenses transactions totals or 

the Debit/Credit transactions totals no longer match. As a precaution, whenever it is difficult to 

find the precise incorrect transaction, it is advisable to use the Recheck accounting command 

(Cash1/Simple1/Account1 menu, or Shift+F9 keys). 
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3.11.7 Enhanced statement 

Banana Accounting offers a schematic statement of the estate situation and the operating result 

of income and expenses using the Enhanced statement command from the Cash1 and Simple1 

menus.  

 

Note: in the Double-Entry Accounting the Enhanced Statement  command is replaced by the 

Enhanced Balance Sheet (paragraph 6.8.4). Furthermore, there is a supplementary command 

“Balance Sheet by groups” (paragraph 6.8.5) which is not available in the Cash book and the 

Simple Accounting.   

 

 
Base tab 

 

 
 

Page header 

Rows 1-4 

In these Rows, the user can freely define the Statement headers. 

 

Column header 

Initial date 

Insert the initial date of the accounting. 
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Final date 

Insert the final date of the accounting. 

 

Previous year 

Insert the final date of the previous accounting year. 

 

Print pages 

Activate any of the following boxes to define different options that will appear in the statement 

printout: 

 

Accounts 

Checking this box the accounts will be printed. 

 

Initial page 

Checking this box an initial page with the file headers will be printed. 

 

Categories 

Checking this box the categories will be printed. 

 

End of page after Accounts 

Checking this box the accounts and the categories will be printed on two different pages. 

 

Include in printout 

Check the different cells to decide which data should be included in the printout. 

 

Print, Preview, Cancel 

With these commands, one has access to the page setup, to the preview, one can cancel or launch 

the printing.  

Specifically, with the print button, it possible to save the document in several formats, by 

exporting the file in Pdf, Html, MS Excel and Copy to Clipboard. 

 
Period / Style / Margins / Texts / Favorites tab 

These sections are the same as those of the Enhanced Balance Sheet (paragraph 6.8.4). 

 

3.11.8 Accounting reports 

By clicking on this command, the amounts of the accounts can be viewed according to a certain 

grouping scheme, for a determined period or by subdivision.  
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Report tab 

 

 
 

Report 

Here the desired grouping scheme can be selected: 

 As on Accounts table 

 Accounts by class 

 External accounting report. Consult the following web page: 

http://www.banana.ch/cms/en/accounting_report. 

 

Options 

Here the accounts, to be included or excluded, can be selected: 

 Show group totals only 

 Include accounts with no transactions 

 Include accounts with 0 balance 

 Exclude groups without accounts 

How to obtain reports, consult paragraph 6.8.6. 

 

The Subdivision tab is equal to the one of the Enhanced balance sheet by groups, described in 

paragraph 6.8.5, while the Period and Favorites tabs are equal to the ones of the Enhanced 

balance sheet, described in paragraph 6.8.4. 

 

3.11.9 VAT/Sales tax Report 

The VAT/Sales tax Report command creates a summary of the VAT/Sales tax transactions and 

groups the totals on the basis of the options selected. The data has to be manually carried over to 

the VAT/Sales tax Report that needs to be completed periodically. 

http://www.banana.ch/cms/en/accounting_report
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Using the VAT/Sales tax Report command (Cash1, Simple1 and Account1 menus), a window is 

opened that gives various options: 

 
Period tab  

 

 
 

If the user selects All, a VAT/Sales tax summary will be compiled for the entire accounting 

period; activate Period selected to process just the determined period by inputting the start and 

end dates desired. 

 

If  the “1. Quarter...., 1. Semester...., Year” option is selected, the program automatically inserts 

the initial and final date of the chosen period.  
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VAT/Sales tax Tab 

 

 
 

Include transactions 

By activating this cell, all the transactions with VAT/Sales tax will be shown. 

 

Include totals by Account 

Activate this cell to show the totals relating to VAT/Sales tax transactions for each account.  

 

Include totals by Code 

By activating this cell, the VAT/Sales tax summary will include the totals for each code. 

Include totals by Percentage 

Select this option to get the totals for each VAT/Sales tax by percentage.  

 

Include unused codes 

By activating this option, also the unused codes of the VAT Codes table will be listed.  

 

Use own (Group, Gr) grouping scheme  

Activate this option to have the transactions grouped on the basis of Group or Gr (purchases and 

sales). If this is not done, the groups and recoverable totals will be created automatically. 

 

Sort transactions by  

By activating this cell, the transactions are sorted on the basis of a preselected option (Date, 

Doc., Description, etc….).  
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Partial report 

By specifying a code or a group in this field, and by activating the necessary options, the 

software calculates the total of the operations with VAT/Sales tax included only for the code or 

group specified. 

 
Favorites Tab 

Since this tab is present in several commands, we refer to paragraph 6.8.4 for its description.  

 

3.11.10 VAT Report table 

Operations subject to sales tax are totaled on the VAT Report table. 

This table is nothing less than an extract from the Transactions table where the columns specific 

to VAT/Sales tax totals are shown. 

 

 
 

Description 

This column gives a detailed description for each code. 

 

Taxable 

This column shows the amount on which the sales tax is calculated.  

 

Recoverable 

This column shows the VAT/Sales tax amount that can be recovered. 

 

Due 

This column shows the VAT/Sales tax amount due to tax authorities. 

 

Balance 

This column contains the sum of the amounts for each by code and by group. 

 

Note: to show the VAT ID number column on the VAT/Sales tax report, consult the chapter on 

VAT/Sales tax (para. 3.16). 
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3.11.11 Import to accounting 

There are various possibilities for importing data into the accounting file.  

 
Import transactions 

 

 
 

This option imports the transactions from various types of file, either from Simple accounting, 

Double-entry accounting or Cash book, in *.ac2 (Banana files extension) or *.txt format (text 

format). The user can also import a summary from the bank in MT 940 format (standard format), 

the receipt/payment transactions in a *.txt format, and text files with column headers. 

 

Browse 

Click on this button to indicate the name of the file the data will be imported from. 
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Import accounts 

 

 
 

This option imports accounts from a Double-entry or Simple accounting file (*.ac2) or a text file 

(*.txt), automatically integrating them on the current Chart of Accounts. 

 
Import VAT Codes 
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This function is only available in the accounting with VAT and allows the user to import VAT 

codes from an .ac2 file or from a text file with column headers.   
 

Import exchange rates 

 

 
 

This option is only present in Double-entry accounting with multi-currencies. It lets the user 

import the exchange rates from the Exchange rate table of another file or from an Exchange rate 

history file (*.ac2 format) or to import a text file with the column heading.  

 

Note: Exchange rate history files only show the Foreign exchange rate table and keep a record 

of past exchange rates.  

 

3.11.12 Import Cash book 

Sometimes the cash account is managed apart from the accounting and the transfer of the 

transactions from the cash book, grouped by category, executed in the accounting from time to 

time.  

Before starting to import data, it is necessary to set the Cash book file in the proper way: the 

codes on the Categories table must be equal to the accounts or categories in the Double-entry 

accounting or Simple accounting, or else it is necessary to view the “Category2” column and 

enter accounts or the categories codes to which the income and expenses of the Cash book refer 

to.  

For further information, consult para. 4.8 of the Cash book. 
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To import data: 

 

o Activate the Import to accounting command (Simple1, Account1) 

o Activate the Import transactions option 

o Select Cash book (*.ac2) 

o Indicate the file from which to take the data and confirm. 

 

 
 

In accounting 

Destination account 

This is the Double-entry or Simple Accounting account number to which the data will be carried 

over. 

 

Document number 

This is the document number given to the transactions carried over. 

 

Select transactions 

Start date / End date 

These drop-down menus specify the start and end dates of the period in which to import data.  

 

Group Transactions 

In this section the user specifies how the transactions of the period must be grouped: monthly, 

quarterly, by semester or yearly.  

 

Note: when the user is working on an accounting file with VAT, the calculations of the VAT may 

result slightly different. If the transaction amounts have been inserted as net amounts, the 

balance of the cash account may also be different because of rounding differences.  
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One transaction per account 

If more than one category is grouped on a single account but the user needs separate transactions 

for each category, this cell must be activated; then the program will create transactions for each 

category. 

When VAT codes are used, transactions will be created not only by category, but also for each 

different VAT code in the same category.  

 

3.11.13 Import Simple accounting transactions 

This command imports the transactions from a simple accounting file (*.ac2) in the current 

accounting:  

 

o Activate the Import to accounting command (Simple1, Account1 menus) 

o Activate the Import transactions option 

o Select Simple accounting transactions (*.ac2) 

o Indicate the file from which to take the data and confirm. 

 

In the window that appears, insert the desired data and choose the appropriate options: 

 

 
 

Select transactions 

Insert the start and end dates of the period related to the transfer of the transactions. 

 

Autocomplete values 

The option is only necessary with accounting with VAT/Sales tax and multi-currency. If 

activated, it allows the automatic completion of the values that are missing in the imported data 

(for example, the exchange rate in the exchange rate table or the VAT code for the transactions 

with VAT/Sales tax). 
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Complete the transactions with 

These options automatically activate when data from bank or postal account statements or receipt 

and payment transactions of an account in test format are imported. 

 

Initial document number  

This is the document number assigned to the first imported transaction. 

 

Destination account 

Insert the bank account number of the chart of accounts related to the imported extract. 

 

3.11.14 Import Double-entry accounting transactions 

This command imports the transactions from a double-entry (*.ac2) accounting file to the current 

accounting file. 

 

The procedure and the windows that appear are the same as  

para. 3.11.13, the only difference being the selection of “Import double-entry transactions.” 

 

3.11.15 Import transactions from bank or postal account’s statement  

The user has the possibility to import the transactions of his bank or postal current account to the 

formats provided by the Banana Accounting 6 version. For more information on the formats, 

consult the web page: New formats for import. 

 

To import the transactions: 

o Activate the Import to accounting command (Cash1, Simple1, Account1 menu) 

o Activate the option Import transactions  

o Select the appropriate format 

o Indicate the file from which to retrieve the data and comfirm. 

 

In the window that opens, insert the desired data.   

 

 

http://www.banana.ch/cms/en/node/1753
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The description of this window is the same as the description in para. 3.11.13, the only 

difference being that the “Complete the transactions with” section is active and allows the 

insertion of the initial document number and the destination account. The only thing missing 

from all the data imported is the balancing entry account that must be inserted manually. 

 

3.11.16 Import Receipt/payment transactions 

This allows the importation of data included in the columns in text format, relating to the receipts 

and payments of an account. 

 

The procedure and the informative windows that appear are the same as para. 3.11.13, the only 

difference being the selection of “Import Receipt/payment transactions.”  

 

3.11.17 Import Text file with column headers 

This allows the importation of the data of a file in text format. The condition to succeed in this 

operation is that the file columns to be imported should be given the same name used in the 

program for the Xml fields’ headers.  

 

The procedure and the informative windows that appear are the same as para 3.11.13, the only 

difference being the selection of “Text file with column headers.”  

 

3.11.18 Import accounts  

By activating the Import accounts option from the Import to accounting command (Account1 

menu), the program will take the accounts or the categories in the current accounting file, 

allowing to select from the options indicated in the following window: 
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Options 

Include Cost Centers 

 

Add new accounts 

When this option is activated, all new accounts are added to the accounting plan.  

Replace text description  

If already existing accounts are imported, but with different descriptions, the existing 

descriptions are replaced by the imported ones when this option is activated.  

 

Replace opening balance 

If already existing accounts are imported with different opening balances, the existing opening 

balances are replaced by the imported ones when this option is activated.  

 

3.11.19 Import exchange rates 

The Import exchange rates option from the Import to accounting command (Account1 menu) 

is available only for multi-currency accounting. The program automatically imports, in the 

exchange rate table, the exchange rates from a multi-currency accounting file, from an exchange 

rate history file (in *.ac2 format), or from a text file. Once one of the options has been chosen 

and the name of the file to take the information from has been indicated, the following window 

opens: 

 



F U N C T I O N S  I N  C O M M O N  85 

 

B A N A N A  A C C O U N T I N G  

 
 

Substitute exchange rates 

The imported exchange rates will substitute the existing ones if this cell is activated. 

 

Add rows 

If this cell is activated, all the exchange rates in the source file will be imported and, if necessary, 

the program will add new rows. 

 

 

3.12 Cash2/Simple2/Account2 Menu  

 

 
 

3.12.1 Sort transactions by date 

By selecting the Sort transactions by date command, all transactions on the Transactions table 

will automatically be sorted by date and the empty rows present in the Transactions table will be 

eliminated. 
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3.12.2 Show expiry dates 

When invoices sent or received are entered, in the Expiry date view (on the Transactions table) 

the unpaid invoices will be visible if this command is selected.  

 

 
 

In the Doc Date column, enter the invoice date.  

In the Date Exp. column, enter the payment deadline.  

Once the invoice has been paid, input the date paid on the same row in the Date Pay. column.  

 

 
 

The Show expiry dates command gives a list of pending invoices. According to the program, 

invoices are pending where there is an expiry date but no payment date.   

 

 
 

Note: the Show expiry dates command cannot be used if a transaction lock has been done.  

 

3.12.3 Recurring transactions 

In accounting there are transactions that repeat themselves from time to time. In order to avoid 

writing the same texts every time, one can recall these contents automatically, with the 

Recurring transactions command from the Cash2, Simple2, Account2 menu (that opens the 

Memorized text table) and in this way accelerate the work. When needed, select and copy the 

rows that are concerned in the Memorized text table.  

To copy rows to and from the Memorized text table use the Copy rows and Paste rows 

command in the Edit menu. 

 

Copy rows in the Memorized text table: 

 Select the rows to be copied and activate the command Copy rows 
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 Visualize the memorized text table with the Memorized text table command  

 Activate the Paste rows command  

 In the Doc column input a code (number or code) that the user will need when recalling the 

data in the Transaction table (e.g. the code for all transactions regarding the salaries could be 

sal) 

 

Recalling rows from the Memorized text table: 

 Insert in the Doc column the same code previously inserted in the memorized text table (e.g. 

sal) 

Hit the F6 key (the program will paste the memorized texts) 

 

3.12.4 Add link... 

Using this command, a link to a digital document is added in the DocLink column (Transactions 

table).  

 

 
 

3.12.5 Open link 

This command lets the user view the selected digital document on the basis of the 

link. Alternatively, the user can open the link simply by double-clicking on the cell containing 

the link. Only documents with a format considered to be secure will be opened from those placed 

in the Program Options command window from the Tool menu.  

 

3.12.6 Remove link  

This removes the link in the open cell. 

 

3.12.7 Lock transactions… 

With the Lock transactions command, the accounting transactions are blocked and marked with 

control codes that can certify, over the years, that the transactions have not been modified. This 

method (US Patent No. 7,020,640), based on electronic signature, guarantees one of the highest 

levels of data integrity since it can demonstrate with no doubt that the accounting has not been 

altered. It conforms to international law standards prescribing that accounting must not be 

changed. 
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New Lock Tab 

 

 
 

Date of new lock (inclusive) 

Specify the date up until when the transactions will be locked. 

 

Lock password (optional) 

It is possible to insert a password to eventually unlock the transactions or to carry out a new lock 

in the future. 

 

If the program finds no errors in the transactions included in the lock date, it will lock the 

transactions, calculate and assign individual numbers and codes to each row of transactions 

which can be viewed in the Lock view on the Transactions table: 

 

 
 

LockNum 

Every row of locked transactions receives a unique number that identifies it. The number is 

assigned progressively starting from 1. 

 

LockAmt 

This column contains the progressive sums of the transaction amounts. The lock amount is ideal 

for the legislations that require totals at the bottom of each page and the amounts carried forward 

to the next page.  
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LockLine 
This column contains the hash (control number) calculated on the basis of row content. This 

column is not seen automatically, but it can be shown by selecting the Setup fields command 

from the Data menu. 

 

LockProgr 
This column contains the progressive hash, calculated on the basis of the contents of the 

transactions that precede it. If this hash remains unchanged it means that the accounting data is 

original. 

 

The control numbers depend on the content of the transactions and their order. If the transactions 

are not altered, (original transactions), even if the user continues to hit the Lock transactions 

command, the recalculation of the numbers will always give the same result. If, however, any 

amount or the order of the transactions changes, the progressive hashes will be different. 

 

Note: In the Cash book, the total balance is not considered in the calculation of the progressive 

hash. 

 

At the end of the procedure, the program shows a report of the lock. 

 

 
 

If this report is printed and kept, it is possible to compare the values with those in the accounting 

file at any time, so as to be assured that the accounting data has not been modified. 

 

The report can be obtained anytime by accessing the Lock info tab from the Lock transactions 

command. 

 
Lock Info Tab 

The values of this tab are inserted automatically by the program. The program calculates the 

control codes (hash) and verifies that they are equal to those linked to the transactions. If the 

values match, the lock is considered valid; if they do not match, then modifications have been 

made to the data and the lock is not valid. 
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Lock valid 

There will be a “Yes” if the lock is valid. 

 

Date of actual lock 

The date inserted the last time that the Lock transactions command was executed. 

 

Last lock number 

The contents of the LockNum column of the last transaction are locked. If the lock is not valid, 

the following will be indicated: 

 

o The last “LockNum” number of the transaction in which the lock was found valid. 

o (-1) if the lock is not valid from the first row. 

o (-2) if there are rows that have the same LockNum. 

 

Date of last transaction locked 

This is the date of the last transaction locked.  

 

Last Amount 

This is the amount indicated in the “LockAmt” column of the last transaction locked. 

 

Last progressive hash 

This is the control code present in the last transaction. 

 

Report 

View the report of the locked transactions in a table. 

 

Note: if the transactions are not blocked, no values will be shown. 

  

3.12.8 Other methods 

Another method to ensure the integrity of the data is to export the file in Html format (Export file 

command from the File menu). The user can then provide the file with an electronic signature or 

else save it on a non rewritable CD. 
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Any time temporary protection of your data is needed in order to prevent the rows from being 

altered by mistake, use the Protect rows command from the Edit menu (para. 3.7.8)  

 

3.12.9 Unlock transactions… 

The Unlock transactions command removes the lock and the control numbers. If the lock was 

given a password, input the password again to unlock the transactions. 

As for locking the accounting again, the control number will be exactly the same as that of the 

previous lock if the data and the transactions order have not been changed. 

 

3.12.10 Create New Year 

Use this command when closing one fiscal year and beginning a new accounting file for the 

following year. It is possible to begin a new year even before finally closing the previous year. 

The Create New Year command creates a new file with the same Chart of accounts. The final 

balances for the previous year are carried over to become the opening balances for the New 

Year. The program also carries over the final balances to the Previous column 

(Category/Accounts table, Previous view). 

 

3.12.11 Update opening balances 

The Update opening balances command is used when a new year begins without closing the 

previous one.  

This command lets the user carry forward the definitive balances updating the opening balance 

column. 

 From the current accounting file (New Year), select the Update opening balances command 

 

 
 

 On the window that then appears, select through the Browse button the name of the file 

(*.ac2) of the accounting from the previous year in which the closing balances are given.  

 Follow the steps given on screen to share out the profit or the loss.  
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3.13 Window Menu  

It is possible to have more than one accounting file open at the same time and each accounting 

file will have its own window. The windows can be moved and their sizes changed according to 

the rules of MS Windows. 

 

 
 

3.13.1 New window 

This command allows the program to open a new window identical to the one in use. 

 

3.13.2 Hide current table 

This command closes the table in use; however, it only works with temporary tables (e.g. 

Selections table, Summary table, etc.). 

 

3.13.3 Tile horizontally 

If this command is selected, the windows are tiled horizontally, one on top of the other, using the 

whole screen. The Message Window, if active, is shown at the bottom of the screen.  

 

3.13.4 Cascade 

When this command is selected, the windows appear, one above the other, starting from the top 

left corner, so that the titles and the left border of the window are visible. If the Message 

Window is active, it is shown at the bottom of the screen. 

3.13.5 Arrange icons 

If the windows have been given an icon, they will be tiled, one beside the other, in the lower part 

of the screen with this command.  

3.13.6 Next window 

This command takes the cursor to the next window. 

 

3.13.7 Previous window 

This command returns the cursor to the previous window.  
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3.13.8 Warning messages 

If this command is activated, when an error occurs, a dialog box automatically appears showing 

the error message. Every error is also shown in the information window in the lower part of the 

screen, even if the Warning messages command is not activated. If the user doesn’t want the 

error message dialog box to be displayed, click on Don’t Warn, and the function will be 

deactivated. 

There are two ways to recall the error messages list: 

 Click on the Message Window command from the Window menu 

 Click on the Information icon from the Toolbar . 

  

From the Message Window, by double-clicking on an error row, the cursor returns to the table 

and the row where the error was generated. 

 

3.13.9 Message window 

This command activates the Message Window. 

 

3.13.10 Clear messages 

This command eliminates all the messages contained in the relative window. When the user 

rechecks the accounting, the program automatically clears the window.   

 

3.13.11 Start page 

This command brings the user back to Banana Accounting’s start page. 

 

3.14 Help Menu  

 

 
 

3.14.1 Index 

This command shows the index of the subjects. 

 

3.14.2 Banana.ch home page 

This command is a direct link to the Banana.ch SA website. 

 

3.14.3 Online support 

This command is a direct link to the Banana.ch SA support page on the website. 
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3.14.4 Check for updates 

This command is a direct link to the Banana.ch SA updates download page on the website. 

 

3.14.5 Registration 

This command is a direct link to the Banana.ch SA registration page on the website. 

 

3.14.6 Buy license 

This command is a direct link to the Banana.ch SA website where the license can be bought. 

3.14.7 Insert license key 

This command opens the following window and allows the insertion of all data related to the 

license key.  

 
License Key Tab 

 

 
 

License key 

Insert license key.  

 

Registration key 

The registration key will be inserted automatically by the program. 

 

Product 

The version of the product is shown. 

 

Expiration date 

The expiration date of the product, if one exists, is shown.  

 

Expiration notice (in days) 
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The frequency of the expiration notice can be personalized.  

 

Don’t show this dialog at startup 

In demo-versions, by activating this cell, this window is not shown anymore. 

 

Buy/Renew 

This button leads directly to the purchase page of www.banana.ch. 

 

Note: if the program is installed in a network, the license key must be inserted on the server. 

 
Full Tab 

In this section, the available applications in full version, without restrictions, are listed. 

 

 
 
 

http://www.banana.ch/redirect/banana50.php?&dlang=enu&cmd=shop


96  F U N C T I O N S  I N  C O M M O N  

 

B A N A N A  A C C O U N T I N G  

Demo Tab 

In this section, the available applications in the demo version are listed. 

 

 
 

3.14.8 Copyright and Info… 

This command displays an on-screen summary of the copyright information and the program 

version. 

 

 

3.15 Currency2 

By doing the accounting with the Cash book, Simple accounting or Double-entry accounting, the 

accounting file can be set up with a second currency. The main function of Currency2 is to be 

able to have the Balance Sheet, Profit & Loss Statement, Account cards and VAT/Sales tax 

Report not only in basic currency, but also in another currency.  

On each table, there is a view and some columns that relate to Currency2. The program converts 

the balances in basic currency to Currency2. 

Pay attention to the fact that the conversion can generate small rounding differences. 

 

3.15.1 Currency2 for Cash book and Simple accounting 

For Cash book and Simple accounting, Currency2 is input in the Currency2 tab of File and 

accounting properties (File menu). 
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Symbol 

Insert the initials for Currency2. 

 

Decimal Points 

Insert the number of decimal points for Currency2. 

Multiplier 

The multiplier is a number needed to get the actual exchange rate. Usually the multiplier is 1, 

100 or 1000. In fact, there are some currencies that are worth very little as a unit of 1, so in order 

not to use exchange rates with too many zeros, a multiplier is used. The multiplier can also be 

negative (-1). In this case, the program uses the inverse of the exchange rate (exchange rate = 1 / 

exchange rate).  

 

Foreign Exchange Rate 

Insert the exchange rate between the Currency2 and the basic currency.  This exchange rate is 

fixed. 

 

3.15.2 Currency2 for Double-entry accounting 

In Double-entry accounting, Currency2 is input under the Foreign currency section of File 

Properties (File menu). 
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Account for exchange rate profit/loss 

Indicate the account numbers destined for exchange rate profit or loss in these drop-down menus. 

 

Currency2 

Select the desired Currency2 initials from this drop-down menu. 

 

Exchange rate valid even from basic currency 

If an amount is exchanged and then exchanged back to the basic currency, the original amount 

might not be obtained. For example, if 0.43 is exchanged (with a 2.00 rate) 0.22 will be returned 

(rounded to 2 decimal points). If this amount is then exchanged back to the original currency at a 

rate of 2.00, 0.44 will be returned. There will, therefore, be a difference of 0.01 cents. Activate 

this box to get the original amount and to avoid rounding differences. 

For Double-entry accounting, the Currency2 exchange rate is defined on the Exchange Rate 

table. The program will always use the exchange rate from this table when it calculates amounts 

in currency2. 

 

 
 

Each time a new exchange rate is inserted during the course of a year, the totals must be 

recalculated and the account card in order to get the amounts in Currency2 updated according to 

the new exchange rate. 

 

 

3.16 VAT/Sales tax 

3.16.1 Select accounting with VAT/Sales tax 

 Select the New… command from the File menu. 

 From the window that appears, select the desired type of accounting and the template with 

VAT/Sales tax. 

 Confirm by clicking on OK 
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When working on an accounting file with VAT/Sales tax, in the Categories table (Cash book and 

Simple accounting) or in the Chart of accounts (Double-entry accounting), the user must have 

the corresponding VAT/Sales tax accounts. 

 

3.16.2 VAT Codes table  

Using the VAT Codes table, it is possible to define codes with different options for each code, so 

that working out VAT/Sales tax and making VAT/Sales tax reports will be carried out 

automatically by the program. 

 

The VAT Codes table has two views: 

 

o The Base view – where only the most used columns are shown 

o The Complete view – where all possible columns are shown 

 

 
 

The following columns are included in the VAT Codes table (Complete view): 

 

Group 

Enter the Group code. If there is a Group, a code cannot be present.   
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Code 

Enter the code for the tax rate.  

 

Description 

Enter a description for the code or the group. 

 

Gr 

Enter the Group code to which the VAT code refers. It has to be an already existing Group.  

 

Gr.1 

When the Xml reports are being used, this column contains the data that the report must use to 

group the VAT codes. For more information on the values to be input in this column, refer to the 

description of the Xml format being used.  

 

Gr2 

For each code, insert the reference number of the official VAT form. This form is to be sent to 

the tax authorities.  

 

Due 

When Yes is inserted in this column, it indicates VAT/Sales tax to pay. When the cell is blank, 

then it is recoverable VAT/Sales tax.  

 

Amount type 

In this column, different options are possible for each VAT code: 

o 0 or blank cell = with VAT/Sales tax  

o 1 = without VAT/Sales tax 

o 2 = VAT/Sales tax amount 

According to these options, in the Amount columns of the Transaction table, it is necessary to 

enter the gross amount, the net amount or only the VAT/Sales tax amount.  

 

% VAT 

This column indicates the rate as a percentage. 

 

VAT % on Gross  
This column is used only in special cases, foreseen by some legislations, where the sales tax 

percentage refers not to the taxable portion but to the gross amount (the amount including sales 

tax). In such cases, insert “Yes”. 

 

An example of when the VAT % on Gross column remains empty (in most cases) is as follows: 

 

VAT % Taxable amt. 
VAT 

amount 

Gross 

amount 

10% 1000 100 1100 

 

An example of when to insert “Yes” in the VAT % on Gross (special cases) is as follows: 

   

VAT % Taxable amt. 
VAT 

amount 

Gross 

amount 

10% 990 110 1100 

 

In the above example, the effective sales tax percentage becomes 11.11%. 
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VAT account  

Indicates into which account of the chart of accounts the VAT amount is being entered. If there 

is no account in this column, the software enters the VAT in the automatic VAT account, set up 

in the chart of accounts and inserted as “default” in the File and Accounting Properties, VAT tab. 

If there are several accounts set up in the VAT table (f.i. VAT due, recoverable VAT), in this 

case the software does not take into account the default VAT account (inserted in the File and 

Accounting Properties), but the VAT is entered into the VAT accounts defined by the user. 

 

Round Min  

Insert the number of desired decimal spaces to be rounded in this column. 

 

Don’t Warn 

There are some transactions that the program might interpret as errors which, in effect, are 

correct. To avoid the program sending error messages in these cases, insert Yes by the relevant 

codes. 

 

Note: when changing a VAT/Sales tax rate, recheck the accounting to have all the transactions 

updated (if they have not been locked). 

 

3.16.4 Importing VAT codes 

Importing VAT codes is useful:  

 when a new acconting is being created, without a configured VAT table 

 each time when the government enforces new rates.  

In the first case, the VAT codes can directly be imported from an accounting file that is already 

in use: 

 

o In the Account1 menu, click on Import to accounting 

o Select Import VAT codes and Accounting file (*.ac2) 

o With the Browse button, select the *.ac2 file, from which to import the VAT codes and 

confirm with OK 

In the second case, the VAT codes with the new rates can directly be downloaded from our 

internet site www.banana.ch: 

 

o Download from the internet site www.banana.ch the indicated file for the new VAT 

codes.   

o In the Account1 menu, click on Import to accounting 

o Select Import VAT codes and Text file with column (text file*.txt) 

o With the Browse button, select the saved file with the new VAT codes and confirm with 

OK 

 

3.16.4 Connect a VAT code to an account or a category 

In the accounting plan it is possible to match costs and revenues to an account (Double-entry 

accounting) or a determined VAT code to income/expense categories (Cash book and Simple 

accounting). With this operation, the program will automatically complete the transactions with 

the VAT/Sales tax as soon as the account (to which a specific VAT code has been linked) is 

typed in.  

 

To link the VAT codes to the accounting plan: 

 Make the “VAT code” column visible in the Accounts table 

http://www.banana.ch/
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 Insert the appropriate VAT/Sales tax codes to the desired accounts or categories. 

 

 
 

3.16.5 Transactions with VAT/Sales tax 

If an accounting file with VAT/Sales tax is chosen, on the Transactions table there are some 

additional columns for working out VAT/Sales tax. Before enter accounting operations, the VAT 

Codes table must be set up correctly. 

 

 
 

Amount  

In this column the user may insert the gross amount (the most common choice), the net amount, 

or just the VAT/Sales tax amount according to what was previously input on the VAT Codes 

Table (see also para. 3.16.2): 

 0 or blank cell = VAT included – insert the gross amount in the Transactions table;  

 1 = VAT excluded – insert the net amount in the Transaction table; 

 2 = VAT amount – insert only the VAT/Sales tax amount in the Transactions table. 

 

VAT Code 

For each transaction input a code that already exists on the VAT Code table in this column. 

 

%VAT  

This column shows the VAT/Sales tax percentage. The program automatically picks up the rate 

from the VAT Codes table, according to the code inserted. 

 

%Eff. 

This column shows the program’s calculation of the percentage with reference to the net amount. 

This differs from the normal percentage when it refers to the gross amount.  

 

Taxable  

Once the VAT code has been input, the program will automatically indicate the taxable amount 

(the amount less VAT/Sales tax). 

 

Amt. VAT 

The program automatically indicates the VAT/Sales tax amount in this column. 
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VAT A/C 

This is the column that shows the account where the VAT/Sales tax will be entered. It is 

automatically picked up from the VAT Codes table. 

 

% Exempt 

This column shows the percentage that cannot be deducted. In cases where not the entire 

VAT/Sales tax amount is deductible, insert the relative percentage of non-deductibility. On the 

basis of the VAT/Sales tax amount and this percentage, the Accountable VAT/Sales tax amount 

will be calculated. 

 

VAT Acc 

This column shows the VAT/Sales tax amount entered on the VAT/Sales tax account. The 

amount of the recorded VAT/Sales tax doesn’t always correspond to the one in the VAT/Sales 

tax amount column. For example, in cases where VAT/Sales tax amounts are only partially 

deductible, the amounts will be different.  

 

VAT Number 

When an entry with VAT/Sales tax is inserted in this column, the user can specify the VAT/Sales 

tax number of the client/supplier or debtor/creditor. The user can also insert in an account, in the 

Chart of accounts, the corresponding VAT/Sales tax number, and the program will automatically 

pick it up for the VAT/Sales tax report, without the user having to rewrite it each time. 

 

Note: the VAT ID number is normally used for the debtor/creditor accounts or for cost centers 

when used to manage debtors/creditors. 

 

To make transactions with VAT/Sales tax, proceed as follows: 

 

Example of a sale with VAT/Sales tax 

 

 
 

When the VAT code is inserted for sales (S10), the program automatically fills in all the other 

columns. 

 

Note: If the parameters of the VAT codes (VAT codes table) are changed, the transactions will 

not change immediately, but only after the accounting has been recalculated. However, the 

VAT/Sales tax values of the rows that were locked are not recalculated.   

 

3.16.6 Reverse VAT/Sales tax transactions  

When there is a balancing entry subject to VAT/Sales tax, in order to reverse a previously-made 

transaction, invert the accounts from the previously-made entry or enter them as the fiscal 

authorities suggest.  

For the VAT code, use the same code but it must be preceded by a minus sign (instead of S10 

key in –S10). 
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The program will correct the VAT/Sales tax in the VAT/Sales tax Report. 

 

3.16.7 Discounts and Reductions  

Discounts and reductions on invoices must usually be shown separately on the VAT/Sales tax 

declaration. Therefore, the user should not use the minus sign before the VAT code but rather 

create a specific VAT code for discounts and reductions. 

 

3.16.8 VAT/Sales tax not completely deductible 

In accounting files with VAT/Sales tax, in the Transactions table there is also the Non Ded.% 

column (non deductible percentage). 

There are cases where the VAT/Sales tax on purchases or on other costs is not completely 

deductible, so from the VAT/Sales tax amount actually paid, only a part can be taken into 

account. For this kind of problem, insert the percentage that is not deductible in the Non Ded.% 

column. The program will then automatically input the VAT/Sales tax amount that can actually 

be deducted in the Accountable VAT/Sales tax column. 

 

Example of a transaction: 

 

 
 

3.16.9 VAT/Sales tax paid in cash at moment of import 

When goods are imported, the VAT/Sales tax is paid directly to customs. In order to transfer the 

VAT/Sales tax amount to the VAT/Sales tax Report, it is necessary to have a type 2 VAT code in 

the VAT Code table (in the Amount type column). 

 

 
 

3.16.10 VAT/Sales tax Report  

Data for the VAT/Sales tax Report elaborated by the program must be entered manually on the 

VAT/Sales tax Report form that must be handed in to the tax authorities. This report varies from 

country to country; therefore there is no automatic pick-up for printing the data. 
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Note: the VAT/Sales tax Report has been covered in para. 3.11.9  

 

3.16.11 VAT/Sales tax Report 

Everyone subject to VAT/Sales tax has to present to the authorities a VAT/Sales tax Report at 

regular intervals (usually every three months). This is an official form where the data relating to 

sales, purchases and VAT/Sales tax amounts are shown. The purpose of the report is to show and 

declare the VAT/Sales tax to the debit and credit of the taxpayer. 

The ways to present this information vary not only from country to country but also on the basis 

of the size and type of the company. 

 

For the presentation, appropriate forms are used which very often differ.  

 

For each country, there are some common rules that apply to each VAT/Sales tax declaration: 

 The subdivision between VAT/Sales tax due and deductible VAT/Sales tax  

 The subdivision by VAT/Sales tax group percentages 

 The subdivision by type of VAT/Sales tax transaction 

 The need to print a journal of all transactions subject to VAT/Sales tax 

 The need to have a report by period.  

 

3.17 Centers of cost and profit 

In accounting terminology, there are centers of cost and/or profit when, alongside the 

accounting, it is necessary to manage some separate activities without altering the basic 

accounting plan. 

A cost center is outside the accounting because, in the case of Double-entry accounting, it is not 

included in the defined classes (Assets, Liabilities, Expenses, Revenue). 

Below we shall discuss cost centers and profit centers. From an accounting point of view, there 

is no difference between cost and profit centers. 

 

Example:  

All the expenses for running automobiles are entered on the “Auto Costs” account (insurance, 

gas, garage bills, etc.). When the user wants to know exactly how much is spent on gas without 

altering the Chart of accounts or the Categories table, add a cost center called “Gas” and, 

alongside all the transactions that relate to the purchase of gas, insert the initials that identify this 

new account. To see exactly how much the user has spent, open the Gas cost center by double 

clicking on the account code. 

 

3.17.1 How to create cost centers 

Cost center accounts must be inserted on the Chart of accounts or on the Categories table. In 

order to avoid confusion with other accounts, it is best to structure them at the end, after all the 

other accounts. The Cost centers accounts are added just like any other sort of account. 

It is possible to create up to three types of cost centers: cost center 1 (CC1), where the account 

initials are preceded by a full stop; cost center 2 (CC2) where the account initials are preceded by 

a comma, and cost center 3 (CC3) where the account initials are preceded by a semi-colon. 
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Warning: do not total the cost centers in the groups used for the accounting or the amounts will 

be doubled and the accounting will be incorrect. 

 

3.17.2 How to enter cost centers 

On the Transactions table, in the Cost Centers view, input the initials of the cost center in the 

appropriate column, without any punctuation. 

 

 
 

On the cost and profit center accounts it is possible to enter in plus (debit) or in minus (credit). 

The program usually enters any amount specified as a plus. If a minus is desired then the cost 

center account initials must be preceded with a minus sign (example: -CC). 

For the Cash Book and Simple accounting it is possible to activate the Records (+/-) cost 

centers according to the category option (File and Accounting properties, Options tab); in this 

case, the program enters the amount in the cost center according to how it is entered in the 

category. 

 

Note: for Double-entry accounting, cost centers can also be used to process a supplier and client 

ledger when it does not have to show up on the Chart of accounts. 

 

3.18 The segments 

The segments represent a kind of cost center. They distinguish themselves from the traditional 

Banana Accounting cost centers by the following characteristics:   

 They show the balances of an account or of a sub-account 

 They can refer to several levels of an account 
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 In the Transactions table, they can directly be inserted in the Debit or Credit account. It is 

therefore not necessary to enter them in separate columns.   

 The reports of the segments are automatically being calculated by the program and can by 

distinguished by period  

The segments can be very useful for the management of building sites, real estate and projects.  

 

3.18.1 Structure of the segments 

The segments have to be configured in the Accounts table at the end of the chart of accounts. 

They can have several levels, those of the first level being preceded by “:”, those of the second 

level being preceded by “::”,those of the third level being preceded by “:::” and so forth. There 

are no limits to the levels.  

 

For the configuration, proceed as follows:  

 Insert the title “Segments” in the Description column 

 Insert an asterisk in the Section column 

 Insert the description of the first-level segments, and in the Account column, insert “:” 

 List the segments of the first level, entering an identification code for each one of them in the 

Account column, preceded by “; then proceed with the description and the GR.  

 Proceed by entering the segments of the second level (and, if necessary, those of the third 

level), in the same way as those of the first level, with the only difference that the segment 

codes need to be preceded by “::” or by “:::”, depending on their level. 

 

 
 

3.18.2 How to enter the segments 

The segments are being entered in the Transactions table. Each segment is preceded by the 

colon, or by the minus sign (-), in case the option Use the minus sign (-) as segments separator 

has been activated in the File and Accounting properties (File menu). 

The use of the colon “:” in the segments is advised when there are account codes with a minus 

sign in the Chart of Accounts.  

When a segment that belongs to more than one level needs to be entered, the segment of the first 

level needs to be entered right after the main account; then, continue with the code of the second 

level.  
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3.18.3 How to obtain reports of the segments 

The reports of the segments can be automatically obtained with the Enhanced balance sheet by 

groups command or by the Accounting reports command in the “Subdivision” tab. 

 

For more information, check paragraph 6.8.6. 
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4 Cash book 

To create a new Cash book file, startup the program and from the New command (File menu) 

select one of the existing accounting types. 

 

 
 

Various types of Cash book: 

 Cash book 

 Cash book with VAT/Sales tax 

 Cash book with a second currency  

 Cash book with a second currency and VAT/Sales tax 

 

 

4.1 Cash book tables 

The Cash book is made up of the following main tables: 

 

 
 

Accounts 

In this table, insert the account to be managed (e.g. cash, bank a/c, post a/c, etc.) 

 

Categories 

This table shows a list of all categories of income and expenses. 

 

Transactions 

This is the table where all the accounting transactions are input. 

 

VAT Code (when selecting the VAT/Sales tax option) 

This is the table where the various VAT codes are defined, but it is available only if a Cash book 

with VAT/Sales tax is selected. 

 

There are also secondary tables used to view the data: 
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Account card/Category card 

This is the table shows the transactions of the predefined account, a single category or a cost 

center. 

 

VAT/Sales tax Report (when selecting VAT/Sales tax option) 

In this table, the user can view the sales tax report, but it is available only if a Cash book with 

VAT/Sales tax is selected. 

 

 

4.2 Accounts table 

In this table, enter the data of the account to be managed.  

 

 
 

Account 

In this column, enter the code/number for the account to be managed. The predefined text can be 

changed. Only one account can be inserted.  

 

Description 

Enter the account description. 

 

Opening 

When starting a new accounting file, enter the opening balance for the account to be managed. 

 

Income 

This column shows the total income for the account. 

 

Expenses 

This column shows the total expenses for the account. 

 

Balance 

This column indicates the difference between income and expenses for the account. 

 

 

4.3 Categories table 
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Group 

This column shows the group number/initial for totaling categories and groups. If there is a 

group number a category number cannot be inserted at the same time. 

 

Category 

This column shows the category number/initial to be used for transactions. If a category number 

is inserted, a group number cannot be inserted as well. 

 

Description 

Insert a free text to describe the group or category. 

 

Gr 

In this column, insert the number/initial of a group to which the account is to be totaled. It must 

be an already existing Group. 

 

Income 

The amount of the transactions being credited (income).  

 

Expenses 

The amount of the transactions being debited (expenses).  

 

Balance 

This column shows the difference between income and expenses. 

 

Note: other columns may exist, depending on the type of view being worked on.  

 

 

4.4 Transactions table 

 

 
 

Date 

This column shows the date relating to the current transaction. 

 

Doc 

This column shows the name or number of the accounting document. 

Description 

In this column, insert free text to describe the current transaction. 

 

Income 

This column shows the amount being credited. 

 

Expenses 

This column shows the amount being debited. 
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Category 

In this column, insert a category number from those defined on the Chart of accounts. 

 

Balance 

This column shows the difference between income and expenses. The amounts are automatically 

updated by using the Recalculate balance and totals (F9 key) command. 

 

 

4.5 Creating a Cash book file by using an existing template 

The program has pre-set templates and examples which can be changed according to the user’s 

specific needs.  

 

In order to personalize the Accounts table, enter the code, the description and the opening 

balance for the desired account to be managed (cash or bank a/c or post a/c, etc…). 

 

In order to personalize the Categories table: 

 Eliminate some categories and/or add new ones 

 Change the categories codes 

 Change the description 

 Add or delete groupings 

 

To delete a category, click on the row number, select the Edit menu, and then the Delete rows… 

command. 

 

To add a new category, insert a new row, and then key in the category code, description and the 

group it belongs to. 

 

To alter the code for a category, place the cursor on the category code to be changed, click, and 

key in the new code. Proceed to alter the description in the same way. 

 

To add or delete any sub-groups on the Categories table, it is necessary to understand the 

grouping and totaling system used by the program, explained in para. 3.4. 

 

 

4.6 Creating a new Cash book file 

To create a new Cash book file starting from zero, select the New command in the File menu, 

then select the desired type of file and the New blank file template (without data, without chart 

of accounts, etc.). 

 

 Input the basic accounting data and save it (Save as…)  

 Go to the Accounts table and enter the code, the description and the opening balance for the 

account to be managed (cash or bank a/c or post a/c, etc…). 
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 Go to the Categories table and enter the categories; it is advised  to begin with the main 

groups:  

 

 
 

 Total Income – where the income is totaled 

 Total Expenses – where the expenses are totaled (in minus) 

 Total – where the opening balance, the income total and the expenses are totaled (in minus). 

 

Note: it is possible to insert cost and profit centers; see para. 3.17 of the Functions in common. 

 

Then input the account codes, the descriptions and the Gr which should be equal to the Group in 

which the accounts will be totaled. 
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Example: 

 

 
 

 The categories from 100 to 112 are in Gr 1, meaning Group 1 that adds up the Total Income.  

 The categories from 200 to 250 are in Gr 2, meaning Group 2 that adds up the Total 

Expenses. 

 The Total Income and Expenses are in Gr 00, meaning Group 00 where the Total Income and 

Expenses are added together (Total). 

 

4.7 Insert transactions 

Before entering any transaction, insert a sufficient number of empty rows.  

 

To make a transaction: 

 Input the date, document number and description 

 Input the amount in credit or debit depending on the type of transaction. 

 Input the category number in the Category column 

 

The update of the categories, the balances in the Transctions table and the totals in the Categories 

table, is immediate and automatic.   

 

Transaction example: 
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4.7.1 Transactions with a second currency (Currency2) 

When a Cash book file with a second currency is selected, enter the symbol for currency2 in the 

basic accounting data (File menu, File and accounting properties command), and its exchange 

rate to the basic currency. It is a fixed exchange rate necessary to have an approximate 

calculation of the accounting in the second currency.  

 

 
 

The amounts in the second currency are shown in the Currency2 view from the Categories or 

Accounts tables. 

 

 
 

Note: in the Accounts table of the Cash book only the predefined account is shown. 
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When the user double clicks on an account or category number, the account card in Currency2 is 

shown. 

 

 
 

 

4.7.2 Transactions with VAT/Sales tax 

Before making any transactions with VAT/Sales tax: 

 Enter the categories with VAT/Sales tax on the Categories table  

 Enter the VAT codes on the VAT Codes Table 

 Enter on the VAT Codes Table, for each code, the relative VAT/Sales tax category. 

Entry example: 
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To make a transaction: 

 Enter the date, document number and description 

 Enter the amount of either income or expense, depending on the transaction 

 Enter the category number in the Category column  

 Enter the code relating to the operation in the VAT Code column  

The program will signal any possible error in the lower information window. 

 

Note: for more information on transactions with VAT/Sales tax, see para. 3.16 of the Common 

functions. 

 

4.7.3 Transactions with cost centers 

For transactions with cost centers, see para. 3.17 of the Common functions. 

 

 

4.8 Link to Double-entry accounting 

When the petty cash is managed outside an accounting file, from time to time, it is necessary to 

carry the various category transactions in double-entry and simple accounting. 

 

To carry out this operation, it is necessary to complete one of the following:  

 The Cash book categories must be the same as the accounts (double-entry accounting) or as 

the categories (simple accounting) of the accounting 

 In the Category2 column (Categories table) the user must enter the same accounts (double-

entry accounting) or categories (simple accounting) of the accounting. If the Category2 

column is not visible, it can be viewed by selecting the Set up fields command from the Data 

menu, then activating the “Visible” cell. 

 

 
 

To carry over the data, proceed as follows: 

 Open the double-entry or simple accounting file 

 From the Account1 or Simple1 menu select the Import to accounting command 

 Select the Import transactions – Cash book (*.ac2) option 

 Indicate the Cash book file from which to import the transactions. 

 

Note: for more information see para. 3.11.12 of the Common functions. 
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5 Simple accounting 

To open a new Simple accounting file, startup the program and select the New command from 

the File menu. 

 

 
 

Various kinds of Simple accounting: 

 Without VAT/Sales tax 

 With VAT/Sales tax 

 With a second currency  

 With a second currency with VAT/Sales tax 

 

5.1 Simple accounting tables 

Simple accounting is made up of the following main tables: 

 

Accounts 

This table is where all of the estate accounts are listed. 

 

Categories 

This table lists all expenses and income. 

 

Transactions 

This table is where all the accounting transactions are entered. 

 

VAT Code (when selecting the VAT/Sales tax option) 

This is the table where the various VAT codes are defined, but it is available only if a Simple 

accounting with VAT/Sales tax is selected. 

 

There are also secondary tables used to view the data: 
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Account card/Category card 

This table is where the transactions of a single category, a cost center or an estate account are 

shown. 

 

VAT/Sales tax Report (when selecting the VAT/Sales tax option) 

This is a table where the sales tax report can be viewed, but it is available only if a Simple 

accounting with VAT/Sales tax is selected. 

 

 

5.2 Accounts table 

 

 
 

Group 

This column shows the group number/initial for totaling categories and groups. If a group 

number is inserted, an account number cannot be inserted as well. 

 

Account 

This column shows the account number/initial to be used for transactions. If an account number 

is inserted, a group number cannot be inserted as well. 

 

Description 

In this column, enter free text to describe the group or category. 

 

Gr. 

In this column, insert the number/initial of a group in which the account is to be totaled. It must 

be an already existing Group. 

 

Opening 

This column shows the opening balance on the account. 

 

Income 

This column shows the amount of the transactions credited to this account. 

 

Expenses 

This column shows the amount of the transactions debited to this account. 

 

Balance 

This column shows the balance for each account (difference between income and expenses). 

 

Note: other columns may exist, depending on the type of view that is active.  
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5.3 Categories table 

 

 
 

Group 

This column shows the group number/initial for totaling categories and groups. If a group 

number is inserted, a category number cannot be inserted as well. 

 

Account 

This column shows the account number/initial to be used for transactions. If a category number 

is entered, a group cannot be entered as well. 

 

Description 

In this column, enter free text to describe the group or category. 

 

Gr. 

In this column, input the number/initial of a group in which the category is to be totaled. It must 

be an already existing Group. 

 

Income 

This column shows the amount of the transactions credited to this category. 

 

Expenses 

This column shows the amount of the transactions debited to this category. 

 

Balance 

This column shows the balance for each account (difference between income and expenses). 

 

Note: other columns may exist, depending on the type of view that is active.  

 

 

5.4 Transactions table 

 

 
 

Date 

This column shows the date of the accounting transaction. 
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Doc 

This column shows the number/name of the accounting document. 

 

Description 

In this column, enter free text to describe the accounting transaction. 

 

Income 

The incoming amount. 

 

Expenses 

The amount registered as expenses. 

 

Account 

This column shows account numbers defined on the Chart of accounts. 

 

Category 

This column shows categories defined on the Categories table.  

 

5.5 Create a Simple accounting file starting from an existing 

template 

The program includes pre-set templates and examples that can be altered on the basis of the 

user’s needs. 

To personalize the Account table and the Categories table: 

 Eliminate accounts/categories and/or add new accounts/categories 

 Change codes for accounts/categories 

 Change the description 

 Add or delete groupings   

To delete an account or a category, click on the row number and select the Edit menu, then 

Delete rows…command. 

 

To add a new account or category, insert a new row, key in the account/category code and 

description, and then finish it by adding the group that it belongs to. 

 

To alter the code for an account or a category, place the mouse on the desired account/category 

code to be changed, click, and key in the new code. Proceed to alter the description in the same 

way. 

To add or delete any sub-groups on the Categories table, it is necessary to understand the 

grouping and totaling system used by the program, explained in para. 3.4. 

 

5.6 Create a new Simple accounting file 

To create a new Simple accounting file starting from zero, select the New command from the 

File menu, then select the desired type of file and the New blank file template (without data, 

without chart of accounts). 

 Enter the basic accounting data and save it under a name with the Save as command from the 

File menu 

 Arrange the Accounts table 

 Arrange the Categories table 
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To input the Accounts table, proceed as follows: 

 Input Group 1 

 

 
 

 Input the account numbers (in the example 1000, 1010, and 1020) and complete this by 

giving a description and Gr1 number (it must be the same as the Group in which to total the 

accounts).  

 

 
 

 Input the opening balances 

 
 

To set up the Categories table, it is advised to proceed as follows: 

 Input the main groups 
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o Total Income – where all the Credit (income) transactions will be totaled 

o Total Expenses – where all the Debit (expenses) transactions will be totaled (negative) 

o Total – on this row, the difference of Income and Expenses are calculated.  

 

 Input the category code, the description and the Gr the account belongs to, which has to be to 

the same as the Group in which it will be totaled. 

 

 
 

 The categories from 4000 to 4200 are in Gr 4, the same as Group 4, which are added into the 

Total Income. 

 The categories 3000 to 3340 are in Gr 3, to the same as Group 3, which are added into the 

Total Expenses (negative). 

 The total of Income and Expenses are in Gr 00, the same as Group 00, where they will be 

added together (Total). 

 



124  S I M P L E  A C C O U N T I N G  

 

B A N A N A  A C C O U N T I N G  

5.7 Input transactions 

Example: 

The electricity, gas and water bills have been paid through the bank’s current account for the 

month of January. 

 

 
 

 After the date has been inserted, the document no. and the description, insert the amount in 

the Expenses column. 

 In the Account column enter the account from which the bills were paid and in the Category 

column, enter the category number that corresponds to the type of payment. 

 

5.7.1 Input cash withdrawal/deposit transfers 

To enter transfers between different accounts, it is necessary to insert in both Account and 

Category column the cash or cash equivalent account numbers involved in the transaction.  

 

Example: Cash withdrawal from post office current account. 

 

 
 

 After the date, the document number and description have been inserted, insert the amount in 

the Expenses column. 

 In the Account column, indicate the account the amount is taken from (in the example the 

account 1010, corresponding to the post office account), and in the Category column enter 

the account being paid into (in the example the account 1000, corresponding to the cash 

account). 

 

5.7.2 Input transactions with VAT/Sales tax 

To enter operations with VAT/Sales tax, first select a type of Simple accounting with VAT/Sales 

tax, and set up the VAT Code table (para. 3.16.2).  

 

The VAT/Sales tax account also has to be present on the Accounts Table or on the Categories 

Table: 
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 If it is present on the Accounts Table, the VAT/Sales tax due will be entered as an expense, 

whereas recoverable VAT/Sales tax will be entered as income.  

 If it is present on the Categories Table, the VAT/Sales tax due will be entered as income, 

whereas recoverable VAT/Sales tax will be entered as an expense. 

Example: 

The telephone bill for the month of February has an amount of 120.00 with 10% VAT/Sales tax 

included, and has been paid from the bank account. 

 

 
 

To complete the transaction, after entering the amount (usually the gross amount), the account 

and the category, key in the VAT code. 

 

5.7.3 View amounts in currency2 

To see the amounts in the second currency, refer to transactions with second currency in the 

Cash book chapter, explained in para. 4.7.1. 
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6 Double-entry accounting 

This is the type of accounting taught in accounting schools, used by accounting professionals and 

known to fiscal authorities all over the world. Double-entry accounting includes everything to 

manage an accounting conforming to international accounting standards: 

 Balance sheet and profit and loss statement  

 Journal 

 Account cards 

 VAT/Sales tax statements  

Double-entry accounting is mandatory for all companies or entities that need to submit a balance 

sheet and a profit and loss statement. 

 

 

6.1 Create a new accounting 

 

 
 

To create a new Double-entry accounting file, startup the program and from the New command 

(File menu) select one of the existing accounting types. 

Various types of Double-entry accounting 

 Double-entry accounting 

 Double-entry accounting with VAT/Sales tax. It is ideal for those who are subject to sales 

tax and need to present a VAT/Sales tax declaration. 

Once the desired type of accounting has been selected, input the basic data in the new file, save it 

using the Save as command from the File menu, then browse through to choose the desired 

folder and file name for the new Double-entry accounting file. Usually the file name is the same 

as the name of the business plus the current accounting year (e.g. Company name-2006.ac2). 

 

 

6.2 Accounts table 

To create a Chart of accounts, whether starting from an example or opening a new blank file, it is 

necessary to understand the structure of the Accounts table. 
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Group  

In this column, enter the codes for the Groups each line belongs to. The group cannot have an 

account number or a BClass number. 

 

Account 

In this column, enter the account code to be used for the accounting. If there is an account 

number, there cannot be a Group number as well.  

Description 

In this column, enter free text to describe the account or the group. 

 

BClass 

This column contains obligatory numeration, for all the accounts that the program will use, so as 

to define what type they belong to: 

 

DESCRIPTION BCLASS 

ASSETS 1 

LIABILITIES 2 

EXPENSES 3 

REVENUE 4 

OFF BALANCE SHEET ASSETS 5 

OFF BALANCE SHEET LIABILITIES 6 

 

If the BClass is missing from some accounts, then there will be differences and some results will 

no longer be reliable. 

 

Gr 

Enter the code of the Group to which the account refers. It has to be an already existing Group.  

 

Opening 

For each account, input the opening balance, which should correspond to the relative closing 

balance from the previous year. The assets amounts should be entered as a plus, whereas the 

liabilities amounts should be negative. The opening balances of the total assets and the total 

liabilities should be equal. 

 



128  D O U B L E - E N T R Y  A C C O U N T I N G  

B A N A N A  A C C O U N T I N G  

Balance 

This column shows the actual balance for each account including the opening balance and all the 

transactions made on the account. 

The Balance column cannot be altered since it is automatically calculated by the program. 

 

Note: it is also possible to make visible other columns in the various views or input new ones by 

using the Set up fields command from the Data menu. 

 

 

6.3 Create a Chart of accounts starting from an existing 

template 

The program has some pre-defined templates and examples that can be altered on the basis of the 

owner’s individual needs. 

 

 
 

In order to personalize the Chart of accounts: 

 Delete accounts and/or add some new accounts 

 Change the account codes 

 Change the description 

 Create sub-groups 

 Delete existing groupings 

 

To delete an account, click on the row number with the mouse and select the Delete rows 

command from the Edit menu. 

 

To add a new account, insert a new row, key in the account code, its description and complete it 

with its BClass and the group to which it belongs. 

 

To edit an account code, place the cursor on the account number to be changed and key in the 

new code. Do the same to alter the description. 

The sub-groups can be inserted when a more detailed Chart of accounts that will give more 

information about the accounting is needed. 
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Example: 

The user wants to create a new subgroup “Liquid assets” that groups the cash, bank, and post 

office accounts. 

 

 
 

To create the sub-group “Liquid assets”: 

 insert a few empty rows 

 in the Group column, key in the “100” code 

 complete it with the description and with Gr “1” 

 change the Gr for the 1000, 1010 and 1020 accounts to 100. 

 

 
 

If the Chart of accounts has some sub-groups that are no longer needed, it is possible to delete 

them. 

 

Example: 

The user wants to delete the sub-group “Total loans”. 

 



130  D O U B L E - E N T R Y  A C C O U N T I N G  

B A N A N A  A C C O U N T I N G  

 
 

To delete the sub-group “Total loans”, the user must delete row 22 and change the Gr for the 

2000 and 2400 accounts from 200 to 2. 

 

 
 

 

6.4 Create a new Chart of accounts  

To create a new accounting file starting from zero, chose the New command from the File menu, 

then select the desired type of file and the New blank file template (without data, without chart 

of accounts). 

 Input the basic accounting data and save it with a name 

 Go to the Accounts table 

 Insert the number of rows needed to structure the accounting plan 

To set up the Chart of accounts, it is advised to begin by entering the main groups: 
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 1 - Total Assets – where all the Assets are added up 

 2301 – Group in which the profit/loss pf the current year is being totalized. 

 2 - Total Liabilities – where all the Liabilities are added up 

 00 – Difference should be zero – if the amount is not = 0, then there is an imbalance. 

 3 - Total Expenses – where all the Expenses are added up 

 4 – Total Income – where all the Income is added up 

 02 - Profit (-) Loss (+) from Profit & Loss Statement) – where the Total expenses (in 

positive) are added to the Total income (as a negative). If the amount is negative, then there 

is a profit, if it is positive, there is a loss. The result of the current year is totalized in the 

group 2301 (in the Liabilities) to obtain the balance of the Balance sheet. 

 

 

Note: it is possible to insert accounts or group of accounts for the  

Off-balance Assets and Liabilities, external to the accounting or profit and cost centers. 

 

Proceed by entering the account codes, their descriptions, the BClass and the Gr they belong to 

(the same as the Group in which they need to be totaled).  

 

Example: 
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 The accounts from 1000 to 1090 are in Gr 1 (Group 1, which adds up the Total assets). 

 The accounts from 2000 to 2090 are in Gr 2 (Group 2, which adds up the Total liabilities). 

 The Total assets and Total liabilities are in Gr 00, equal to Group 00 “Difference should be 

0”. 
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 The accounts from 3000 to 3210 are in Gr 3 (Group 3, which adds up the Total expenses). 

 The accounts from 4000 to 4600 are in Gr 4 (Group 4, which adds up the Total revenue). 

 The Total expenses and Total revenue are in Gr 02, in the Group where they will be added up 

(Profit/Loss from Profit & Loss Statement). 

 The profit/loss from the Profit & Loss Statement has Gr 2301, equal to Group 2301, listed in 

the Liabilities. 

 

6.4.1 Structure of the Enhanced Balance sheet by groups  

In order to create automatically a Balance Sheet by groups, the chart of accounts needs to be 

configured with special codes that are to be entered in the Section column.  

 

The encoding is the following: 

 

* Title 1 To enter for the main headers 

** Title 2 To enter for the secondary headers 

1 Assets To enter in the title row Assets 

2 Liabilities   To enter in the title row Liabilities 

3 Expenses To enter in the title row Expenses 

4 Revenue To enter in the title row Revenue 

01 
Client’s 

Register 
To enter in the title row Client’s Register  

02 
Supplier’s 

Register 
To enter in the title row Supplier’s Register  

03 Cost Centers  To enter in the title row Cost Centers 

04 Profit Centers To enter in the title row Profit Centers 

#* Notes To enter in the title row Notes 

#X Hidden data 
To enter in the row from whereon the data have 

to be hidden  

 

 Enter a * on the same row as the title Balance Sheet  

 Enter 1 on the same row as the title Assets 

 Enter 2 on the same row as the title Liabilities. 
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 Enter a * on the same row as the title Profit/Loss Statement  

 Enter 3 on the same row as the title Expenses 

 Enter 4 on the same row as the title Revenue (Income). 

 

Attention: in case a chart of accounts with Expenses and Revenue mixed (with the calculation of 

the Gross Profit) is being used, insert a  “*” on the title row “Profit/Loss Statement” and only 

the number 4 on the row preceding the row containing the title “Expenses” or “Revenue”. 
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For the clients/suppliers register a new section is being defined, by entering an asterisk as usual.  

 

 Enter 01 on the same row as the title Clients register 

 Enter 02 on the same row as the title Suppliers register 

 

The amounts will be shown in the same way as for the Assets and the Liabilities.   

This encoding is also valid when the clients and suppliers are configured as cost centers.   

 

Example in case there is a clients/suppliers register in the chart of accounts.   
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In case there are cost or profit centers configured, enter the following elements 

 An asterisk for the section change 

 03 on the same row as the title Cost center 

 03 on the same row as the title Profit center 

 

The amounts will be shown as positive (in black) like the expenses and in red like the revenue. 
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6.5 Transactions table 

This is the table where the accounting transactions are inserted. It is characterized by various 

columns. 

 

 
 

Date 

In this column, enter the date of the transaction. 

 

Doc 
In this column, enter the number or name of the accounting document. 

 

Description 
In this column, enter free text to describe the transaction. 

 

Debit A/C 

In this column, enter the account to which the amount will be debited. 

 

Credit A/C 

In this column, enter the account to which the amount will be credited. 

 

Amount 

In this column, enter the amount of the transaction. This amount will be debited to the Debit A/C 

and credited to the Credit A/C. 

 

6.5.1 Accounting transactions 

Each time a new transaction is entered, the accounts are immediately updated. 

In the information window at the bottom of the screen, the accounts being used for the 

transaction are shown together with any possible errors in red and the account balance. 

 

6.5.2 Simple transactions  

Simple transactions are entered on a single row with one account debited to the Debit A/C and 

another credited to the Credit A/C for the same amount. 

 

Example:  

Withdrawal in cash from the Bank current account: 
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6.5.3 Compound transactions  

Compound transactions are input on more than one row because they affect more accounts. 

On each row, enter one account at a time using only the Debit A/C or the Credit A/C and the 

amount for a single account. 

All the rows have the same date and the same document number. What changes is the 

description, the Debit A/C, the Credit A/C and the amount. 

 

Note: until the whole transaction has been made, the program will keep signaling a difference. 

 

Example:  

Payment of various invoices using the bank current account. 

 

 
 

When using an accounting file with VAT/Sales tax, there are all the columns relating to 

VAT/Sales tax (para. 3.16 on VAT/Sales tax). For a multi-currency accounting, there are 

columns relating to Exchange rates (para. 7.1). 

The table columns can be sorted, viewed or suppressed (except the system columns). If needed, 

it is possible to insert new columns by selecting the View fields command from the Data menu. 

 

In the Cost Centers view, there are additional columns for entering cost and profit centers (para. 

3.17) 

 

 

6.6 Totals table 

The Totals table contains the groupings of the classes from the accounting plan (1 Assets, 2 

Liabilities, 3 Expenses, and 4 Revenue) with their relative balances constantly up-to-date. 
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This table is automatically created by the program and cannot be altered by the user (only the 

text in the Description column can be modified). It indicates whether there is a profit or a loss 

and whether there are accounting imbalances. 

 

6.7 VAT Codes table 

In an accounting with sales tax, the VAT Codes table is present which allows the program to 

automatically separate the VAT/Sales tax according to various percentages and to credit/debit it 

to the appropriate accounts (see para. 3.16.2). 

 

 

6.8 Accounting functions 

 

6.8.1 Balance by period 

In order to obtain a balance by period, the Enhanced balance sheet command, Account1 menu, 

needs to be activated. In the Period tab   the desired period can be entered, after which the 

program calculates and shows the Balance by period. For more details, see para. 6.8.4. 

 

6.8.2 Close current year 

Traditionally, to discover the profit, all the Expenses and Revenue accounts were returned to 

zero. Today the program automatically calculates the profit at any time, without having to close 

the accounting.  

 

6.8.3 Create New Year 

If from the Account2 menu, the Create New Year command is selected, a new accounting file 

will be created for the following year with the same Chart of accounts. The opening balances 

will be transferred from the closing balances from the previous year (Assets and Liabilities). 

 

A window opens where it is possible to specify how to allocate the profit or the loss simply by 

indicating the account or accounts number (for example, profit/loss brought forward…) and the 

amount to assign to each. 

 



140  D O U B L E - E N T R Y  A C C O U N T I N G  

B A N A N A  A C C O U N T I N G  

 
 

Carry forward account opening balances  

Indicate which accounts are required to have opening balances carried forward. Usually the 

balances on the Balance Sheet accounts, Off balance sheet accounts and cost centers are carried 

forward (when they are used to manage debtors/creditors). 

 

Allocation profit/loss  

Total to allocate 

The program will indicate the profit/loss that needs to be shared between various accounts. 

 

Accounts/Amounts 

Indicate to which account(s) the profit or loss should be shared with the relative amount. If three 

accounts are not sufficient, then it will be necessary to manually correct the amounts on the new 

accounting in the opening column.  

 

The program will show a warning message if there are any differences between the assets and 

liabilities totals. If there is a difference, it could be due to: 

 Profit/loss has not been allocated 

 During the previous year, there were differences/errors 

 The exchange rate differences were not entered.  

 

Complete the basic data in the new accounting file, check the opening balances and save the file 

with a new name. 

 

The program will even carry forward the final balances to the Previous view on the Accounts 

table (Previous column) of the New Year accounting. 
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6.8.4 Enhanced balance sheet 

This command is activated from the Account1 menu by selecting Enhanced balance sheet. A 

window for the default printing of the Enhanced balance sheet and Profit & loss statement opens. 

Grouping of the accounts takes place according to the content of the BClass column. A window 

with four tabs will show up: 

 
Base Tab 

 

 
 

Page header 

Rows 1 thru 4 

In this field, enter texts to use as headers when printing. 

 

Print cover page / Print date / Print page numbers 

The activated options will be shown in the print-out. 

Column header (Balance / Profit and Loss) 

The first two vertical fields refer to the Balance Sheet, the two second ones refer to the Profit and 

Loss Statement.   

 

Current year  

Insert the final date of the current accounting. 
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Previous year 

In this field, enter the final date of the previous year’s accounting. 

 

Print pages 

By selecting the appropriate cells, the different class pages (Assets, Liabilities, Expenses, 

Revenue, Off Balance Sheet Assets, and Off Balance Sheet Liabilities) and the front page will be 

printed. 

By selecting the "2 classes per page" option, the list of accounts will be printed with two classes 

on each page (e.g. assets and liabilities on one page, income (revenue) and expenses on another). 

This works when there is a fairly simple Chart of Accounts. 

 

Include in printout 

Decide what data should be included or excluded in the printout. 

 

Print, Preview, Cancel 

With these commands, one can access the printing configurations (preview, cancel the printing 

and launch the printing).   

Moreover, with the print button, one can save the file in different formats, exporting the file to 

Pdf, Html, MS Excel and Copy to Clipboard. 

 
Period Tab 
 

 
 

All 

By activating this option, the balance sheet for the entire accounting period is being calculated 

and shown.  

 

Period selected 

This option allows the user to obtain the balance sheet for a determined period, by inserting the 

start and the end date. When a specified period is inserted, the field of the current year, in the 

Base tab, is automatically updated.   
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Style Tab 

 

 
 

Use style 

There are different models of the Enhanced balance sheet provided. By selecting one, the user 

can obtain the Enhanced balance sheet of his choice.   

 

Style property 

For each style, the color of the fonts and the backgrounds can be defined.   

 

Value / Change... / Default 

These functions allow the user to change style or to restore the default style.   

 

Ignore line formatting 

If this function is activated, the formatting will not be maintained. 

 

Include accounts and groups excluded 

If this function is activated, also the excluded accounts and groups will be shown.   

 

Print error messages 

If this function is activated, the error messages will be printed.   

 

Zoom 
The display of the Balance sheet can be maximized or minimized.  

 

Page orientation 
This function makes it possible to change the orientation of the page (portrait, landscape). 
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Texts Tab 

This tab is used to alter the texts that the program uses as default headings for print-outs.  

 

 
 

Key 

By selecting a text from the list shown, it will then automatically appear in the cell as the key to 

edit.  

 

Value 

Input free text in this cell to alter the key.  

 

Modify 

Click on this button to confirm any alteration to the pre-set (default) text.  

 

Value=Key 

By clicking on this key, the Key text will be identical to the Value text. 
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Margins Tab 
 

 
 

Begin to print accounts 

Enter or alter the print margins in this field. 

 

Margins 

Enter the space between the page margins and the header or the footer. 
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Favorites Tab  

The functions of this tab allow the user to save models of different reports, so that manually 

changing and selecting options for each print-out is no longer needed. 

 

 
 

Use selected 
Allows the user to select the favorite that is to be used. 

Set as default 

Makes it possible to define the default favorite (the report model that will be charged during the 

next opening of the dialogue). 

Rename 
Allows the user to rename the favorite. 

Duplicate 
With this button, the user can duplicate a report model to have the possibility to modify the 

desired configurations and create a new report model: 

 Click on "Duplicate" 

 Enter the name of the new report in the window and confirm with OK  

 Select the options of your choice from the different tabs  

 With the preview, the selected configurations for the report are automatically being 

saved.  

New 

Allows the user to create a new report model. 
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Delete 
Allows the user to delete an existing report model. 

6.8.5 Enhanced balance sheet by groups  

This command (Accounts1 menu) automatically drafts the Enhanced balance sheet by groups. 

Contrary to the regular Enhanced balance sheet, the groups and sub-groups are being shown in 

detail. Moreover, the user can select one of the provided styles, customizing colors and thus 

obtain a balance sheet with a different structure and graphics.  There are two added tabs: 

Sections and Subdivision. Also, the Base tab distinguishes itself by some added printing options.  

 
Base Tab 

 

 
 

Page 

The rows Header 1, Header 2, Header 3, Header 4 are destined for the headers of the print-outs. 

 

Print cover page / Print date / Print page numbers 

By activating these options, the cover page, the date and the page numbers will be printed.   
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Column header (Balance/Profit and Loss) 

Enter the beginning date and the end date of the current year and the beginning date and the end 

date of the previous year. 

Show columns  

When these options are selected, the account numbers, percentages, previous year balances, the 

budget and foreign currency will be shown. 

 

Show rows 

When these options are selected, the accounts, the accounts with zero balance, the accounts with 

transactions and the groups with zero balance will be shown.   

 
Sections Tab 

 

 
 

Print sections 

In the box, all the sections of the chart of accounts that have been marked with the provided 

encoding are being shown. 

 

Start on new page 

If the user wants a section of the Balance sheet to be printed on a new page, click on the section 

and check the box.   

 

 



D O U B L E - E N T R Y  A C C O U N T I N G   149 

 

B A N A N A  A C C O U N T I N G  

Print section title 

Allows the user to print the title of the section. 

 

Alternate text for section title 

To change the text of the different sections (for example, revenue with income), just select the 

desired title and enter the alternate text in the box.   

 

For those who use a chart of accounts with the lists of expenses and revenue mixed, the report 

can be personalized with the following functions: 

 Group for % calculation 

 Show group up to level 

 Row options 

By clicking on the main groups (Assets, Liabilities, Expenses, Revenue, etc) the following 

options are being activated: 

 

Group for % calculation 

The percentages of the totals are being calculated according to the selected group or subgroup. If 

no option is being selected, the percentages are calculated according to the total of the main 

groups. 

 

Show group up to level 

By selecting a level from the list, the data will be displayed up to the chosen level.   

 

Row options 

By clicking on this option, a window appears in which different configurations can be selected 

related to the rows.    
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Text parameters 

The parameters that have been chosen for the section can also be introduced in the form of codes 

to be entered in this area. It is also possible to enter parameters that have not been considered in 

the above mentioned options: the corresponding codes for the different parameters that can be 

used, are available on our web site www.banana.ch.   
 

http://www.banana.ch/
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Subdivision tab 

 

 
 

None 

The entire period is being shown. 

 

Subdivision by period 

This function makes it possible to display the dates of the selected period per day, month, bi-

monthly, per quarter, per 4 months, per semester or per year. The selected period will be shown 

in the column headers.   

 

Only segment 

The data related to the selected segment are being shown.   

 

Create periods for the whole year  
When the accounting period is not the same as the solar year, but when the user still wants to see 

all months, this function needs to be activated.   

 

Totals column 

This function creates a Totals column for the selected periods in the Profit / Loss Statement and 

in the Totals view of the Accounting reports command (Account1 menu). 

 

Max number of divisions 

The default maximum number of periods is 36. In particular cases, if the user would want to 

obtain special and very detailed statistics over a long time span, this value can be changed 

manually. A very high maximum number of periods can slow down the program.  
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Subdivision by segment 

The data related to the selected segment are being shown. In the column headers the selected 

segment is present.  

 

Totals column 

When this option is being activated, the totals for the selected segment will be obtained 

  
 

Period Tab / Style Tab/ Text Tab / Margins Tab / Favorites Tab 

These sections are the same as those of the Enhanced balance sheet, already described in 

paragraph 6.8.4. 

 

 

6.8.6 How to obtain reports 

The reports are presentations of all the accounts that can satisfy different requirements, 

according to the configurations selected by the user. The most common reports are those grouped 

by class, by period, by segment or by external groupings.   

To calculate the reports, click on the Accounting reports command of the “Account1” menu: a 

window opens, of which the different tabs have already been described in paragraph 3.11.8. 

 

Different types of reports can be obtained:   

 

 As on Accounts table – all accounts will be shown as on the chart of accounts  

 Accounts by class – when there is a chart of accounts with different subgroups, the Balance 

by classes makes it possible to calculate and display rapidly all the accounts according to 

their BClass number, with the groupings and the descriptions of the Totals table.    

 External accounting reports – makes it possible to have external groupings that are outside of 

the accounting.  For more information, consult the following web page:  

http://www.banana.ch/cms/en/accounting_report. 

 

All report types can be saved in Pdf, MS Excel, Html, Xml and Txt format, by means of the 

Export rows command (Data menu). 

 

 

 
 

 

 

 

 

 

 

http://www.banana.ch/cms/en/accounting_report
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7 Multi-currency accounting 

Multi-currency accounting is a form of double-entry accounting that manages accounts and 

transactions in different currencies. 

Compared to double-entry accounting, multi-currency accounting presents: 

 The Exchange rates table 

 The basic currency that must be indicated in the File and accounting properties (File menu) 

 The exchange rate profit/loss accounts that should be indicated in the Foreign currency tab 

(see also 3.5.8) from the File and accounting properties command (File menu).  

Multi-currency accounting conforms to international accounting standards. 

 

Multi-currency accounting is a professional instrument created for advanced users. For correct 

use, it is necessary to read the “Practical Guide to Multi-currency Accounting” (available on 

www.banana.ch) thoroughly. 

 

There are two types of multi-currency accounting: 

 Double-entry with foreign currencies  

 Double-entry with foreign currencies and VAT/Sales tax  

 

7.1 Foreign exchange rate table 

This table is present only for accounting with multi-currencies. The symbols for the various 

currencies are defined on this table. Each currency has its own symbol and exchange rate to the 

basic accounting currency. 

 

 
 

Date 

This is the date when the exchange rate was used. The program only uses exchange rates with no 

date. The date column is only used for historical exchange rates. 

 

Warning: if a date is entered, the exchange rate will not be used by the program and an error 

message will be received declaring: currency symbol does not exist. 

 

Currency Ref. 

This column shows the symbol/currency to which the exchange rate refers.  

 

Currency 

This column shows the foreign currency symbol. 

 

Text 

This column shows text to identify the currency being used. 

 

http://www.banana.ch/redirect/banana50.php?&dlang=enu&cmd=manuals
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Fixed 

If there is a fixed exchange rate, enter Yes in this column. In this case, the exchange rate used 

will not be the opening one but the rate specified in the Exchange Rate column. 

 

Mult. 

The multiplier is usually 1, 100 or 1000 and is used to obtain the effective exchange rate. The 

multiplier is used for currencies which have a very low unit value in order to avoid having to 

insert exchange rates with many zeros. The multiplier can also be negative (-1). In this case, the 

program will use an inverted exchange rate or else it will act as if the currencies inserted in the 

Currency and Reference Currency columns had actually been inverted (exchange rate = 

1/exchange rate). 

 

Warning: do not alter the multiplier once there are already transactions in the same currency. 

The program will signal a transaction error due to erroneous exchange rates. 

 

Exchange rate 

This column shows the actual exchange rate for the currency with respect to the reference 

currency. 

 

Opening Exchange rate 

This is the exchange rate at the moment the accounting is opened. It is used to convert the 

opening amount of the currency into the opening amount of the accounting basic currency. Insert 

it only once when the exchange rates are input because the program will then pick it up 

automatically at the beginning of a new year. 

 

Minimum 

This column shows the minimum exchange rate accepted. If a lesser exchange rate is used during 

the entry, there will be a warning. 

 

Maximum 

This column shows the maximum exchange rate accepted. If a greater exchange rate is used 

during the entry, there will be a warning. 

 

Decimal Points 

This column shows the number of decimal points to be used when rounding the amounts in 

currency2. 

 

 

7.2 Operating multi-currency accounting 

 

In the transactions table, there are specific columns for multi-currency: 

 

 



M U L T I - C U R R E N C Y  A C C O U N T I N G   155 

 

B A N A N A  A C C O U N T I N G  

Currency Amount 

Enter the currency amount. 

 

Currency 

Enter the currency symbol for the Currency Amount. During the insertion of the transaction, if 

this field is empty, the program will use the currency from the debit or credit account. 

 

Exchange Rate 

This is the specific exchange rate for this transaction. During the insertion of the transaction, if 

this field is empty, the program will automatically use the exchange rate in the exchange rate 

table.  

 

Amount (basic currency) 

This is the amount converted in the basic currency. During the insertion, if the currency amount 

is modified, the program will automatically calculate the amount in basic currency. 

 

The values automatically completed by the program (Currency, Exchange Rate, Amount in basic 

currency) can be modified at any time. 

 

7.2.1 Transactions with foreign currency  

When transactions on accounts are inserted in foreign currency, there can be three types of 

transaction:  

 Transactions between two accounts in basic currency; 

in this case, it is a normal transaction of double-entry accounting 

 Transactions between an account in basic currency and another in foreign currency 

 Transactions between two accounts with different currencies, neither of them the basic 

currency 

 

7.2.2 Transactions between one account in basic currency and one in a 

foreign currency 

Before beginning to make accounting transactions on the Transactions table, it is necessary to 

update the Exchange Rate column in the Foreign exchange rate table with the day’s exchange 

rate. If this operation is not carried out, the program will automatically pick up the exchange rate 

that it finds on the Foreign exchange rate table. Proceed as follows: 

 

 
 

 Enter the debit account, the credit account and the amount in foreign currency  

The program will automatically calculate the amount in basic currency on the basis of the 

exchange rate on the Foreign exchange rate table. 
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Obtaining an exchange rate when the amounts in basic currency and in the foreign 

currency are already known 

When the amounts in foreign currency and basic currency are already known (for example when 

the amount in basic currency is given on the bank statement), proceed as follows to 

automatically calculate the exchange rate: 

 Enter the debit account, credit account and the amounts 

 Go to the Amount USD column (basic currency) 

 

 
 

Note: it is normal that an error message shows up since the exchange rate is missing. 

 

 Hit the F6 key to calculate the exchange rate. 

 

 
 

Using an exchange rate different from the one present on the Foreign exchange rate table 

 Enter the debit account, credit account and the amount in foreign currency 

 Go to the Exchange Rate column and key in the desired exchange rate. 

 Hit the F6 key in order to calculate the amount in basic currency. 

 

7.2.3 Transactions between two accounts with different currencies, neither 

of them the basic currency 

It is not possible to have, in only one row, a transaction between two accounts with different 

currencies; neither of them being the basic currency. To enter these operations, it is necessary to 

make a transaction on more than one row. 
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 On the first line, enter the debit account and the amount in foreign currency (CHF in the 

example) 

 On the second line, enter the credit account and the second amount in foreign currency (EUR 

in the example). At this point, the program will signal a difference since the amounts 

automatically calculated in basic currency are different. 

 Then copy the amount in basic currency from the preceding line (USD 890.32 in the 

example) and hit the F6 key to calculate the exchange rate. At this point, the transaction is 

finished and there are no accounting imbalances. 

 

Note: it is also possible to enter these operations by passing through a second account (transfer 

account) instead of leaving the debit and credit accounts blank. 

 

7.2.4 Enter exchange rate differences 

When there are accounts in foreign currency, there are always exchange rate differences because 

the amount in foreign currency is converted into domestic currency and, since the exchange rates 

alter, differences are created. When an accounting file is closed, update the Exchange rates table 

with the official closure exchange rates, which will then become the opening rates for the 

following year. 

 

In order to have a correct accounting, enter the exchange rate differences using the Create 

transaction for exchange rate variation command from the Account2 menu (in the window 

that opens, indicate the date of the transactions for the exchange rate differences, usually 

December 31
st
 of the current year). 

By clicking OK, the program will automatically create the requested transactions on the 

Transactions table, using as accounts those indicated in the File and accounting properties 

command (File menu), Foreign currency tab. 

 

 
 

Entering these exchange rate differences transactions only alters the balance of the basic 

currency account. 

The balance on the foreign currency account remains unchanged. 
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7.2.5 Closing a multi-currency accounting 

To close a multi-currency accounting file: 

 Update the Foreign exchange rate table by inputting, in the Exchange rate column, the rates 

for the closure that will become the opening exchange rates for the New Year;  

 Enter the exchange rate and rounding differences, otherwise the differences will be carried 

forward to the New Year). If, subsequently, more transactions are made, check whether there 

are accounting differences again. 
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8 Exchange rate history 

Exchange rate history is a file that simply shows the Exchange Rate table where all the exchange 

rates relevant to specific dates are filed: 

 

To create an Exchange rate history, proceed as follows:  

 From the File menu click on the New command  

 Select Other as the group 

 Select  Exchange rate history as the file 

 

 
 

Once the data pertinent to the exchange rates has been inserted, save the file with a name using 

the Save As command (File menu). 
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9 Instructions for labels 

The labels application is a simple table where it is possible to insert addresses or other data in 

order to print labels.  

A list of addresses can be made from scratch, setting up all the fields needed to create a made-to-

measure database. 

Even label printing can be personalized. 

The advantage of this program is that it lets the user print labels very rapidly, and, if the text is 

too long, the program will use a smaller font when printing so that the text remains contained 

within the label.  

 

9.1 Create a new label file 

By selecting the New command from the File menu, three different files can be selected from the 

label group: 

 

 
 

Labels with progressive fields (1,2,3…) 

New fields are created (field 1, 2, etc.) where it is mandatory to insert the label header (ex. name, 

address, country, telephone, etc.).  

 

Address labels 

Fields corresponding to an already defined address database are being created.  

 

Labels to be composed 

It is an empty database that allows the user to alter all existing fields or create new ones through 

the Set up fields command from the Data menu (for more information on how to set up fields see 

para. 3.8.15).   

 

9.2 The Print label 1… and Print label 2… commands 

By using the Print label 1… and Print label 2… commands from the Label1 menu, the user 

will have access to the definition and the printing of labels. 

There are two separate commands because two print set-ups can be saved for labels; otherwise 

the two commands are the same. 
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When one of these two commands is activated in order to print labels, a window with three tabs 

opens:  

 
Print tab 

 

 
 

First label starting position 

Decide on the position of the first label. For example, if “1” is entered in the horizontal and 

vertical fields, it refers to the upper left-hand corner of the page. 

 

Nr. copies of each label 

The value of “1”, in this field, means only one copy of each label is wanted. 

 

Selected lines only 

If this cell is activated, only the selected rows will be printed. 

 

Warn if text exceeds label 

If the text goes beyond the margins for the label, the program will warn the user by sending an 

error message if this cell is activated. 
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Page settings tab 

 

 
 

Page 

Margins 

Input the size in centimeters; if no size is entered, the margin sizes will be zero. 

 

Number of horizontal labels 

Input the number of horizontal labels there are on the page. 

 

Number of vertical labels 

Input the number of vertical labels there are on the page. 

 

Print landscape 

The page will be printed horizontally if this cell is activated. 

 

Label 

Margins 

It is possible to input a margin for each label; the values for the label margins must be input in 

centimeters. 

 

Center text horizontally 

Select this option to horizontally center the text for each label in the cell. 

 

Center text vertically 

Select this option to vertically center the text for each label in the cell. 

 

Font size 

Base size 
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This field shows the default font size. 

 

Reduce to fit, but not less than 

The program calculates the maximum font size possible for a given label, starting from 14 points 

all the way down to 8 points. The calculation is made taking into account both the height and 

width of the label. If a label has a line that is too long (or has too many rows) to be printed, then 

an error message will appear in the message window. Even if it is incomplete, the label will still 

be printed. 

 

Note: the printers will not print on the whole surface of a page because they need minimum 

margins. The program tries to adapt the single labels to the margin values required by the 

printer.  

 
Compose label tab 

 

 
 

The window shows three distinct areas: Field list to select the fields, Divider list to select the 

dividers and View labels to view the result of the field and divider composition. 

 

Field list 

This is a list of all label possible fields; to select a field, it is possible to work in two ways: 

 Double-click on a field name. 

 Click on an field name from the list and hit the Add Field key 

The field selected will be shown in the View labels area. 

 

Divider list 

Between two fields there must be a divider. Choose from the following: 

 

<space> This serves to separate two fields set on the same line, e.g. 

Name<space>Last name 

<return> This must always be entered at the end of each line for the labels, e.g. 
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Courtesy <return>. If the previous field contains no data, the label row 

will not be printed. 

 

<always return>

  

Select this divider to print the label row even if the field preceding it 

contains no data, e.g., Courtesy <always return>: if the cell corresponding 

to Courtesy is blank, then a blank row will be printed. 

 

 

View labels 

This shows how the fields and dividers will show up on the printed label: each row in this area 

corresponds to a row on the label. Naturally, the symbols used here for the dividers <space> < 

return> <always return> are not printed. 

 

Delete last field  

This button deletes the last divider or field input. 

 

Delete all  

This button deletes the whole label structure. 

 

The user can display the labels in preview and print them with the buttons in the lower part of the 

window.   

 

Note: When new fields that must be shown in the label print-outs are added, the print format 

must be changed. 

 

9.2.1 Print merge 

In order to use the Print merge command in Word using the data from the Banana Labels 

application, export the data by selecting Export Rows in txt… from the Export Rows command 

on the Data menu, making sure that the Column header option is selected in the Export Rows 

in txt window.  

In this way not only the data is exported, but the headers as well which can then be read by the 

program when printing a series of letters.
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10 Error Messages  

 

Error messages can either show up immediately or be listed in a message window. The table 

name and the row number where the error occurred will be shown as well as the text. Double-

click on the error to be immediately transferred to the row that caused the error. 

If the user clicks on the Don’t warn button, immediate presentation will be deactivated. To 

reactivate it, use the Warning messages command in the Window menu. 

The text of the messages and an explanation of their meaning are listed in the electronic version 

of the manual. 
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11 Short-cut Keys 

The short-cut keys can be used to carry out various functions without using the mouse. The main 

functions are for moving around, editing and selecting: 

 

Moving Keys Description 

Esc  Cancel operation by closing open window. 

Backspace Delete preceding character by moving cursor backwards. 

Delete Delete subsequent characters. 

PgUp Scroll up one screen page. 

PgDown Scroll down one screen page. 

Right Arrow Scroll towards right. 

Left Arrow Scroll towards left. 

Up Arrow Scroll up. 

Down Arrow Scroll down. 

Home Scroll to beginning of row. 

End Scroll to end of row. 

Ctrl+Home Scroll to top-left angle of table. 

Ctrl+End Scroll to bottom-right angle of table. 

Ctrl+Down Scroll to end of table. 

Ctrl+Up Scroll to top of table. 

Enter Advance one cell, confirming keyed-in text.  

Ctrl+F4 Close active window. 

Alt+F4 Exit program. 

Tab 
Has the same function as Enter but only when the window for editing has 

not been opened (Shift+F2). 

 

Moving Keys Description 

Shift+Tab  Return to previous cell, confirming keyed-in text. 

Ctrl+Tab Go from one window to another according to their order 

Ctrl+F6  Next window.  

Ctrl+PgDown Next table. 

Ctrl+PgUp  Previous table. 

Alt+PgDown  Next view. 

Alt+PgUp  Previous view. 

F3  Find next command in Data menu. 

Shift+F3  Find command in Data menu. 

F5  Scroll to desired row by keying in row number in active window. 

Shift+F5  Go to original row command on Data menu. 

 

Editing Keys Description 

Ctrl+Enter Add row below position of cursor. 

Ctrl+Ins Copy selected text. 

Shift+Ins Paste copied text in selected cell.  

Ctrl+Delete Delete content of selected cells.  

F2 Edit content of cell. 

Shift+F2 Open window to enter longer texts. 

F4 Copy previous cell from same column.  

Shift+F4 Copy previous cell and advance. 
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F6 
This key executes different functions depending on the column the user is 

working on. The functions are explained in the information window. 

Shift+F6 Add row and copy transaction from previous row.  

F9 Perform simple recheck. 

Shift+F9  Perform global recheck. 

 

Selection Keys Description 

Shift+PgUp Select column moving upwards, page by page. 

Shift+PgDown Select column moving downwards, page by page. 

Shift+Right Select row to right. 

Shift+Left Select row to left. 

Shift+Up Select upper column. 

Shift+Down Select lower column. 

Shift+ Home Select back to start of row. 

Shift+End Select forward to end of row. 

Shift+Ctrl+ Home Select back to top of table. 

Shift+Ctrl+ End Select forward to end of table. 

Ctrl+Space Select entire column. 

Shift+Space Select entire row. 

Ctrl+Space and 

Shift+Space 
Select entire table. 

 

Other Keys Description 

Ctrl+N New file. 

Ctrl+S Save. 

Ctrl+O Open. 

Ctrl+P Print. 

Ctrl+Z Undo operation. 

Ctrl+Y Redo operation. 

Ctrl+Delete Delete text from the cursor point to the end of the cell. 
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